aboutsummaryrefslogtreecommitdiff
path: root/games/openlierox/Makefile
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2017-08-12 13:15:47 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2017-08-12 13:15:47 +0000
commitf24d02b366c98c91bd78556a71b89033447ab790 (patch)
tree44f75c5aad123b85af254aaf647f4a5a58024ccb /games/openlierox/Makefile
parent139215faecfa67eccc3b756cade5df87f2f6362e (diff)
downloadports-f24d02b366c98c91bd78556a71b89033447ab790.tar.gz
ports-f24d02b366c98c91bd78556a71b89033447ab790.zip
Notes
Diffstat (limited to 'games/openlierox/Makefile')
-rw-r--r--games/openlierox/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/games/openlierox/Makefile b/games/openlierox/Makefile
index 7519736c5fb3..7fb2a643897a 100644
--- a/games/openlierox/Makefile
+++ b/games/openlierox/Makefile
@@ -3,7 +3,7 @@
PORTNAME= openlierox
DISTVERSION= 0.58_rc3
-PORTREVISION= 11
+PORTREVISION= 12
PORTEPOCH= 1
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/OpenLieroX%20${DISTVERSION:C/_/%20/}
@@ -19,7 +19,6 @@ LIB_DEPENDS= libgd.so:graphics/gd \
USES= tar:bzip2 cmake openal:al,alut pkgconfig
USE_SDL= sdl image
USE_GNOME= libxml2
-USE_GCC= any # too many gcc'isms
CFLAGS+= -I${LOCALBASE}/include
CXXFLAGS+= -I${LOCALBASE}/include
@@ -60,6 +59,9 @@ post-patch:
s|/usr/local|${LOCALBASE}|' ${WRKSRC}/CMakeOlxCommon.cmake
@${FIND} ${WRKSRC} \( -name "*.cpp" -o -name "*.h" -o -name "*.cc" \) -print0 | ${XARGS} -0 -n1 \
${REINPLACE_CMD} -e '/include.*curl\/types.h/ d'
+# Convert the static_assert calls to regular, C++ ones.
+ @${FIND} ${WRKSRC} \( -name "*.cpp" -o -name "*.h" -o -name "*.cc" \) -print0 | ${XARGS} -0 -n1 \
+ ${REINPLACE_CMD} -E -e 's/static_assert\((.+), (.+)\)/static_assert\(\1, "\2"\)/g'
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/openlierox ${STAGEDIR}${PREFIX}/bin/