aboutsummaryrefslogtreecommitdiff
path: root/games/openlierox
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2018-06-27 14:48:58 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2018-06-27 14:48:58 +0000
commit3480f7cb8864627ac418a1707bf79ac23109255c (patch)
treeb44bdfd01789d274f8e2763e4d5f299dd4473448 /games/openlierox
parent22436547544a2ec0f1f9fab69ad2ee8ce2165bf6 (diff)
downloadports-3480f7cb8864627ac418a1707bf79ac23109255c.tar.gz
ports-3480f7cb8864627ac418a1707bf79ac23109255c.zip
- Switch to USES=localbase
- Tweak depends - Switch to options helpers - Fix build with clang 6
Notes
Notes: svn path=/head/; revision=473445
Diffstat (limited to 'games/openlierox')
-rw-r--r--games/openlierox/Makefile28
-rw-r--r--games/openlierox/files/patch-src_common_sex.cpp11
2 files changed, 22 insertions, 17 deletions
diff --git a/games/openlierox/Makefile b/games/openlierox/Makefile
index 273852707eff..1b84b42438f8 100644
--- a/games/openlierox/Makefile
+++ b/games/openlierox/Makefile
@@ -12,17 +12,14 @@ DISTNAME= OpenLieroX_${DISTVERSION}.src
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Extremely addictive realtime worms shoot-em-up
-LIB_DEPENDS= libgd.so:graphics/gd \
- libboost_signals.so:devel/boost-libs \
+LIB_DEPENDS= libboost_signals.so:devel/boost-libs \
libcurl.so:ftp/curl
-USES= tar:bzip2 cmake openal:al,alut pkgconfig
+USES= tar:bzip2 cmake localbase pkgconfig
USE_SDL= sdl image
USE_GNOME= libxml2
-CFLAGS+= -I${LOCALBASE}/include
-CXXFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+CXXFLAGS+= -Wno-c++11-narrowing
CMAKE_ARGS= -DHAWKNL_BUILTIN=YES \
-DLIBZIP_BUILTIN=YES \
@@ -43,16 +40,11 @@ PLIST_FILES= bin/openlierox \
share/pixmaps/OpenLieroX.svg
OPTIONS_DEFINE= DEDICATED_ONLY DOCS
-DEDICATED_ONLY_DESC=Build dedicated server only
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MDEDICATED_ONLY}
-CMAKE_ARGS+= -DDEDICATED_ONLY=YES
-.else
-USE_XORG+= x11
-USE_SDL+= mixer
-.endif
+DEDICATED_ONLY_DESC= Build dedicated server only
+DEDICATED_ONLY_CMAKE_BOOL= DEDICATED_ONLY
+DEDICATED_ONLY_USE_OFF= XORG=x11 SDL=mixer
+DEDICATED_ONLY_LIB_DEPENDS_OFF= libgd.so:graphics/gd
post-patch:
@${REINPLACE_CMD} -e 's|EXEC_PROGRAM.*OLXVER)|SET(OLXVER "${DISTVERSION}")|; \
@@ -69,7 +61,9 @@ do-install:
${STAGEDIR}${PREFIX}/share/applications/
${INSTALL_DATA} ${WRKSRC}/share/OpenLieroX.svg \
${STAGEDIR}${PREFIX}/share/pixmaps/
- cd ${WRKSRC}/share/gamedir && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/
- cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}/
+ @cd ${WRKSRC}/share/gamedir && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/
+
+do-install-DOCS-on:
+ @cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}/
.include <bsd.port.mk>
diff --git a/games/openlierox/files/patch-src_common_sex.cpp b/games/openlierox/files/patch-src_common_sex.cpp
new file mode 100644
index 000000000000..6f23fd3af157
--- /dev/null
+++ b/games/openlierox/files/patch-src_common_sex.cpp
@@ -0,0 +1,11 @@
+--- src/common/sex.cpp.orig 2018-06-25 13:54:25 UTC
++++ src/common/sex.cpp
+@@ -242,7 +242,7 @@ static Table list[] = {
+ {his, SZ(his)}, {dongadj, SZ(dongadj)},
+ {dong, SZ(dong)}, {intoher, SZ(intoher)},
+ {twatadj, SZ(twatadj)}, {twat, SZ(twat)},
+- {(const char **)NULL, (short)NULL},
++ {(const char **)NULL, 0},
+ };
+
+ std::string sex(short wraplen) {