aboutsummaryrefslogtreecommitdiff
path: root/games/openlierox
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-03-10 04:24:37 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-03-10 04:24:37 +0000
commit928ac34ec2d6067aef734966aa12b34d97bc080b (patch)
treee598dc0c354ff04cbcfb1ab41fdaabc9f9af93a8 /games/openlierox
parentd676e8607f49fd9aa3b9d85cea53338346085aa5 (diff)
downloadports-928ac34ec2d6067aef734966aa12b34d97bc080b.tar.gz
ports-928ac34ec2d6067aef734966aa12b34d97bc080b.zip
- Update to 0.59_beta10
Notes
Notes: svn path=/head/; revision=313801
Diffstat (limited to 'games/openlierox')
-rw-r--r--games/openlierox/Makefile25
-rw-r--r--games/openlierox/distinfo4
-rw-r--r--games/openlierox/files/patch-src-common-Debug_DumpCallstack.cpp20
-rw-r--r--games/openlierox/files/patch-src-common-SystemFunctions.cpp15
-rw-r--r--games/openlierox/files/patch-src-gusanos-blitters-mmx.h15
-rw-r--r--games/openlierox/files/patch-src-gusanos-objects_list.h10
6 files changed, 63 insertions, 26 deletions
diff --git a/games/openlierox/Makefile b/games/openlierox/Makefile
index 72a12fcebaa3..414cdc72365e 100644
--- a/games/openlierox/Makefile
+++ b/games/openlierox/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= openlierox
-DISTVERSION= 0.59_beta9
-PORTREVISION= 3
+DISTVERSION= 0.59_beta10
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/OpenLieroX%20${DISTVERSION:C/_/%20/}
DISTNAME= OpenLieroX_${DISTVERSION}.src
@@ -21,6 +20,7 @@ USE_SDL= sdl image
USE_GNOME= libxml2
MAKE_JOBS_SAFE= yes
USE_OPENAL= yes
+USE_GCC= 4.6+
CFLAGS+= -I${LOCALBASE}/include
CXXFLAGS+= -I${LOCALBASE}/include
@@ -30,7 +30,8 @@ USE_CMAKE= yes
CMAKE_ARGS= -DHAWKNL_BUILTIN=YES \
-DLIBZIP_BUILTIN=YES \
-DBREAKPAD=NO \
- -DSYSTEM_DATA_DIR="${DATADIR}"
+ -DSYSTEM_DATA_DIR="${DATADIR}" \
+ -DHASBFD=NO
WRKSRC= ${WRKDIR}/OpenLieroX
@@ -42,11 +43,16 @@ PLIST_FILES= bin/openlierox \
share/pixmaps/OpenLieroX.svg
PLIST_DIRSTRY= share/applications
-OPTIONS= DEDICATED_ONLY "Build dedicated server only" off
+OPTIONS_DEFINE= DEDICATED_ONLY DOCS
+DEDICATED_ONLY_DESC=Build dedicated server only
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_DEDICATED_ONLY)
+.if ${OSVERSION} < 700000
+IGNORE= does not build on 7.x
+.endif
+
+.if ${PORT_OPTIONS:MDEDICATED_ONLY}
BROKEN= does not build
CMAKE_ARGS+= -DDEDICATED_ONLY=YES
.else
@@ -55,7 +61,8 @@ USE_SDL+= mixer
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|-mt||; s|EXEC_PROGRAM.*OLXVER)|SET(OLXVER "${DISTVERSION}")|; \
+ @${REINPLACE_CMD} -e 's|boost_signals-mt|boost_signals boost_system|; \
+ s|EXEC_PROGRAM.*OLXVER)|SET(OLXVER "${DISTVERSION}")|; \
s|/usr/local|${LOCALBASE}|' ${WRKSRC}/CMakeOlxCommon.cmake
@${FIND} ${WRKSRC} \( -name "*.cpp" -o -name "*.h" -o -name "*.cc" \) -print0 | ${XARGS} -0 -n1 \
${REINPLACE_CMD} -e '/include.*curl\/types.h/ d'
@@ -71,9 +78,9 @@ do-install:
${MKDIR} ${DATADIR}
cd ${WRKSRC}/share/gamedir && ${COPYTREE_SHARE} . ${DATADIR}/
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${DOCSDIR}/
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/openlierox/distinfo b/games/openlierox/distinfo
index 5c2fcedb4c70..e2e407d0addd 100644
--- a/games/openlierox/distinfo
+++ b/games/openlierox/distinfo
@@ -1,2 +1,2 @@
-SHA256 (OpenLieroX_0.59_beta9.src.tar.bz2) = a5c05cca11f44d22d3f9af832c13dd55a9a0309e9f80a0e6b5d2bcb9fca160ac
-SIZE (OpenLieroX_0.59_beta9.src.tar.bz2) = 100913507
+SHA256 (OpenLieroX_0.59_beta10.src.tar.bz2) = 5f4bcc83c7f90fae716820ac9c4c6ee266c143abc55ce6b9efd0603b7c1d057c
+SIZE (OpenLieroX_0.59_beta10.src.tar.bz2) = 103956181
diff --git a/games/openlierox/files/patch-src-common-Debug_DumpCallstack.cpp b/games/openlierox/files/patch-src-common-Debug_DumpCallstack.cpp
new file mode 100644
index 000000000000..28d423e31dde
--- /dev/null
+++ b/games/openlierox/files/patch-src-common-Debug_DumpCallstack.cpp
@@ -0,0 +1,20 @@
+--- src/common/Debug_DumpCallstack.cpp.orig 2012-04-17 04:26:14.000000000 +0400
++++ src/common/Debug_DumpCallstack.cpp 2012-12-14 23:19:15.525963503 +0400
+@@ -11,6 +11,8 @@
+ #include "util/macros.h"
+ #include <vector>
+ #include <string>
++#include <cstdio>
++#include <cstdlib>
+
+ #ifndef HAVE_EXECINFO
+ # if defined(__linux__)
+@@ -25,8 +27,6 @@
+ #if HAVE_EXECINFO
+
+ #include <execinfo.h>
+-#include <stdio.h>
+-#include <stdlib.h>
+
+ #if HASBFD
+
diff --git a/games/openlierox/files/patch-src-common-SystemFunctions.cpp b/games/openlierox/files/patch-src-common-SystemFunctions.cpp
new file mode 100644
index 000000000000..2d5c5c92aa89
--- /dev/null
+++ b/games/openlierox/files/patch-src-common-SystemFunctions.cpp
@@ -0,0 +1,15 @@
+--- src/common/SystemFunctions.cpp.orig 2012-04-17 04:26:14.000000000 +0400
++++ src/common/SystemFunctions.cpp 2012-12-14 23:18:03.318932050 +0400
+@@ -63,8 +63,10 @@
+ #if defined(__APPLE__) && defined(MAC_OS_X_VERSION_10_6) && MAC_OS_X_VERSION_MIN_REQUIRED >= MAC_OS_X_VERSION_10_6
+ #define HAVE_PTHREAD_NAME
+ // glibc 2.12 introduced this
+-#elif __GLIBC_PREREQ(2,12)
+-#define HAVE_PTHREAD_NAME
++#elif defined(__GLIBC_PREREQ)
++# if __GLIBC_PREREQ(2,12)
++# define HAVE_PTHREAD_NAME
++# endif
+ #endif
+ #endif
+
diff --git a/games/openlierox/files/patch-src-gusanos-blitters-mmx.h b/games/openlierox/files/patch-src-gusanos-blitters-mmx.h
deleted file mode 100644
index af5ab854371a..000000000000
--- a/games/openlierox/files/patch-src-gusanos-blitters-mmx.h
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/gusanos/blitters/mmx.h.orig 2010-02-17 19:59:26.000000000 +0300
-+++ src/gusanos/blitters/mmx.h 2012-03-10 07:56:06.901704744 +0400
-@@ -207,12 +207,4 @@
- #error "MMX capability only available on GCC!"
- #endif
-
--#ifndef always_inline
--#if defined(__GNUC__) && (__GNUC__ > 3 || __GNUC__ == 3 && __GNUC_MINOR__ > 0)
--# define always_inline __attribute__((always_inline)) inline
--#else
--# define always_inline inline
--#endif
--#endif
--
- #endif //MMX_H
diff --git a/games/openlierox/files/patch-src-gusanos-objects_list.h b/games/openlierox/files/patch-src-gusanos-objects_list.h
new file mode 100644
index 000000000000..e5a170c07b93
--- /dev/null
+++ b/games/openlierox/files/patch-src-gusanos-objects_list.h
@@ -0,0 +1,10 @@
+--- src/gusanos/objects_list.h.orig 2012-12-14 23:03:07.488932193 +0400
++++ src/gusanos/objects_list.h 2012-12-14 23:06:22.329933269 +0400
+@@ -4,6 +4,7 @@
+ //#include "game/CGameObject.h"
+ #include <list>
+ #include <vector>
++#include <cstring>
+
+ static const int RENDER_LAYERS_AMMOUNT = 10;
+ static const int COLLISION_LAYERS_AMMOUNT = 10;