aboutsummaryrefslogtreecommitdiff
path: root/games/openmortal
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-10-31 13:15:39 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-10-31 13:15:39 +0000
commit2ba7749b7e0d55ef38679252c8a8dc3ccf4b4227 (patch)
treeef0794e86da93b2aa1863d3c4cad12ab0ab9adc3 /games/openmortal
parent99a80b56c5366657fd2e8d95250e075eb0838d54 (diff)
downloadports-2ba7749b7e0d55ef38679252c8a8dc3ccf4b4227.tar.gz
ports-2ba7749b7e0d55ef38679252c8a8dc3ccf4b4227.zip
- Unbreak
- Fix build with gcc 4.2 - Pass maintainership to submitter - Use SF macro PR: 117702 Submitted by: Dmitry Marakasov <amdmi3@amdmi3.ru> Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=202459
Diffstat (limited to 'games/openmortal')
-rw-r--r--games/openmortal/Makefile14
-rw-r--r--games/openmortal/files/patch-src-OnlineChat.cpp11
2 files changed, 14 insertions, 11 deletions
diff --git a/games/openmortal/Makefile b/games/openmortal/Makefile
index a717e01c5cb5..f06f88c3d814 100644
--- a/games/openmortal/Makefile
+++ b/games/openmortal/Makefile
@@ -9,10 +9,9 @@ PORTNAME= openmortal
PORTVERSION= 0.7
PORTREVISION= 2
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= amdmi3@amdmi3.ru
COMMENT= A parody of the once popular coin-up fighting game, Mortal Kombat
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
@@ -25,12 +24,5 @@ GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-post-patch:
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Broken with gcc 4.2
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/openmortal/files/patch-src-OnlineChat.cpp b/games/openmortal/files/patch-src-OnlineChat.cpp
new file mode 100644
index 000000000000..41d155653bde
--- /dev/null
+++ b/games/openmortal/files/patch-src-OnlineChat.cpp
@@ -0,0 +1,11 @@
+--- src/OnlineChat.cpp.orig 2004-04-29 16:32:35.000000000 +0000
++++ src/OnlineChat.cpp 2007-10-31 02:54:07.000000000 +0000
+@@ -56,7 +56,7 @@
+ class CChallengeMenu: public Menu
+ {
+ public:
+- CChallengeMenu::CChallengeMenu( std::string a_sChallenger )
++ CChallengeMenu( std::string a_sChallenger )
+ : Menu( "You have been challenged!" ),
+ m_sChallenger( a_sChallenger )
+ {