aboutsummaryrefslogtreecommitdiff
path: root/games/openmortal
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-04-20 14:01:06 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-04-20 14:01:06 +0000
commitdf841b86f9accc4dbac6f2ef99efd0a8bec4925c (patch)
treef24b2b06148ed2969fe6006b53255614bfb800dc /games/openmortal
parent17b42fa78f5c9208eef84fc6e5e56c3b7e1676ad (diff)
downloadports-df841b86f9accc4dbac6f2ef99efd0a8bec4925c.tar.gz
ports-df841b86f9accc4dbac6f2ef99efd0a8bec4925c.zip
- Open Mortal is a parody of the once popular coin-up fighting
game, Mortal Kombat
Notes
Notes: svn path=/head/; revision=107718
Diffstat (limited to 'games/openmortal')
-rw-r--r--games/openmortal/Makefile35
-rw-r--r--games/openmortal/distinfo2
-rw-r--r--games/openmortal/pkg-descr7
-rw-r--r--games/openmortal/pkg-plist195
4 files changed, 239 insertions, 0 deletions
diff --git a/games/openmortal/Makefile b/games/openmortal/Makefile
new file mode 100644
index 000000000000..1572eb455e62
--- /dev/null
+++ b/games/openmortal/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: openmortal
+# Date created: 20 Apr 2004
+# Whom: krion@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= openmortal
+PORTVERSION= 0.6
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= krion@FreeBSD.org
+COMMENT= A parody of the once popular coin-up fighting game, Mortal Kombat
+
+LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
+
+USE_BZIP2= yes
+USE_PERL5= yes
+USE_REINPLACE= yes
+USE_SDL= mixer image sdl net
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+post-patch:
+ @${REINPLACE_CMD} -e 's|sdl-config|sdl11-config|g' ${WRKSRC}/configure
+ @${FIND} ${WRKSRC}/src -name "*.cpp" | ${XARGS} \
+ ${REINPLACE_CMD} -e 's|SDL/|SDL11/|g' -e 's|<malloc.h>|<stdlib.h>|g'
+ @${FIND} ${WRKSRC} -name "*.h" | ${XARGS} \
+ ${REINPLACE_CMD} -e 's|SDL/|SDL11/|g' -e 's|<malloc.h>|<stdlib.h>|g'
+
+.include <bsd.port.mk>
diff --git a/games/openmortal/distinfo b/games/openmortal/distinfo
new file mode 100644
index 000000000000..d86accc18f1a
--- /dev/null
+++ b/games/openmortal/distinfo
@@ -0,0 +1,2 @@
+MD5 (openmortal-0.6.tar.bz2) = 50ff59fdfc1a7679abbc25a9b892e2d0
+SIZE (openmortal-0.6.tar.bz2) = 50548986
diff --git a/games/openmortal/pkg-descr b/games/openmortal/pkg-descr
new file mode 100644
index 000000000000..f2e4100336d1
--- /dev/null
+++ b/games/openmortal/pkg-descr
@@ -0,0 +1,7 @@
+Open Mortal is a parody of the once popular coin-up fighting
+game, Mortal Kombat, for Windows and Linux. It is currently
+playable, has 16 playable characters, some more in the making.
+New characters can be added, so players can be their own Open
+Mortal actor.
+
+WWW: http://apocalypse.rulez.org/~upi/Mortal/
diff --git a/games/openmortal/pkg-plist b/games/openmortal/pkg-plist
new file mode 100644
index 000000000000..269a9b3bdd27
--- /dev/null
+++ b/games/openmortal/pkg-plist
@@ -0,0 +1,195 @@
+bin/openmortal
+%%DATADIR%%/characters/Agent.dat
+%%DATADIR%%/characters/Agent.dat.txt
+%%DATADIR%%/characters/Agent.full.png
+%%DATADIR%%/characters/Agent.icon.png
+%%DATADIR%%/characters/Agent.jpg
+%%DATADIR%%/characters/Agent.pl
+%%DATADIR%%/characters/Ambrus.dat
+%%DATADIR%%/characters/Ambrus.dat.txt
+%%DATADIR%%/characters/Ambrus.full.png
+%%DATADIR%%/characters/Ambrus.icon.png
+%%DATADIR%%/characters/Ambrus.jpg
+%%DATADIR%%/characters/Ambrus.pl
+%%DATADIR%%/characters/Bence.dat
+%%DATADIR%%/characters/Bence.dat.txt
+%%DATADIR%%/characters/Bence.full.png
+%%DATADIR%%/characters/Bence.icon.png
+%%DATADIR%%/characters/Bence.jpg
+%%DATADIR%%/characters/Bence.pl
+%%DATADIR%%/characters/Cumi.dat
+%%DATADIR%%/characters/Cumi.dat.txt
+%%DATADIR%%/characters/Cumi.full.png
+%%DATADIR%%/characters/Cumi.icon.png
+%%DATADIR%%/characters/Cumi.jpg
+%%DATADIR%%/characters/Cumi.pl
+%%DATADIR%%/characters/Dani.dat
+%%DATADIR%%/characters/Dani.dat.txt
+%%DATADIR%%/characters/Dani.full.png
+%%DATADIR%%/characters/Dani.icon.png
+%%DATADIR%%/characters/Dani.jpg
+%%DATADIR%%/characters/Dani.pl
+%%DATADIR%%/characters/Descant.dat
+%%DATADIR%%/characters/Descant.dat.txt
+%%DATADIR%%/characters/Descant.full.png
+%%DATADIR%%/characters/Descant.icon.png
+%%DATADIR%%/characters/Descant.jpg
+%%DATADIR%%/characters/Descant.pl
+%%DATADIR%%/characters/Grizli.dat
+%%DATADIR%%/characters/Grizli.dat.txt
+%%DATADIR%%/characters/Grizli.full.png
+%%DATADIR%%/characters/Grizli.icon.png
+%%DATADIR%%/characters/Grizli.jpg
+%%DATADIR%%/characters/Grizli.pl
+%%DATADIR%%/characters/Jacint.dat
+%%DATADIR%%/characters/Jacint.dat.txt
+%%DATADIR%%/characters/Jacint.icon.png
+%%DATADIR%%/characters/Jacint.pl
+%%DATADIR%%/characters/Jozsi.dat
+%%DATADIR%%/characters/Jozsi.dat.txt
+%%DATADIR%%/characters/Jozsi.icon.png
+%%DATADIR%%/characters/Jozsi.pl
+%%DATADIR%%/characters/Kinga.dat
+%%DATADIR%%/characters/Kinga.dat.txt
+%%DATADIR%%/characters/Kinga.full.png
+%%DATADIR%%/characters/Kinga.icon.png
+%%DATADIR%%/characters/Kinga.jpg
+%%DATADIR%%/characters/Kinga.pl
+%%DATADIR%%/characters/Macy.dat
+%%DATADIR%%/characters/Macy.dat.txt
+%%DATADIR%%/characters/Macy.full.png
+%%DATADIR%%/characters/Macy.icon.png
+%%DATADIR%%/characters/Macy.jpg
+%%DATADIR%%/characters/Macy.pl
+%%DATADIR%%/characters/Mrsmith.dat
+%%DATADIR%%/characters/Mrsmith.dat.txt
+%%DATADIR%%/characters/Mrsmith.icon.png
+%%DATADIR%%/characters/Mrsmith.pl
+%%DATADIR%%/characters/STAFF.DAT
+%%DATADIR%%/characters/Sirpi.dat
+%%DATADIR%%/characters/Sirpi.dat.txt
+%%DATADIR%%/characters/Sirpi.full.png
+%%DATADIR%%/characters/Sirpi.icon.png
+%%DATADIR%%/characters/Sirpi.jpg
+%%DATADIR%%/characters/Sirpi.pl
+%%DATADIR%%/characters/Sleepy.dat
+%%DATADIR%%/characters/Sleepy.dat.txt
+%%DATADIR%%/characters/Sleepy.icon.png
+%%DATADIR%%/characters/Sleepy.pl
+%%DATADIR%%/characters/UPi.dat
+%%DATADIR%%/characters/UPi.dat.txt
+%%DATADIR%%/characters/UPi.full.png
+%%DATADIR%%/characters/UPi.icon.png
+%%DATADIR%%/characters/UPi.jpg
+%%DATADIR%%/characters/UPi.pl
+%%DATADIR%%/characters/Ulmar.dat
+%%DATADIR%%/characters/Ulmar.dat.txt
+%%DATADIR%%/characters/Ulmar.full.png
+%%DATADIR%%/characters/Ulmar.icon.png
+%%DATADIR%%/characters/Ulmar.jpg
+%%DATADIR%%/characters/Ulmar.pl
+%%DATADIR%%/characters/Zoli.dat
+%%DATADIR%%/characters/Zoli.dat.txt
+%%DATADIR%%/characters/Zoli.full.png
+%%DATADIR%%/characters/Zoli.icon.png
+%%DATADIR%%/characters/Zoli.jpg
+%%DATADIR%%/characters/Zoli.pl
+%%DATADIR%%/fonts/CreditsFont2.png
+%%DATADIR%%/fonts/aardvark.ttf
+%%DATADIR%%/fonts/bradybun.ttf
+%%DATADIR%%/fonts/brandybun3.png
+%%DATADIR%%/fonts/deadgrit.ttf
+%%DATADIR%%/fonts/glossyfont.png
+%%DATADIR%%/fonts/thin.ttf
+%%DATADIR%%/gfx/Credits.png
+%%DATADIR%%/gfx/Doodads.png
+%%DATADIR%%/gfx/FighterStats.png
+%%DATADIR%%/gfx/Foot.png
+%%DATADIR%%/gfx/GameOver.png
+%%DATADIR%%/gfx/Mortal.png
+%%DATADIR%%/gfx/PlayerSelect.png
+%%DATADIR%%/gfx/PlayerSelect_chat.png
+%%DATADIR%%/gfx/Story1.png
+%%DATADIR%%/gfx/Story2.png
+%%DATADIR%%/gfx/icon.bmp
+%%DATADIR%%/gfx/icon.png
+%%DATADIR%%/gfx/level1.png
+%%DATADIR%%/gfx/level10.desc
+%%DATADIR%%/gfx/level10_ground.png
+%%DATADIR%%/gfx/level10_hill.png
+%%DATADIR%%/gfx/level10_sky.png
+%%DATADIR%%/gfx/level2.png
+%%DATADIR%%/gfx/level3.desc
+%%DATADIR%%/gfx/level3_city.png
+%%DATADIR%%/gfx/level3_ground.png
+%%DATADIR%%/gfx/level3_moon.png
+%%DATADIR%%/gfx/level3_sky.png
+%%DATADIR%%/gfx/level4.desc
+%%DATADIR%%/gfx/level4_earth.png
+%%DATADIR%%/gfx/level4_ground.png
+%%DATADIR%%/gfx/level4_moon.png
+%%DATADIR%%/gfx/level4_nebula.png
+%%DATADIR%%/gfx/level4_rock.png
+%%DATADIR%%/gfx/level4_saturn.png
+%%DATADIR%%/gfx/level5.png
+%%DATADIR%%/gfx/level6.png
+%%DATADIR%%/gfx/level7.desc
+%%DATADIR%%/gfx/level7_cumi.png
+%%DATADIR%%/gfx/level7_ground1.png
+%%DATADIR%%/gfx/level7_ground2.png
+%%DATADIR%%/gfx/level7_ground3.png
+%%DATADIR%%/gfx/level7_ground4.png
+%%DATADIR%%/gfx/level7_logo.png
+%%DATADIR%%/gfx/level7_sky.png
+%%DATADIR%%/gfx/level7_upi.png
+%%DATADIR%%/gfx/level8.png
+%%DATADIR%%/gfx/level9.png
+%%DATADIR%%/script/Backend.pl
+%%DATADIR%%/script/CollectStats.pl
+%%DATADIR%%/script/CollectedStats.pl
+%%DATADIR%%/script/Collision.pl
+%%DATADIR%%/script/Damage.pl
+%%DATADIR%%/script/DataHelper.pl
+%%DATADIR%%/script/Doodad.pl
+%%DATADIR%%/script/Fighter.pl
+%%DATADIR%%/script/FighterStats.pl
+%%DATADIR%%/script/Keys.pl
+%%DATADIR%%/script/PlayerInput.pl
+%%DATADIR%%/script/QuickSave.pl
+%%DATADIR%%/script/Rewind.pl
+%%DATADIR%%/script/State.pl
+%%DATADIR%%/script/Translate.pl
+%%DATADIR%%/sound/2nd_pm.s3m
+%%DATADIR%%/sound/alarm.voc
+%%DATADIR%%/sound/aroooga.voc
+%%DATADIR%%/sound/ba_gooock.voc
+%%DATADIR%%/sound/bowling.voc
+%%DATADIR%%/sound/car_start.voc
+%%DATADIR%%/sound/crashhh.voc
+%%DATADIR%%/sound/ding.voc
+%%DATADIR%%/sound/evil_laughter.voc
+%%DATADIR%%/sound/machine_start.voc
+%%DATADIR%%/sound/magic.voc
+%%DATADIR%%/sound/moo2.voc
+%%DATADIR%%/sound/pop.voc
+%%DATADIR%%/sound/pop.wav
+%%DATADIR%%/sound/ride.mod
+%%DATADIR%%/sound/shades_rollup.voc
+%%DATADIR%%/sound/slip4.voc
+%%DATADIR%%/sound/splat.wav
+%%DATADIR%%/sound/splat2.voc
+%%DATADIR%%/sound/splat_.voc
+%%DATADIR%%/sound/strange_button.voc
+%%DATADIR%%/sound/strange_quack.voc
+%%DATADIR%%/sound/thump.voc
+%%DATADIR%%/sound/thump.wav
+%%DATADIR%%/sound/thump3.voc
+%%DATADIR%%/sound/woman_screams.voc
+%%DATADIR%%/sound/woosh.voc
+%%DATADIR%%/sound/woosh.wav
+@dirrm %%DATADIR%%/sound
+@dirrm %%DATADIR%%/script
+@dirrm %%DATADIR%%/gfx
+@dirrm %%DATADIR%%/fonts
+@dirrm %%DATADIR%%/characters
+@dirrm %%DATADIR%%