aboutsummaryrefslogtreecommitdiff
path: root/games/openmsx
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-11-04 19:17:44 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-11-04 19:17:44 +0000
commit0373c2b6547206760bd15041ccd62edc7b538e87 (patch)
treee7ce53ef917b92d4c97799c304802b9af72f641d /games/openmsx
parentb0752d9f661e50faaff44bc1122eef360e1246a4 (diff)
downloadports-0373c2b6547206760bd15041ccd62edc7b538e87.tar.gz
ports-0373c2b6547206760bd15041ccd62edc7b538e87.zip
Add new port games/openmsx:
OpenMSX is free alternative music for OpenTTD game engine. WWW: http://dev.openttdcoop.org/projects/openmsx PR: ports/151916 Submitted by: Ilya A. Arhipov <admin at gorodkirov.ru>
Notes
Notes: svn path=/head/; revision=264090
Diffstat (limited to 'games/openmsx')
-rw-r--r--games/openmsx/Makefile29
-rw-r--r--games/openmsx/distinfo2
-rw-r--r--games/openmsx/pkg-descr3
-rw-r--r--games/openmsx/pkg-plist37
4 files changed, 71 insertions, 0 deletions
diff --git a/games/openmsx/Makefile b/games/openmsx/Makefile
new file mode 100644
index 000000000000..0a79abfbfc56
--- /dev/null
+++ b/games/openmsx/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: openmsx
+# Date created: 2010-11-04
+# Whom: Ilya A. Arhipov
+#
+# $FreeBSD$
+#
+
+PORTNAME= openmsx
+PORTVERSION= 0.3.1
+CATEGORIES= games
+MASTER_SITES= http://ftp.snt.utwente.nl/pub/games/openttd/binaries/extra/openmsx/${PORTVERSION}/ \
+ http://gb.binaries.openttd.org/binaries/extra/openmsx/${PORTVERSION}/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-all
+
+MAINTAINER= micro@heavennet.ru
+COMMENT= Free alternative music for OpenTTD game engine
+
+USE_ZIP= yes
+NO_BUILD= yes
+
+post-extract:
+ @${FIND} ${WRKDIR}/openmsx-${PORTVERSION} -type f -name "*.txt" -exec ${MV} {} {}-msx \;
+
+do-install:
+ ${MKDIR} ${PREFIX}/share/openttd/gm
+ ${INSTALL_DATA} ${WRKDIR}/openmsx-${PORTVERSION}/* \
+ ${PREFIX}/share/openttd/gm
+
+.include <bsd.port.mk>
diff --git a/games/openmsx/distinfo b/games/openmsx/distinfo
new file mode 100644
index 000000000000..a564f0782927
--- /dev/null
+++ b/games/openmsx/distinfo
@@ -0,0 +1,2 @@
+SHA256 (openmsx-0.3.1-all.zip) = 92e293ae89f13ad679f43185e83fb81fb8cad47fe63f4af3d3d9f955130460f5
+SIZE (openmsx-0.3.1-all.zip) = 136981
diff --git a/games/openmsx/pkg-descr b/games/openmsx/pkg-descr
new file mode 100644
index 000000000000..439ff827ec07
--- /dev/null
+++ b/games/openmsx/pkg-descr
@@ -0,0 +1,3 @@
+OpenMSX is free alternative music for OpenTTD game engine.
+
+WWW: http://dev.openttdcoop.org/projects/openmsx
diff --git a/games/openmsx/pkg-plist b/games/openmsx/pkg-plist
new file mode 100644
index 000000000000..a06fcac3944d
--- /dev/null
+++ b/games/openmsx/pkg-plist
@@ -0,0 +1,37 @@
+share/openttd/gm/5432gone_redfarn.mid
+share/openttd/gm/be_sharp_bw_redfarn.mid
+share/openttd/gm/big_man_boogie_redfarn.mid
+share/openttd/gm/boogi_marabi_redfarn.mid
+share/openttd/gm/busy_schedule.mid
+share/openttd/gm/careless_perc_redfarn.mid
+share/openttd/gm/changelog.txt-msx
+share/openttd/gm/chemistry_lab.mid
+share/openttd/gm/chuggachugga.mid
+share/openttd/gm/city_blues_redfarn.mid
+share/openttd/gm/coconut_run2.mid
+share/openttd/gm/flying_scotsman.mid
+share/openttd/gm/harp_harmony.mid
+share/openttd/gm/license.txt-msx
+share/openttd/gm/linns_basket.mid
+share/openttd/gm/midnight_snow_run.mid
+share/openttd/gm/mighty_giant_run.mid
+share/openttd/gm/modern_motion.mid
+share/openttd/gm/moo_redfarn.mid
+share/openttd/gm/mosey_along_redfarn.mid
+share/openttd/gm/no_work_song_redfarn.mid
+share/openttd/gm/openmsx.obm
+share/openttd/gm/readme.txt-msx
+share/openttd/gm/relax_song.mid
+share/openttd/gm/run_for_your_life.mid
+share/openttd/gm/say_what_redfarn.mid
+share/openttd/gm/slow_neasy_redfarn.mid
+share/openttd/gm/the_fast_route.mid
+share/openttd/gm/the_hobo_redfarn.mid
+share/openttd/gm/train_filled_with_cash.mid
+share/openttd/gm/ttsong_iii_imuh3.mid
+share/openttd/gm/ttsong_iv_imuh3.mid
+share/openttd/gm/tttheme2.mid
+share/openttd/gm/ultimate_run.mid
+share/openttd/gm/wood_whistles.mid
+@dirrmtry share/openttd/gm
+@dirrmtry share/openttd