aboutsummaryrefslogtreecommitdiff
path: root/games/openra
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-04-06 19:31:13 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-04-06 19:31:13 +0000
commit2f32996239a84b2ef06dd0562bfb80e77e03a053 (patch)
tree09368beac56e4f7b438f43acdf21c6ef206f0446 /games/openra
parentb60cc5a8e043b7f4ea9c241de45771b89fa08fa1 (diff)
downloadports-2f32996239a84b2ef06dd0562bfb80e77e03a053.tar.gz
ports-2f32996239a84b2ef06dd0562bfb80e77e03a053.zip
games/openra: drop non-unit tests
Checking style and mod data is only useful upstream.
Notes
Notes: svn path=/head/; revision=530922
Diffstat (limited to 'games/openra')
-rw-r--r--games/openra/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/games/openra/Makefile b/games/openra/Makefile
index 2c003161263e..c35c25ac5ac0 100644
--- a/games/openra/Makefile
+++ b/games/openra/Makefile
@@ -55,11 +55,6 @@ INSTALL_TARGET= install install-man-page \
install-linux-mime install-linux-shortcuts
PORTDATA= *
-OPTIONS_DEFINE= TEST
-
-TEST_MAKE_ENV= HOME="${WRKDIR}"
-TEST_ALL_TARGET=test
-
post-patch:
${REINPLACE_CMD} \
-e 's/ -verbosity:m//' \
@@ -71,4 +66,9 @@ post-patch:
${WRKSRC}/thirdparty/Eluant.dll.config.in \
>${WRKSRC}/Eluant.dll.config
+do-test:
+ @(cd ${TEST_WRKSRC} && mono \
+ ${NUGET_PACKAGEDIR}/NUnit.ConsoleRunner/tools/nunit3-console.exe \
+ --noresult OpenRA.Test.nunit)
+
.include <bsd.port.mk>