aboutsummaryrefslogtreecommitdiff
path: root/games/openra
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-01-30 21:38:18 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-01-30 21:38:18 +0000
commit810632df12b21013919ed14a41fcb17c5662dc1a (patch)
tree2d18fe51a0622a694d25d899245ba2107d95cbab /games/openra
parent6244f44401d3d33a6de6eded5bc44d0589915d13 (diff)
downloadports-810632df12b21013919ed14a41fcb17c5662dc1a.tar.gz
ports-810632df12b21013919ed14a41fcb17c5662dc1a.zip
games/openra: de-duplicate dllmap in *.config files
SharpFont.dll.config already has os="freebsd" line but not os="dragonfly". Due to symlinks this can lead to <?xml version="1.0" encoding="utf-8" ?> <configuration> <dllmap dll="freetype6" os="linux" target="libfreetype.so.6" /> <dllmap dll="freetype6" os="freebsd" target="libfreetype.so.6" /> <dllmap dll="freetype6" os="freebsd" target="libfreetype.so.6" /> <dllmap dll="freetype6" os="freebsd" target="libfreetype.so.6" /> <dllmap dll="freetype6" os="freebsd" target="libfreetype.so.6" /> <dllmap dll="freetype6" os="osx" target="/Library/Frameworks/Mono.framework/Libraries/libfreetype.6.dylib" /> <dllmap dll="freetype6" os="freebsd" target="libfreetype.so.6" /> </configuration>
Notes
Notes: svn path=/head/; revision=460439
Diffstat (limited to 'games/openra')
-rw-r--r--games/openra/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/games/openra/Makefile b/games/openra/Makefile
index a4deb3f8265a..4c89749f491a 100644
--- a/games/openra/Makefile
+++ b/games/openra/Makefile
@@ -70,7 +70,7 @@ post-patch:
${REINPLACE_CMD} -e '/[[:<:]]get[[:blank:]]/d' \
${WRKSRC}/thirdparty/fetch-thirdparty-deps.sh
${FIND} -L ${WRKSRC}/thirdparty -name '*.config*' -exec ${REINPLACE_CMD} \
- -i '.bak.os' -e '/linux/{ p; s//${OPSYS:tl}/; }' {} +
+ -i '.bak.os' -e '/${OPSYS:tl}/d; /linux/{ p; s//${OPSYS:tl}/; }' {} +
${SED} 's/@LIBLUA51@/liblua-${LUA_VER}.so/' \
${WRKSRC}/thirdparty/Eluant.dll.config.in \
>${WRKSRC}/Eluant.dll.config