aboutsummaryrefslogtreecommitdiff
path: root/games/opensurge
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-03-11 05:04:29 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-03-11 05:04:29 +0000
commita505818518173aa0db780f30e117927ff9400768 (patch)
treef2a9de93c43176c217f9e887eca484bf91822550 /games/opensurge
parent62cf632cfa4cba8d6d200648f89e230524e2327a (diff)
downloadports-a505818518173aa0db780f30e117927ff9400768.tar.gz
ports-a505818518173aa0db780f30e117927ff9400768.zip
Open Surge is an open source retro-style 2D sidescroller inspired by
old-school games. Join Surge, Neon and Charge and save the world from the evil Gimacian the Dark! WWW: http://opensnc.sourceforge.net/ PR: ports/182515 Submitted by: nemysis (self) Reviewed by: Horia Racoviceanu <horia at racoviceanu.com>
Notes
Notes: svn path=/head/; revision=347840
Diffstat (limited to 'games/opensurge')
-rw-r--r--games/opensurge/Makefile87
-rw-r--r--games/opensurge/Makefile.svn_rev2
-rw-r--r--games/opensurge/distinfo4
-rw-r--r--games/opensurge/files/opensurge.in7
-rw-r--r--games/opensurge/files/pkg-message.in20
-rw-r--r--games/opensurge/pkg-descr5
-rw-r--r--games/opensurge/pkg-plist11
7 files changed, 136 insertions, 0 deletions
diff --git a/games/opensurge/Makefile b/games/opensurge/Makefile
new file mode 100644
index 000000000000..530985ff489b
--- /dev/null
+++ b/games/opensurge/Makefile
@@ -0,0 +1,87 @@
+# Created by: Rusmir Dusko <nemysis@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= opensurge
+PORTVERSION= 0.1.r${SVN_REV}
+CATEGORIES= games
+MASTER_SITES= http://www.ime.usp.br/~alemart/opensurge_nightly/ \
+ SF/nemysisfreebsdp/${CATEGORIES}/${PORTNAME}/
+DISTFILES= ${PORTNAME}-src-build${SVN_REV}${EXTRACT_SUFX} \
+ ${PORTNAME}-mods-${MODS_VER}${EXTRACT_SUFX}
+
+MAINTAINER= nemysis@FreeBSD.org
+COMMENT= Game based on the Sonic the Hedgehog universe
+
+LICENSE= GPLv2 CCbyNCSA3
+LICENSE_COMB= dual
+LICENSE_NAME_CCbyNCSA3=Attribution-NonCommercial-ShareAlike 3.0 Unported
+LICENSE_FILE= ${WRKSRC}/license.txt
+LICENSE_FILE_CCbyNCSA3=${WRKSRC}/licenses/CC-BY-SA-3.0.txt
+LICENSE_PERMS_CCbyNCSA3=dist-mirror pkg-mirror auto-accept
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libaldmb.a:${PORTSDIR}/audio/dumb-allegro \
+ ${LOCALBASE}/include/alfont.h:${PORTSDIR}/x11-fonts/alfont \
+ alureplay:${PORTSDIR}/audio/alure
+LIB_DEPENDS= liballeg.so:${PORTSDIR}/devel/allegro \
+ libogg.so:${PORTSDIR}/audio/libogg \
+ libvorbis.so:${PORTSDIR}/audio/libvorbis
+RUN_DEPENDS= ${LOCALBASE}/lib/libaldmb.a:${PORTSDIR}/audio/dumb-allegro
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-src-build${SVN_REV}
+
+USES= cmake dos2unix openal:soft
+DOS2UNIX_GLOB= *.bg *.brk *.grp *.inc *.lev *.lng *.obj *.qst *.spr *.txt
+USE_GCC= yes
+
+PORTDOCS= readme.html
+
+OPTIONS_DEFINE= DOCS
+
+SUB_FILES= ${PORTNAME} pkg-message
+
+INSTALLS_ICONS= yes
+ICON_SIZES= 16x16 32x32 48x48 64x64 72x72 96x96 128x128 256x256
+
+DESKTOP_ENTRIES="Open Surge" "" "${PORTNAME}" \
+ "${PORTNAME}" "Game;ArcadeGame;" ""
+
+.include "Makefile.svn_rev"
+
+post-extract-script:
+ @(cd ${WRKDIR}/opensurge-mods ; ${COPYTREE_SHARE} . ${WRKSRC})
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/share/opensurge|${DATADIR}|' \
+ -e 's|/usr/bin|${PREFIX}/bin|' \
+ ${WRKSRC}/src/core/global.h
+ @${REINPLACE_CMD} -e 's|/usr/bin|${PREFIX}/bin|' \
+ ${WRKSRC}/src/core/osspec.c
+
+ @${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share|; \
+ s|/usr/bin|${PREFIX}/bin|; \
+ s|license.txt readme.html||; \
+ s|licenses||' \
+ ${WRKSRC}/CMakeLists.txt
+ @${REINPLACE_CMD} -i '' '/Copying executable to/,+2d' \
+ ${WRKSRC}/CMakeLists.txt
+
+post-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+
+.for s in ${ICON_SIZES}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps/
+ @${INSTALL_DATA} ${WRKSRC}/src/misc/${PORTNAME}_${s}.png \
+ ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
+.endfor
+ ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+ @cd ${STAGEDIR}${PREFIX} && ${FIND} ${DATADIR_REL} \
+ -type f >> ${TMPPLIST} && \
+ ${FIND} ${DATADIR_REL} -type d -o -type l | ${SORT} -r | \
+ ${SED} 's|^|@dirrm |' >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/games/opensurge/Makefile.svn_rev b/games/opensurge/Makefile.svn_rev
new file mode 100644
index 000000000000..e4970ae1b53c
--- /dev/null
+++ b/games/opensurge/Makefile.svn_rev
@@ -0,0 +1,2 @@
+SVN_REV= 763
+MODS_VER= 20140311
diff --git a/games/opensurge/distinfo b/games/opensurge/distinfo
new file mode 100644
index 000000000000..8dc65f3fe539
--- /dev/null
+++ b/games/opensurge/distinfo
@@ -0,0 +1,4 @@
+SHA256 (opensurge-src-build763.tar.gz) = c23f993e4f771ef5f981b1d0145541979c4d274363647b33b68b91e37252303d
+SIZE (opensurge-src-build763.tar.gz) = 17577000
+SHA256 (opensurge-mods-20140311.tar.gz) = dfddfeef98e16e62b80d49b82ec47d7831246337879f1c8995a182785d6ffd9c
+SIZE (opensurge-mods-20140311.tar.gz) = 99755567
diff --git a/games/opensurge/files/opensurge.in b/games/opensurge/files/opensurge.in
new file mode 100644
index 000000000000..29391c47e6a8
--- /dev/null
+++ b/games/opensurge/files/opensurge.in
@@ -0,0 +1,7 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+cd "%%DATADIR%%"
+exec ./opensurge "${@}"
diff --git a/games/opensurge/files/pkg-message.in b/games/opensurge/files/pkg-message.in
new file mode 100644
index 000000000000..aa176ab1e825
--- /dev/null
+++ b/games/opensurge/files/pkg-message.in
@@ -0,0 +1,20 @@
+===============================================================================
+
+Open Surge has been installed.
+
+
+When you have problems to build Source please reinstall
+
+audio/alure
+x11-fonts/alfont
+
+
+After deinstallation, some files may stay in %%DATADIR%%,
+you can delete them with
+
+ /bin/rm -fr %%DATADIR%%
+
+
+Have fun!
+
+===============================================================================
diff --git a/games/opensurge/pkg-descr b/games/opensurge/pkg-descr
new file mode 100644
index 000000000000..ab6195cfe1d8
--- /dev/null
+++ b/games/opensurge/pkg-descr
@@ -0,0 +1,5 @@
+Open Surge is an open source retro-style 2D sidescroller inspired by
+old-school games. Join Surge, Neon and Charge and save the world from
+the evil Gimacian the Dark!
+
+WWW: http://opensnc.sourceforge.net/
diff --git a/games/opensurge/pkg-plist b/games/opensurge/pkg-plist
new file mode 100644
index 000000000000..930f029bd9d5
--- /dev/null
+++ b/games/opensurge/pkg-plist
@@ -0,0 +1,11 @@
+bin/opensurge
+share/icons/hicolor/128x128/apps/opensurge.png
+share/icons/hicolor/16x16/apps/opensurge.png
+share/icons/hicolor/256x256/apps/opensurge.png
+share/icons/hicolor/32x32/apps/opensurge.png
+share/icons/hicolor/48x48/apps/opensurge.png
+share/icons/hicolor/64x64/apps/opensurge.png
+share/icons/hicolor/72x72/apps/opensurge.png
+share/icons/hicolor/96x96/apps/opensurge.png
+share/pixmaps/opensurge.png
+