aboutsummaryrefslogtreecommitdiff
path: root/games/openttd/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2010-05-12 20:26:00 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2010-05-12 20:26:00 +0000
commit6701e036cd792b82cf451fed9ad955a673e70b04 (patch)
tree739fabf093f85fa2c9a86f6bae08059124feb6ea /games/openttd/Makefile
parent3bc4db8e654a021095d7521e3cb00ecbdb3b02f8 (diff)
Notes
Diffstat (limited to 'games/openttd/Makefile')
-rw-r--r--games/openttd/Makefile27
1 files changed, 16 insertions, 11 deletions
diff --git a/games/openttd/Makefile b/games/openttd/Makefile
index f2b87e83b4b8..1b29597382cb 100644
--- a/games/openttd/Makefile
+++ b/games/openttd/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= openttd
-PORTVERSION= 0.7.5
-PORTREVISION= 1
+PORTVERSION= 1.0.1
CATEGORIES= games
MASTER_SITES= http://gb.binaries.openttd.org/binaries/releases/${PORTVERSION}/ \
#SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -15,16 +14,16 @@ MASTER_SITES= http://gb.binaries.openttd.org/binaries/releases/${PORTVERSION}/ \
MAINTAINER= danfe@FreeBSD.org
COMMENT= An open source clone of Microprose Transport Tycoon Deluxe
-LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png
+LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
+ lzo2.2:${PORTSDIR}/archivers/lzo2
HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix-dir="${PREFIX}" --data-dir="${DATADIR_REL}"
USE_BZIP2= yes
USE_GMAKE= yes
INSTALLS_ICONS= yes
MAKE_JOBS_SAFE= yes
-CONFIGURE_ARGS= --prefix-dir="${PREFIX}" --data-dir="${DATADIR_REL}"
-
DISTVERSIONSUFFIX= -source
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
@@ -36,6 +35,8 @@ CONFIGURE_ARGS+= --with-midi-arg=${WITH_MIDI_PLAYER_ARGS}
.endif
.if defined(WITH_DEDICATED_SERVER_ONLY)
CONFIGURE_ARGS+= --enable-dedicated
+# Aid it to find lzo2 headers; client build gets it via sdl-config
+CONFIGURE_ENV= CXXFLAGS="${CXXFLAGS} -I${LOCALBASE}/include"
.else
LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2 \
fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig
@@ -48,11 +49,11 @@ MAN6= openttd.6
DESKTOP_ENTRIES="OpenTTD" "${COMMENT}" "openttd" "openttd" \
"Game;Simulation;StrategyGame;" false
-PORTDOCS= 32bpp.txt HOWTO_compile_lang_files.txt Manual.txt elrail.svg \
+PORTDOCS= 32bpp.txt HOWTO_compile_lang_files.txt elrail.svg \
elrail_tile.png elrail_track.png landscape.html \
landscape_externals.html landscape_grid.html multiplayer.txt \
- obg_format.txt ottd-colour-palette.gif \
- ottd-colourtext-palette.png tileh.png
+ obg_format.txt obm_format.txt obs_format.txt \
+ ottd-colour-palette.gif ottd-colourtext-palette.png tileh.png
pre-everything::
.if !defined(WITH_MIDI_PLAYER)
@@ -66,16 +67,20 @@ pre-everything::
.endif
post-patch:
-# Remove extra (vendor) CFLAGS, we set our own
- @${REINPLACE_CMD} '1102,1103d' ${WRKSRC}/config.lib
+# Remove extra (vendor-provided) CFLAGS and LDFLAGS
+ @${REINPLACE_CMD} -e '1250,1252d' ${WRKSRC}/config.lib
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${PREFIX}/bin
- @${MKDIR} ${DATADIR}/data ${DATADIR}/lang ${DATADIR}/scripts
+ @${MKDIR} ${DATADIR}/ai ${DATADIR}/data ${DATADIR}/gm \
+ ${DATADIR}/lang ${DATADIR}/scripts
+ ${INSTALL_DATA} ${WRKSRC}/bin/ai/*.nut ${DATADIR}/ai
${INSTALL_DATA} ${WRKSRC}/bin/data/* ${DATADIR}/data
+ ${INSTALL_DATA} ${WRKSRC}/bin/gm/* ${DATADIR}/gm
${INSTALL_DATA} ${WRKSRC}/bin/lang/* ${DATADIR}/lang
${INSTALL_DATA} ${WRKSRC}/bin/scripts/* ${DATADIR}/scripts
${INSTALL_MAN} ${WRKSRC}/docs/${MAN6} ${MANPREFIX}/man/man6
+ ${INSTALL_DATA} ${WRKSRC}/media/openttd.32.xpm ${PREFIX}/share/pixmaps
.for n in 16 32 48 64 128 256
@${MKDIR} ${PREFIX}/share/icons/hicolor/${n}x${n}/apps
${INSTALL_DATA} ${WRKSRC}/media/openttd.${n}.png \