aboutsummaryrefslogtreecommitdiff
path: root/games/openttd
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2020-04-02 08:36:17 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2020-04-02 08:36:17 +0000
commit728311e9d2800275b1d0a7030d5b8861c02eb0c4 (patch)
tree8de3c224c23ec8de74691c28c51dc0959e78566d /games/openttd
parentd130ef3cdf05cb62bcdd0c570a74610678438039 (diff)
downloadports-728311e9d2800275b1d0a7030d5b8861c02eb0c4.tar.gz
ports-728311e9d2800275b1d0a7030d5b8861c02eb0c4.zip
- Update OpenTTD to version 1.10.0
- Adjust existing patches and PORTDOCS - Stick to SDL 1.2 for the time being PR: 245253 (independent)
Notes
Notes: svn path=/head/; revision=530264
Diffstat (limited to 'games/openttd')
-rw-r--r--games/openttd/Makefile13
-rw-r--r--games/openttd/distinfo6
-rw-r--r--games/openttd/files/extra-patch-save-passwords8
-rw-r--r--games/openttd/files/patch-config.lib8
-rw-r--r--games/openttd/pkg-plist2
5 files changed, 20 insertions, 17 deletions
diff --git a/games/openttd/Makefile b/games/openttd/Makefile
index 0e7bf38a3de4..325c7ff3a59c 100644
--- a/games/openttd/Makefile
+++ b/games/openttd/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= openttd
-DISTVERSION= 1.9.3
-PORTREVISION= 1
+DISTVERSION= 1.10.0
CATEGORIES= games
MASTER_SITES= https://proxy.binaries.openttd.org/openttd-releases/${DISTVERSION}/
DISTNAME= ${PORTNAME}-${DISTVERSION}-source
@@ -19,8 +18,7 @@ LIB_DEPENDS= libpng.so:graphics/png \
USES= cpe gmake pkgconfig tar:xz
HAS_CONFIGURE= yes
CONFIGURE_ENV= STRIP="${STRIP_CMD} ${STRIP}"
-CONFIGURE_ARGS= --prefix-dir="${PREFIX}" --data-dir="${DATADIR_REL}" \
- --without-libtimidity
+CONFIGURE_ARGS= --prefix-dir="${PREFIX}" --data-dir="${DATADIR_REL}"
MAKE_ARGS= VERBOSE=1
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
@@ -28,10 +26,12 @@ CXXFLAGS= # Set to empty as OpenTTD treats it as an addition to CFLAGS
SUB_FILES= pkg-message
-PORTDOCS= HOWTO_compile_lang_files.txt README.md admin_network.txt \
+PORTDOCS= README.md admin_network.md compiling_lang_files.md \
+ debugging_desyncs.md desync.md directory_structure.md \
changelog.txt elrail.svg elrail_tile.png elrail_track.png \
known-bugs.txt landscape.html landscape_externals.html \
- landscape_grid.html multiplayer.txt obg_format.txt \
+ landscape_grid.html logging_and_performance_metrics.md \
+ multiplayer.md obg_format.txt \
obm_format.txt obs_format.txt ottd-colourtext-palette.png \
tileh.png
@@ -60,6 +60,7 @@ CONFIGURE_ARGS+= --enable-dedicated
CFLAGS+= -I${LOCALBASE}/include
USE_RC_SUBR= ${PORTNAME}
.else
+CONFIGURE_ARGS+= --with-sdl=sdl1
USES+= compiler:c++11-lib gnome sdl
USE_CXXSTD= gnu++11
CXXFLAGS+= -DU_USING_ICU_NAMESPACE=1
diff --git a/games/openttd/distinfo b/games/openttd/distinfo
index 7ca0e93b2c00..b717a56fc088 100644
--- a/games/openttd/distinfo
+++ b/games/openttd/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1568662216
-SHA256 (openttd-1.9.3-source.tar.xz) = 1988e17f5b6f4b8f423c849ef1c579c21f678722ae4440f87b27a5fea6385846
-SIZE (openttd-1.9.3-source.tar.xz) = 6659508
+TIMESTAMP = 1585730612
+SHA256 (openttd-1.10.0-source.tar.xz) = 1ba21aac9a1de98b23f80fee952b4b9c5e2d3cc4ac187f5203730826b3f0e253
+SIZE (openttd-1.10.0-source.tar.xz) = 6801228
diff --git a/games/openttd/files/extra-patch-save-passwords b/games/openttd/files/extra-patch-save-passwords
index 45b28557d55a..3620a34f7de7 100644
--- a/games/openttd/files/extra-patch-save-passwords
+++ b/games/openttd/files/extra-patch-save-passwords
@@ -14,8 +14,8 @@
+++ src/network/network_server.cpp 2014-11-09 21:37:49.000000000 +0200
@@ -32,7 +32,7 @@
#include "../core/pool_func.hpp"
- #include "../core/random_func.hpp"
- #include "../rev.h"
+ #include <mutex>
+ #include <condition_variable>
-
+#include "../fileio_func.h"
#include "../safeguards.h"
@@ -117,9 +117,9 @@
uint16 last_port; ///< port of the last joined server
bool no_http_content_downloads; ///< do not do content downloads over HTTP
+ bool save_password; ///< If password file is used
- #else /* ENABLE_NETWORK */
- #endif
};
+
+ /** Settings related to the creation of games. */
--- src/table/settings.ini 2014-10-21 21:36:21.000000000 +0300
+++ src/table/settings.ini 2014-11-09 21:37:49.000000000 +0200
@@ -3915,6 +3915,12 @@
diff --git a/games/openttd/files/patch-config.lib b/games/openttd/files/patch-config.lib
index 3bf0d5a7030f..f7ec57c342ca 100644
--- a/games/openttd/files/patch-config.lib
+++ b/games/openttd/files/patch-config.lib
@@ -31,7 +31,7 @@
fi
- if [ -n "$lzma_config" ]; then
-- CFLAGS="$CFLAGS -DWITH_LZMA"
+- CFLAGS="$CFLAGS -DWITH_LIBLZMA"
- CFLAGS="$CFLAGS `$lzma_config --cflags | tr '\n\r' ' '`"
-
- if [ "$enable_static" != "0" ]; then
@@ -44,7 +44,7 @@
- LIBS="$LIBS `$lzma_config --libs | tr '\n\r' ' '`"
+ LIBS="$LIBS -llzma"
fi
-+ CFLAGS="$CFLAGS -DWITH_LZMA"
++ CFLAGS="$CFLAGS -DWITH_LIBLZMA"
fi
if [ "$with_lzo2" != "0" ]; then
@@ -56,8 +56,8 @@
+ detect_library "$with_lzma" "lzma" "liblzma.a" "" "lzma.h"
+}
+
- detect_libtimidity() {
- detect_pkg_config "$with_libtimidity" "libtimidity" "libtimidity_config" "0.1" "1"
+ detect_fluidsynth() {
+ detect_library "$with_fluidsynth" "fluidsynth" "" "" "fluidsynth.h"
}
@@ -2756,10 +2757,6 @@ detect_pkg_config() {
log 1 "checking $2... found"
diff --git a/games/openttd/pkg-plist b/games/openttd/pkg-plist
index a0a3b738c8eb..b4d8412f27ba 100644
--- a/games/openttd/pkg-plist
+++ b/games/openttd/pkg-plist
@@ -11,6 +11,7 @@ man/man6/openttd.6.gz
%%DATADIR%%/ai/compat_1.7.nut
%%DATADIR%%/ai/compat_1.8.nut
%%DATADIR%%/ai/compat_1.9.nut
+%%DATADIR%%/ai/compat_1.10.nut
%%DATADIR%%/baseset/no_music.obm
%%DATADIR%%/baseset/no_sound.obs
%%DATADIR%%/baseset/openttd.grf
@@ -32,6 +33,7 @@ man/man6/openttd.6.gz
%%DATADIR%%/game/compat_1.7.nut
%%DATADIR%%/game/compat_1.8.nut
%%DATADIR%%/game/compat_1.9.nut
+%%DATADIR%%/game/compat_1.10.nut
%%DATADIR%%/lang/afrikaans.lng
%%DATADIR%%/lang/arabic_egypt.lng
%%DATADIR%%/lang/basque.lng