aboutsummaryrefslogtreecommitdiff
path: root/games/openttd
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-04-04 10:04:30 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-04-04 10:04:30 +0000
commite00bb86407b25d8578cbcc981b03e614b9e565ca (patch)
tree75d8a71fdce2a3510e711bca02a8ee578de8fa04 /games/openttd
parenta5aec7f98c26bad81900dd19a6a0763a9a885a1c (diff)
downloadports-e00bb86407b25d8578cbcc981b03e614b9e565ca.tar.gz
ports-e00bb86407b25d8578cbcc981b03e614b9e565ca.zip
games/openttd: unbreak with ICU 61
src/language.h:108:8: error: unknown type name 'Collator'; did you mean 'UCollator'? extern Collator *_current_collator; ^~~~~~~~ UCollator /usr/local/include/unicode/ucol.h:58:26: note: 'UCollator' declared here typedef struct UCollator UCollator; ^ https://ssl.icu-project.org/trac/changeset/40705 PR: 227042 Reported by: antoine (via exp-run)
Notes
Notes: svn path=/head/; revision=466412
Diffstat (limited to 'games/openttd')
-rw-r--r--games/openttd/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/games/openttd/Makefile b/games/openttd/Makefile
index d6550c3e48c2..8cc09404109d 100644
--- a/games/openttd/Makefile
+++ b/games/openttd/Makefile
@@ -57,6 +57,7 @@ USE_RC_SUBR= ${PORTNAME}
.else
USES+= compiler:c++11-lib
USE_CXXSTD= gnu++11
+CXXFLAGS+= -DU_USING_ICU_NAMESPACE=1
LIB_DEPENDS+= libfreetype.so:print/freetype2 \
libicui18n.so:devel/icu \
libicu-le-hb.so:devel/icu-le-hb \