aboutsummaryrefslogtreecommitdiff
path: root/games/pacmanarena
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2013-11-25 11:50:18 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2013-11-25 11:50:18 +0000
commit708eac13b3f63b6d3264dc393d3b1706c8bc55a3 (patch)
tree726923dd8806fa3c5a5c63282bf8eec0404de97b /games/pacmanarena
parent8086c1e05121094cc6c53fc83c2ba3bb5e720426 (diff)
downloadports-708eac13b3f63b6d3264dc393d3b1706c8bc55a3.tar.gz
ports-708eac13b3f63b6d3264dc393d3b1706c8bc55a3.zip
Notes
Diffstat (limited to 'games/pacmanarena')
-rw-r--r--games/pacmanarena/Makefile56
-rw-r--r--games/pacmanarena/distinfo4
-rw-r--r--games/pacmanarena/pkg-plist59
3 files changed, 87 insertions, 32 deletions
diff --git a/games/pacmanarena/Makefile b/games/pacmanarena/Makefile
index 1012caf6da67..7415e873fb43 100644
--- a/games/pacmanarena/Makefile
+++ b/games/pacmanarena/Makefile
@@ -1,15 +1,17 @@
+# Created by: Rusmir Dusko <nemysis@FreeBSD.org>
# $FreeBSD$
PORTNAME= pacmanarena
PORTVERSION= 0.15
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/v0.0/ \
- SF/nemysisfreebsdp/:icons
+ SF/nemysisfreebsdp/${CATEGORIES}/${PORTNAME}/:icons
DISTFILES= ${DISTNAME:S/na/n-a/}.tar.bz2 \
${PORTNAME:S/arena/-data/}-0.0.zip \
- ${PORTNAME}_icons.tar.gz:icons
+ ${PORTNAME}_icons_1.tar.gz:icons
-MAINTAINER= nemysis@gmx.ch
+MAINTAINER= nemysis@FreeBSD.org
COMMENT= Pacman clone in full 3D with a few surprises
LICENSE= GPLv2
@@ -18,43 +20,37 @@ EXTRACT_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
WRKSRC= ${WRKDIR}/${PORTNAME:S/arena//}
-GNU_CONFIGURE= yes
USE_SDL= mixer net sdl
+GNU_CONFIGURE= yes
-PLIST_FILES= bin/${PORTNAME} \
- share/pixmaps/${PORTNAME}_48.png \
- share/pixmaps/${PORTNAME}_64.png \
- share/pixmaps/${PORTNAME}_72.png \
- share/pixmaps/${PORTNAME}_96.png
-
-PORTDATA= *
PORTDOCS= README
-NO_STAGE= yes
-post-patch:
-# Fix data location
- @${REINPLACE_CMD} -e 's|@prefix@|${DATADIR}|' \
- -e 's|@datadir@/pacman|${DATADIR}|' ${WRKSRC}/Makefile.in
+INSTALLS_ICONS= yes
+ICON_SIZES= 32x32 48x48 64x64 72x72 96x96
-.include <bsd.port.options.mk>
+DESKTOP_ENTRIES="Pacman Arena" "${COMMENT}" "${PORTNAME}" \
+ "${PORTNAME}" "Game;ArcadeGame;" false
-do-install:
-# Executable
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME:S/arena//} ${PREFIX}/bin/${PORTNAME}
+post-patch:
+ @${REINPLACE_CMD} -e 's|@prefix@|${DATADIR}| ; \
+ s|@datadir@/pacman|${DATADIR}|' \
+ ${WRKSRC}/Makefile.in
-# Data
- ${MKDIR} ${DATADIR}
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME:S/arena//} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.for d in gfx sfx
- @(cd ${WRKSRC}/../ && ${COPYTREE_SHARE} ${d} ${DATADIR})
+ @(cd ${WRKSRC}/../ && ${COPYTREE_SHARE} ${d} ${STAGEDIR}${DATADIR})
.endfor
-# Pixmaps
- ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}*.png ${PREFIX}/share/pixmaps
+.for s in ${ICON_SIZES}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps/
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}_${s}.png \
+ ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
+.endfor
+ ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
-# Documentation
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
-.endif
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/games/pacmanarena/distinfo b/games/pacmanarena/distinfo
index 0921b53e8e9a..d1dcc62243ef 100644
--- a/games/pacmanarena/distinfo
+++ b/games/pacmanarena/distinfo
@@ -2,5 +2,5 @@ SHA256 (pacman-arena-0.15.tar.bz2) = 3f151518f3d4a9595ea03f9ef681e8a8829e88e76fb
SIZE (pacman-arena-0.15.tar.bz2) = 100112
SHA256 (pacman-data-0.0.zip) = 7949f080ca0ba4c02d737c5bb365856c3e66f103838329be8c1857d6c297b9b8
SIZE (pacman-data-0.0.zip) = 11994364
-SHA256 (pacmanarena_icons.tar.gz) = 55a6e8e4144f4fc3c49597a11bb9482ff980935d43f993da9080db837fdcc3d7
-SIZE (pacmanarena_icons.tar.gz) = 14848
+SHA256 (pacmanarena_icons_1.tar.gz) = 70f4217e1141d07190e2a892b4f0d383c95af0a4036cbf25c7741a0d19b2b0a0
+SIZE (pacmanarena_icons_1.tar.gz) = 11532
diff --git a/games/pacmanarena/pkg-plist b/games/pacmanarena/pkg-plist
new file mode 100644
index 000000000000..4daa7b68689f
--- /dev/null
+++ b/games/pacmanarena/pkg-plist
@@ -0,0 +1,59 @@
+bin/pacmanarena
+share/icons/hicolor/32x32/apps/pacmanarena.png
+share/icons/hicolor/48x48/apps/pacmanarena.png
+share/icons/hicolor/64x64/apps/pacmanarena.png
+share/icons/hicolor/72x72/apps/pacmanarena.png
+share/icons/hicolor/96x96/apps/pacmanarena.png
+%%DATADIR%%/gfx/1024-768-high.tga
+%%DATADIR%%/gfx/1024-768-low.tga
+%%DATADIR%%/gfx/1400-1050-high.tga
+%%DATADIR%%/gfx/1400-1050-low.tga
+%%DATADIR%%/gfx/640-480-high.tga
+%%DATADIR%%/gfx/640-480-low.tga
+%%DATADIR%%/gfx/800-600-high.tga
+%%DATADIR%%/gfx/800-600-low.tga
+%%DATADIR%%/gfx/bomb.3d
+%%DATADIR%%/gfx/dot-yellow.tga
+%%DATADIR%%/gfx/dot.tga
+%%DATADIR%%/gfx/exit-high.tga
+%%DATADIR%%/gfx/exit-low.tga
+%%DATADIR%%/gfx/game-over.tga
+%%DATADIR%%/gfx/ghost-green-dying.3d
+%%DATADIR%%/gfx/ghost-green-moving.3d
+%%DATADIR%%/gfx/ghost-green-returning.3d
+%%DATADIR%%/gfx/level-complete.tga
+%%DATADIR%%/gfx/pacman-arena-banner.tga
+%%DATADIR%%/gfx/pacman-dying.3d
+%%DATADIR%%/gfx/pacman-jumping.3d
+%%DATADIR%%/gfx/pacman-moving.3d
+%%DATADIR%%/gfx/pacman-stopped.3d
+%%DATADIR%%/gfx/pacman_arena1.tga
+%%DATADIR%%/gfx/particle.tga
+%%DATADIR%%/gfx/resolution-high.tga
+%%DATADIR%%/gfx/resolution-low.tga
+%%DATADIR%%/gfx/rocket-highlight.tga
+%%DATADIR%%/gfx/rocket.3d
+%%DATADIR%%/gfx/start-game-high.tga
+%%DATADIR%%/gfx/start-game-low.tga
+%%DATADIR%%/gfx/wall-horizontal.3d
+%%DATADIR%%/gfx/wall-ll.3d
+%%DATADIR%%/gfx/wall-lr.3d
+%%DATADIR%%/gfx/wall-ul.3d
+%%DATADIR%%/gfx/wall-ur.3d
+%%DATADIR%%/gfx/wall-vertical.3d
+%%DATADIR%%/gfx/wall.tga
+%%DATADIR%%/sfx/chomp.wav
+%%DATADIR%%/sfx/eat-ghost.wav
+%%DATADIR%%/sfx/explosion.wav
+%%DATADIR%%/sfx/gameover.ogg
+%%DATADIR%%/sfx/ghost-return.wav
+%%DATADIR%%/sfx/glomp.wav
+%%DATADIR%%/sfx/hiscore.ogg
+%%DATADIR%%/sfx/hummingbird.ogg
+%%DATADIR%%/sfx/pacman-die.wav
+%%DATADIR%%/sfx/rocket-launch.wav
+%%DATADIR%%/sfx/tranzy.ogg
+share/pixmaps/pacmanarena.png
+@dirrm %%DATADIR%%/sfx
+@dirrm %%DATADIR%%/gfx
+@dirrm %%DATADIR%%