aboutsummaryrefslogtreecommitdiff
path: root/games/palomino
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-18 02:21:58 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-18 02:57:10 +0000
commit1b42793aba21034eaf6666ff4ccf67411a470893 (patch)
treeb1ddd174255fdbeab5b1b9d0d509aca97145d879 /games/palomino
parent09e56dc8e568994c4f3e5f17373f0c7d5965d976 (diff)
downloadports-1b42793aba21034eaf6666ff4ccf67411a470893.tar.gz
ports-1b42793aba21034eaf6666ff4ccf67411a470893.zip
games/palomino: Mark BROKEN on 14
- Fails to compile with: error: no matching function for call to 'make_pair' Tried to build with llvm14 and llvm without any result - Pet portclippy Sponsored by: The FreeBSD Foundation
Diffstat (limited to 'games/palomino')
-rw-r--r--games/palomino/Makefile20
1 files changed, 11 insertions, 9 deletions
diff --git a/games/palomino/Makefile b/games/palomino/Makefile
index 8e718d1a16bc..9309b6c6c670 100644
--- a/games/palomino/Makefile
+++ b/games/palomino/Makefile
@@ -15,6 +15,7 @@ WWW= http://www.palomino3d.org/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE_GNU_GPL_2.txt
+BROKEN_FreeBSD_14= fails to compile: no matching function for call to 'make_pair'
LIB_DEPENDS= libosg.so:graphics/osg34
@@ -22,29 +23,30 @@ USES= alias compiler:c++11-lang cmake:insource,noninja gl lua:51 tar:xz
USE_CXXSTD= gnu++98
USE_GL= gl glu
-MISC_VER= 20091027
-MODELS_VER= 20090615
-SOUNDS_VER= 20080704
-TERRAIN_VER= 20080206
+DESKTOP_ENTRIES= "Palomino" "" "${PORTNAME}" \
+ "${PORTNAME}" "Game;ArcadeGame;" ""
WRKSRC= ${WRKDIR}/${PORTNAME}
PORTDOCS= *
-DESKTOP_ENTRIES= "Palomino" "" "${PORTNAME}" \
- "${PORTNAME}" "Game;ArcadeGame;" ""
-
OPTIONS_DEFINE= DOCS GUI PLIB SDL
OPTIONS_DEFAULT=GUI SDL
OPTIONS_SUB= yes
-PLIB_DESC= Enable sound support through plib
-PLIB_BUILD_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:x11-toolkits/plib
GUI_DESC= Enable FLTK GUI
+PLIB_DESC= Enable sound support through plib
+
GUI_LIB_DEPENDS= libfltk.so:x11-toolkits/fltk
+PLIB_BUILD_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:x11-toolkits/plib
SDL_USES= sdl
SDL_USE= SDL=sdl,mixer
+MISC_VER= 20091027
+MODELS_VER= 20090615
+SOUNDS_VER= 20080704
+TERRAIN_VER= 20080206
+
post-patch:
@${FIND} ${WRKSRC}/CMakeModules -type f -print0 | ${XARGS} -0 \
${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g'