aboutsummaryrefslogtreecommitdiff
path: root/games/pcgen
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2005-09-08 13:46:23 +0000
committerHerve Quiroz <hq@FreeBSD.org>2005-09-08 13:46:23 +0000
commit9776adda226f6cb55d09baf3a73bc8980c7441cd (patch)
tree0439f35544c86106d0d4fc9d619f9be83b6f7e9d /games/pcgen
parent6e8dbb5f273eab01b851fe62730e45493a1746a4 (diff)
downloadports-9776adda226f6cb55d09baf3a73bc8980c7441cd.tar.gz
ports-9776adda226f6cb55d09baf3a73bc8980c7441cd.zip
- Update to 5.8.0 (latest release from stable branch)
- Add a FreeBSD-specific launcher shell script. It allows the user to specify Java VM args using PCGEN_OPTS
Notes
Notes: svn path=/head/; revision=142222
Diffstat (limited to 'games/pcgen')
-rw-r--r--games/pcgen/Makefile10
-rw-r--r--games/pcgen/distinfo4
-rw-r--r--games/pcgen/files/pcgen.sh.in7
3 files changed, 13 insertions, 8 deletions
diff --git a/games/pcgen/Makefile b/games/pcgen/Makefile
index 15f199291fc6..5c74b841d712 100644
--- a/games/pcgen/Makefile
+++ b/games/pcgen/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= pcgen
-PORTVERSION= 5.7.15
+PORTVERSION= 5.8.0
CATEGORIES= games java
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= pcgen
@@ -26,6 +26,8 @@ DATADIR= ${JAVASHAREDIR}/${PORTNAME}
DATAFILES= characters data filepaths.ini lib outputsheets pcgen.jar plugins system
PLIST_FILES+= bin/pcgen
+SUB_FILES= pcgen.sh
+
.if !defined(NOPORTDOCS)
PORTDOCS= acknowledgments faqpages gmgen greetings.html images \
index.html installationpages listfilepages menupages \
@@ -38,10 +40,6 @@ post-extract:
do-configure:
@${ECHO_CMD} "pcgen.filepaths=user" > ${WRKSRC}/filepaths.ini
- @${SED} \
- -e 's|^java|JAVA_VERSION="1.4+" "${LOCALBASE}/bin/java"|' \
- -e 's|`dirname $$0`|"${DATADIR}"|' \
- ${WRKSRC}/pcgen.sh > ${WRKSRC}/pcgen.sh.bsd
do-install:
@${ECHO_MSG} -n ">> Installing in ${DATADIR}..."
@@ -49,7 +47,7 @@ do-install:
@cd ${WRKSRC} && ${FIND} ${DATAFILES} -type f -exec ${INSTALL_DATA} {} ${DATADIR}/{} ";"
@${ECHO_MSG} " [ DONE ]"
@${ECHO_MSG} -n ">> Installing launcher script as ${PREFIX}/bin/pcgen..."
- @${INSTALL_SCRIPT} ${WRKSRC}/pcgen.sh.bsd ${PREFIX}/bin/pcgen
+ @${INSTALL_SCRIPT} ${WRKDIR}/pcgen.sh ${PREFIX}/bin/pcgen
@${ECHO_MSG} " [ DONE ]"
.if !defined(NOPORTDOCS)
@${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
diff --git a/games/pcgen/distinfo b/games/pcgen/distinfo
index 52a259aaec33..f3eb36074e39 100644
--- a/games/pcgen/distinfo
+++ b/games/pcgen/distinfo
@@ -1,2 +1,2 @@
-MD5 (pcgen5715_partial.zip) = 259a16b8023f0687cadd1238c4aafd5e
-SIZE (pcgen5715_partial.zip) = 8672048
+MD5 (pcgen580_partial.zip) = 1479b4e708c146a8fcd585a3aa2825d1
+SIZE (pcgen580_partial.zip) = 8249444
diff --git a/games/pcgen/files/pcgen.sh.in b/games/pcgen/files/pcgen.sh.in
new file mode 100644
index 000000000000..5581e263f262
--- /dev/null
+++ b/games/pcgen/files/pcgen.sh.in
@@ -0,0 +1,7 @@
+#!/bin/sh
+#
+# $FreeBSD$
+
+[ \! -d "${HOME}/.pcgen" ] && mkdir "${HOME}/.pcgen"
+cd "%%DATADIR%%"
+JAVA_VERSION="%%JAVA_VERSION%%" "%%LOCALBASE%%/bin/java" ${PCGEN_OPTS} -jar ./pcgen.jar "$@"