aboutsummaryrefslogtreecommitdiff
path: root/games/pear-Games_Chess
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-10-23 03:12:43 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-10-23 03:12:43 +0000
commit48d243d662dad47437166f1cb8735a0f5fa48f0a (patch)
tree4b40f56e995adfb2d3552534a0b23d26f6307bb0 /games/pear-Games_Chess
parentec061a30a8a61d08dbaea808ebaf0fca5821c2f4 (diff)
downloadports-48d243d662dad47437166f1cb8735a0f5fa48f0a.tar.gz
ports-48d243d662dad47437166f1cb8735a0f5fa48f0a.zip
new port: games/pear-Games_Chess 0.9.0
new port pear-Games_Chess to validate PGN (portable Game Notation) representing chess games PR: ports/87617 Submitted by: Mark Huizer <xaa+ports@timewasters.nl>
Notes
Notes: svn path=/head/; revision=146168
Diffstat (limited to 'games/pear-Games_Chess')
-rw-r--r--games/pear-Games_Chess/Makefile31
-rw-r--r--games/pear-Games_Chess/distinfo2
-rw-r--r--games/pear-Games_Chess/pkg-descr7
3 files changed, 40 insertions, 0 deletions
diff --git a/games/pear-Games_Chess/Makefile b/games/pear-Games_Chess/Makefile
new file mode 100644
index 000000000000..319ce1aa7be0
--- /dev/null
+++ b/games/pear-Games_Chess/Makefile
@@ -0,0 +1,31 @@
+# Ports collection makefile for: pear-Games_Chess
+# Date created: 19 October 2005
+# Whom: Mark Huizer <xaa+ports@timewasters.nl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Games_Chess
+PORTVERSION= 0.9.0
+CATEGORIES= games devel pear
+
+MAINTAINER= xaa+ports@timewasters.nl
+COMMENT= PEAR methods for constructing and validating chess games in PGN
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= Games
+FILES= Chess.php \
+ Chess/Crazyhouse.php Chess/Losers.php Chess/Player.php \
+ Chess/Result.php Chess/Standard.php
+
+EXAMPLES= HTMLChess.php images/B.gif images/N.gif images/Q.gif \
+ images/blank.gif images/K.gif images/P.gif images/R.gif \
+ images/dark/b.gif images/dark/k.gif images/dark/p.gif \
+ images/dark/r.gif images/dark/blank.gif images/dark/n.gif \
+ images/dark/q.gif
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/games/pear-Games_Chess/distinfo b/games/pear-Games_Chess/distinfo
new file mode 100644
index 000000000000..a4fd1460cde4
--- /dev/null
+++ b/games/pear-Games_Chess/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/Games_Chess-0.9.0.tgz) = 113d29fe28e965212668acb57f8cef8f
+SIZE (PEAR/Games_Chess-0.9.0.tgz) = 68965
diff --git a/games/pear-Games_Chess/pkg-descr b/games/pear-Games_Chess/pkg-descr
new file mode 100644
index 000000000000..7fea8e612b3f
--- /dev/null
+++ b/games/pear-Games_Chess/pkg-descr
@@ -0,0 +1,7 @@
+The logic of handling a chessboard and parsing standard
+FEN (Farnsworth-Edwards Notation) for describing a position as well as SAN
+(Standard Algebraic Notation) for describing individual moves is handled. This
+class can be used as a backend driver for playing chess, or for validating
+and/or creating PGN files using the File_ChessPGN package.
+
+WWW: http://pear.php.net/package/Games_Chess/