aboutsummaryrefslogtreecommitdiff
path: root/games/pengpong
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-09-04 23:38:57 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-09-04 23:38:57 +0000
commit6a3e7d9599c4f646425c957319a8e72e9c72647e (patch)
treea31981f78fbd25e7eb80702527d2efe87c009e08 /games/pengpong
parent25f823282808892c49275e1559a593fa76c70b22 (diff)
downloadports-6a3e7d9599c4f646425c957319a8e72e9c72647e.tar.gz
ports-6a3e7d9599c4f646425c957319a8e72e9c72647e.zip
Update to 0.3
Submitted by: MAINTAINER
Notes
Notes: svn path=/head/; revision=47438
Diffstat (limited to 'games/pengpong')
-rw-r--r--games/pengpong/Makefile16
-rw-r--r--games/pengpong/distinfo2
-rw-r--r--games/pengpong/files/patch-Makefile38
-rw-r--r--games/pengpong/pkg-plist6
4 files changed, 48 insertions, 14 deletions
diff --git a/games/pengpong/Makefile b/games/pengpong/Makefile
index d1db3c0dcd35..05b79705eff3 100644
--- a/games/pengpong/Makefile
+++ b/games/pengpong/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pengpong
-PORTVERSION= 0.2
+PORTVERSION= 0.3
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -20,11 +20,25 @@ SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
NO_WRKSUBDIR= yes
MAKE_ENV= SDL_CONFIG="${SDL_CONFIG}"
+DATAFILES= 24P_Copperplate_Blue.png ball.tga logo.jpg \
+ paddle.tga red.png
+
+pre-patch:
+ @${PERL} -pi.orig -e \
+ 's|/usr/local/share/games/pengpong|${DATADIR}|' \
+ ${WRKSRC}/files.h
+ @${PERL} -pi.orig -e 's|0.2|${PORTVERSION}|' \
+ ${WRKSRC}/pengpong.cpp
+
do-install:
.ifndef(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
@${INSTALL_PROGRAM} ${WRKSRC}/pengpong ${PREFIX}/bin
+.for files in ${DATAFILES}
+ @${MKDIR} ${DATADIR}
+ @${INSTALL_DATA} ${WRKSRC}/${files} ${DATADIR}
+.endfor
.include <bsd.port.mk>
diff --git a/games/pengpong/distinfo b/games/pengpong/distinfo
index fca9b1e3c4fa..8232cbbf9e6c 100644
--- a/games/pengpong/distinfo
+++ b/games/pengpong/distinfo
@@ -1 +1 @@
-MD5 (pengpong-0.2.tar.gz) = 840fc7a4a6bb4abdc33cae629b951273
+MD5 (pengpong-0.3.tar.gz) = 1f45c8dbddcb0ff44758bd51f55f1ff1
diff --git a/games/pengpong/files/patch-Makefile b/games/pengpong/files/patch-Makefile
index b0f9108784c6..f3de592276b1 100644
--- a/games/pengpong/files/patch-Makefile
+++ b/games/pengpong/files/patch-Makefile
@@ -1,25 +1,39 @@
---- Makefile.orig Fri Aug 24 15:39:29 2001
-+++ Makefile Mon Sep 3 13:25:31 2001
-@@ -1,15 +1,8 @@
--all: SFont link2 sdlpong finish
-+CXXFLAGS += `${SDL_CONFIG} --cflags`
+--- Makefile.orig Fri Aug 31 17:21:43 2001
++++ Makefile Tue Sep 4 19:14:16 2001
+@@ -1,29 +1,8 @@
+-all: finish clean
++CXXFLAGS += `${SDL_CONFIG} --cflags` -D_REENTRANT
+LIBS = `${SDL_CONFIG} --libs` -lSDL_image
+-pengpong:
+- g++ -I/usr/include/SDL -D_REENTRANT -c -o pengpong.o pengpong.cpp
+-
-SFont:
- g++ -I/usr/include/SDL -D_REENTRANT -c -o SFont.o SFont.c
+-
-link2:
- g++ -I/usr/include/SDL -D_REENTRANT -c -o link2.o link2.cpp
--sdlpong:
-- g++ -pedantic -Wall -c -o sdlpong.o sdlpong.cpp -I/usr/include/SDL -D_REENTRANT
--finish: SFont link2 sdlpong
-- g++ -o pengpong sdlpong.o link2.o SFont.o -D_REENTRANT -I/usr/include/SDL -lSDL_image
+-
+-finish: SFont link2 pengpong
+- g++ -o pengpong link2.o SFont.o pengpong.o -D_REENTRANT -I/usr/include/SDL -lSDL_image
+-
+-uninstall:
+- rm /usr/local/bin/pengpong
+- rm /usr/local/share/games/pengpong -rf
+-
-install:
- cp pengpong /usr/local/bin
--
+- mkdir -p /usr/local/share/games/pengpong
+- mkdir ~/.pengpong
+- cp *.png /usr/local/share/games/pengpong
+- cp *.tga /usr/local/share/games/pengpong
+- cp *.jpg /usr/local/share/games/pengpong
-clean:
- rm *.o
+-
+-
+all:
+ ${CXX} -c -o SFont.o SFont.c ${CXXFLAGS}
+ ${CXX} -c -o link2.o link2.cpp ${CXXFLAGS}
-+ ${CXX} -c -o sdlpong.o sdlpong.cpp ${CXXFLAGS}
-+ ${CXX} -o pengpong sdlpong.o link2.o SFont.o ${CXXFLAGS} ${LIBS}
++ ${CXX} -c -o pengpong.o pengpong.cpp ${CXXFLAGS}
++ ${CXX} -o pengpong pengpong.o link2.o SFont.o ${CXXFLAGS} ${LIBS}
diff --git a/games/pengpong/pkg-plist b/games/pengpong/pkg-plist
index 907591fe2735..daf674cd028b 100644
--- a/games/pengpong/pkg-plist
+++ b/games/pengpong/pkg-plist
@@ -1,3 +1,9 @@
bin/pengpong
+share/pengpong/24P_Copperplate_Blue.png
+share/pengpong/ball.tga
+share/pengpong/logo.jpg
+share/pengpong/paddle.tga
+share/pengpong/red.png
%%PORTDOCS%%share/doc/pengpong/README
+@dirrm share/pengpong
%%PORTDOCS%%@dirrm share/doc/pengpong