aboutsummaryrefslogtreecommitdiff
path: root/games/pengpong
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-09-03 16:31:09 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-09-03 16:31:09 +0000
commit6aa4f9ff2199872b76c630b26865cf0f7fcfdf9b (patch)
tree710f849485dc05c1912b43fe09a74239f9da3190 /games/pengpong
parentfe3e441eb2b0b39fbcf3f65f429ab7003776b9a0 (diff)
downloadports-6aa4f9ff2199872b76c630b26865cf0f7fcfdf9b.tar.gz
ports-6aa4f9ff2199872b76c630b26865cf0f7fcfdf9b.zip
New port pengpong version 0.2: A cross-platform pong game written
in SDL PR: 30060 Submitted by: Patrick Li <pat@databits.net>
Notes
Notes: svn path=/head/; revision=47372
Diffstat (limited to 'games/pengpong')
-rw-r--r--games/pengpong/Makefile30
-rw-r--r--games/pengpong/distinfo1
-rw-r--r--games/pengpong/files/patch-Makefile25
-rw-r--r--games/pengpong/pkg-comment1
-rw-r--r--games/pengpong/pkg-descr3
-rw-r--r--games/pengpong/pkg-plist3
6 files changed, 63 insertions, 0 deletions
diff --git a/games/pengpong/Makefile b/games/pengpong/Makefile
new file mode 100644
index 000000000000..d1db3c0dcd35
--- /dev/null
+++ b/games/pengpong/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: pengpong
+# Date created: Fri Aug 24 18:21:25 EDT 2001
+# Whom: Patrick Li <pat@databits.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pengpong
+PORTVERSION= 0.2
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= pat@databits.net
+
+LIB_DEPENDS= SDL_image.10:${PORTSDIR}/graphics/sdl_image
+
+SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
+
+NO_WRKSUBDIR= yes
+MAKE_ENV= SDL_CONFIG="${SDL_CONFIG}"
+
+do-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+ @${INSTALL_PROGRAM} ${WRKSRC}/pengpong ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/games/pengpong/distinfo b/games/pengpong/distinfo
new file mode 100644
index 000000000000..fca9b1e3c4fa
--- /dev/null
+++ b/games/pengpong/distinfo
@@ -0,0 +1 @@
+MD5 (pengpong-0.2.tar.gz) = 840fc7a4a6bb4abdc33cae629b951273
diff --git a/games/pengpong/files/patch-Makefile b/games/pengpong/files/patch-Makefile
new file mode 100644
index 000000000000..b0f9108784c6
--- /dev/null
+++ b/games/pengpong/files/patch-Makefile
@@ -0,0 +1,25 @@
+--- Makefile.orig Fri Aug 24 15:39:29 2001
++++ Makefile Mon Sep 3 13:25:31 2001
+@@ -1,15 +1,8 @@
+-all: SFont link2 sdlpong finish
++CXXFLAGS += `${SDL_CONFIG} --cflags`
++LIBS = `${SDL_CONFIG} --libs` -lSDL_image
+
+-SFont:
+- g++ -I/usr/include/SDL -D_REENTRANT -c -o SFont.o SFont.c
+-link2:
+- g++ -I/usr/include/SDL -D_REENTRANT -c -o link2.o link2.cpp
+-sdlpong:
+- g++ -pedantic -Wall -c -o sdlpong.o sdlpong.cpp -I/usr/include/SDL -D_REENTRANT
+-finish: SFont link2 sdlpong
+- g++ -o pengpong sdlpong.o link2.o SFont.o -D_REENTRANT -I/usr/include/SDL -lSDL_image
+-install:
+- cp pengpong /usr/local/bin
+-
+-clean:
+- rm *.o
++all:
++ ${CXX} -c -o SFont.o SFont.c ${CXXFLAGS}
++ ${CXX} -c -o link2.o link2.cpp ${CXXFLAGS}
++ ${CXX} -c -o sdlpong.o sdlpong.cpp ${CXXFLAGS}
++ ${CXX} -o pengpong sdlpong.o link2.o SFont.o ${CXXFLAGS} ${LIBS}
diff --git a/games/pengpong/pkg-comment b/games/pengpong/pkg-comment
new file mode 100644
index 000000000000..c4f2efcec573
--- /dev/null
+++ b/games/pengpong/pkg-comment
@@ -0,0 +1 @@
+A cross-platform pong game written in SDL
diff --git a/games/pengpong/pkg-descr b/games/pengpong/pkg-descr
new file mode 100644
index 000000000000..22a1e24cf881
--- /dev/null
+++ b/games/pengpong/pkg-descr
@@ -0,0 +1,3 @@
+Peng-Pong is a cross-platform pong game written in SDL
+
+WWW: http://pengpong.sourceforge.net/
diff --git a/games/pengpong/pkg-plist b/games/pengpong/pkg-plist
new file mode 100644
index 000000000000..907591fe2735
--- /dev/null
+++ b/games/pengpong/pkg-plist
@@ -0,0 +1,3 @@
+bin/pengpong
+%%PORTDOCS%%share/doc/pengpong/README
+%%PORTDOCS%%@dirrm share/doc/pengpong