aboutsummaryrefslogtreecommitdiff
path: root/games/pengpong
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-07-26 05:33:51 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-07-26 05:33:51 +0000
commita4fc6158f566f3061d1acce1ef519be9cd17a69a (patch)
treeeb22256c13100460a384a64ae5d3fbefbaab9ab7 /games/pengpong
parentf720ee1568631cec981d47b6deaf26f18bc44159 (diff)
downloadports-a4fc6158f566f3061d1acce1ef519be9cd17a69a.tar.gz
ports-a4fc6158f566f3061d1acce1ef519be9cd17a69a.zip
- switch simple inline replacement from perl to sed
and remove where is no need in this anymore. - trim Makefile header Approved by: bapt@ (portmrg@)
Notes
Notes: svn path=/head/; revision=323680
Diffstat (limited to 'games/pengpong')
-rw-r--r--games/pengpong/Makefile12
1 files changed, 3 insertions, 9 deletions
diff --git a/games/pengpong/Makefile b/games/pengpong/Makefile
index 2844fb42db5a..5808c5bf042d 100644
--- a/games/pengpong/Makefile
+++ b/games/pengpong/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pengpong
-# Date created: Fri Aug 24 18:21:25 EDT 2001
-# Whom: Patrick Li <pat@databits.net>
-#
+# Created by: Patrick Li <pat@databits.net>
# $FreeBSD$
-#
PORTNAME= pengpong
PORTVERSION= 0.3
@@ -22,11 +18,9 @@ DATAFILES= 24P_Copperplate_Blue.png ball.tga logo.jpg \
paddle.tga red.png
pre-patch:
- @${PERL} -pi.orig -e \
- 's|/usr/local/share/games/pengpong|${DATADIR}|' \
+ @${REINPLACE_CMD} -i '' -e 's|/usr/local/share/games/pengpong|${DATADIR}|' \
${WRKSRC}/files.h
- @${PERL} -pi.orig -e 's|0.2|${PORTVERSION}|' \
- ${WRKSRC}/pengpong.cpp
+ @${REINPLACE_CMD} -i '' -e 's|V 0.2|V ${PORTVERSION}|' ${WRKSRC}/pengpong.cpp
do-install:
.ifndef(NOPORTDOCS)