aboutsummaryrefslogtreecommitdiff
path: root/games/penguin-command
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-10-16 12:55:25 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-10-16 12:55:25 +0000
commitbffb98a8bdb30ac583dec2b7885c6a6eaeb4917c (patch)
tree4e87ae80e1acd118f3e421fc3db50840be4f7e8c /games/penguin-command
parent68c709c1066a4db2986e236ce017cd8143de4112 (diff)
downloadports-bffb98a8bdb30ac583dec2b7885c6a6eaeb4917c.tar.gz
ports-bffb98a8bdb30ac583dec2b7885c6a6eaeb4917c.zip
- Support staging
- Add DESKTOP_ENTRIES - Use new LIB_DEPENDS syntax
Notes
Notes: svn path=/head/; revision=330502
Diffstat (limited to 'games/penguin-command')
-rw-r--r--games/penguin-command/Makefile22
-rw-r--r--games/penguin-command/pkg-plist96
2 files changed, 15 insertions, 103 deletions
diff --git a/games/penguin-command/Makefile b/games/penguin-command/Makefile
index 8a9670973be0..11d3698d0641 100644
--- a/games/penguin-command/Makefile
+++ b/games/penguin-command/Makefile
@@ -10,18 +10,26 @@ MASTER_SITES= SF
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= A clone of the classic game Missile Command
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- jpeg:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg
USE_SDL= mixer image sdl
GNU_CONFIGURE= yes
-MAN6= penguin-command.6 penguin-command.ja.6
+PLIST_FILES= bin/${PORTNAME} \
+ man/man6/penguin-command.6.gz \
+ man/man6/penguin-command.ja.6.gz
+PORTDATA= *
+
+DESKTOP_ENTRIES="Penguin Command" \
+ "${COMMENT}" \
+ "${DATADIR}/gfx/icon.xpm" \
+ "${PORTNAME}" \
+ "Game;ArcadeGame;" \
+ ""
-NO_STAGE= yes
post-patch:
- @${REINPLACE_CMD} 's| -lSDL | |g' ${WRKSRC}/configure
- @${REINPLACE_CMD} 's|LIBS="-lSDL_image|LIBS="-lSDL_image $$SDL_LIBS|g' \
- ${WRKSRC}/configure
+ @${REINPLACE_CMD} 's|LIBS="-lSDL_image|LIBS="-lSDL_image $$SDL_LIBS|g; \
+ s| -lSDL | |g' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/games/penguin-command/pkg-plist b/games/penguin-command/pkg-plist
deleted file mode 100644
index ce8876d76fd7..000000000000
--- a/games/penguin-command/pkg-plist
+++ /dev/null
@@ -1,96 +0,0 @@
-bin/penguin-command
-%%DATADIR%%/gfx/10explo.png
-%%DATADIR%%/gfx/10flyer.png
-%%DATADIR%%/gfx/11explo.png
-%%DATADIR%%/gfx/11flyer.png
-%%DATADIR%%/gfx/12explo.png
-%%DATADIR%%/gfx/12flyer.png
-%%DATADIR%%/gfx/13explo.png
-%%DATADIR%%/gfx/13flyer.png
-%%DATADIR%%/gfx/14explo.png
-%%DATADIR%%/gfx/14flyer.png
-%%DATADIR%%/gfx/15explo.png
-%%DATADIR%%/gfx/15flyer.png
-%%DATADIR%%/gfx/16explo.png
-%%DATADIR%%/gfx/16flyer.png
-%%DATADIR%%/gfx/17explo.png
-%%DATADIR%%/gfx/18explo.png
-%%DATADIR%%/gfx/19explo.png
-%%DATADIR%%/gfx/1cursor.png
-%%DATADIR%%/gfx/1explo.png
-%%DATADIR%%/gfx/1flyer.png
-%%DATADIR%%/gfx/20explo.png
-%%DATADIR%%/gfx/2cursor.png
-%%DATADIR%%/gfx/2explo.png
-%%DATADIR%%/gfx/2flyer.png
-%%DATADIR%%/gfx/3cursor.png
-%%DATADIR%%/gfx/3explo.png
-%%DATADIR%%/gfx/3flyer.png
-%%DATADIR%%/gfx/4cursor.png
-%%DATADIR%%/gfx/4explo.png
-%%DATADIR%%/gfx/4flyer.png
-%%DATADIR%%/gfx/5cursor.png
-%%DATADIR%%/gfx/5explo.png
-%%DATADIR%%/gfx/5flyer.png
-%%DATADIR%%/gfx/6cursor.png
-%%DATADIR%%/gfx/6explo.png
-%%DATADIR%%/gfx/6flyer.png
-%%DATADIR%%/gfx/7cursor.png
-%%DATADIR%%/gfx/7explo.png
-%%DATADIR%%/gfx/7flyer.png
-%%DATADIR%%/gfx/8cursor.png
-%%DATADIR%%/gfx/8explo.png
-%%DATADIR%%/gfx/8flyer.png
-%%DATADIR%%/gfx/9cursor.png
-%%DATADIR%%/gfx/9explo.png
-%%DATADIR%%/gfx/9flyer.png
-%%DATADIR%%/gfx/abc.png
-%%DATADIR%%/gfx/back.jpg
-%%DATADIR%%/gfx/bomb1.png
-%%DATADIR%%/gfx/bomb10.png
-%%DATADIR%%/gfx/bomb2.png
-%%DATADIR%%/gfx/bomb3.png
-%%DATADIR%%/gfx/bomb4.png
-%%DATADIR%%/gfx/bomb5.png
-%%DATADIR%%/gfx/bomb6.png
-%%DATADIR%%/gfx/bomb7.png
-%%DATADIR%%/gfx/bomb8.png
-%%DATADIR%%/gfx/bomb9.png
-%%DATADIR%%/gfx/cannon1.png
-%%DATADIR%%/gfx/cannon10.png
-%%DATADIR%%/gfx/cannon11.png
-%%DATADIR%%/gfx/cannon12.png
-%%DATADIR%%/gfx/cannon13.png
-%%DATADIR%%/gfx/cannon14.png
-%%DATADIR%%/gfx/cannon15.png
-%%DATADIR%%/gfx/cannon16.png
-%%DATADIR%%/gfx/cannon17.png
-%%DATADIR%%/gfx/cannon18.png
-%%DATADIR%%/gfx/cannon19.png
-%%DATADIR%%/gfx/cannon2.png
-%%DATADIR%%/gfx/cannon20.png
-%%DATADIR%%/gfx/cannon21.png
-%%DATADIR%%/gfx/cannon3.png
-%%DATADIR%%/gfx/cannon4.png
-%%DATADIR%%/gfx/cannon5.png
-%%DATADIR%%/gfx/cannon6.png
-%%DATADIR%%/gfx/cannon7.png
-%%DATADIR%%/gfx/cannon8.png
-%%DATADIR%%/gfx/cannon9.png
-%%DATADIR%%/gfx/cannonhit.png
-%%DATADIR%%/gfx/city.png
-%%DATADIR%%/gfx/cityhit.png
-%%DATADIR%%/gfx/icon.xpm
-%%DATADIR%%/gfx/shot.png
-%%DATADIR%%/gfx/title.jpg
-%%DATADIR%%/sound/Machine.wav
-%%DATADIR%%/sound/Wooeep.wav
-%%DATADIR%%/sound/bombex.wav
-%%DATADIR%%/sound/click.wav
-%%DATADIR%%/sound/datajack.s3m
-%%DATADIR%%/sound/icefront.s3m
-%%DATADIR%%/sound/missex.wav
-%%DATADIR%%/sound/ramagard.s3m
-@dirrm %%DATADIR%%/sound
-@dirrm %%DATADIR%%/gfx
-@dirrm %%DATADIR%%