aboutsummaryrefslogtreecommitdiff
path: root/games/pinball
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-12-13 16:26:19 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-12-13 16:26:19 +0000
commit1a477d2b3763d432c0deb9611bf5f7f0a0b0318f (patch)
tree6be6cfd8b65bd4465a8b312a92d4fb52e35aee04 /games/pinball
parent8236d3cc024ac007f0b02108ddf59a31265a57f7 (diff)
downloadports-1a477d2b3763d432c0deb9611bf5f7f0a0b0318f.tar.gz
ports-1a477d2b3763d432c0deb9611bf5f7f0a0b0318f.zip
- Fix build with libc++ 3.9
- Add LICENSE_FILE - Switch to USES=localbase - Simplify docs installation PR: 214651 Reported by: jbeich Approved by: maintainer timeout (thierry, 3 weeks)
Notes
Notes: svn path=/head/; revision=428507
Diffstat (limited to 'games/pinball')
-rw-r--r--games/pinball/Makefile19
-rw-r--r--games/pinball/files/patch-base_Config.cpp13
2 files changed, 20 insertions, 12 deletions
diff --git a/games/pinball/Makefile b/games/pinball/Makefile
index 01272a456756..670e67a07e1b 100644
--- a/games/pinball/Makefile
+++ b/games/pinball/Makefile
@@ -11,13 +11,15 @@ MAINTAINER= thierry@FreeBSD.org
COMMENT= Emilia Pinball is a free pinball game
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
-USES= gmake libtool:keepla # .la needed for plugin loading
-USE_GL= gl
+USES= gmake localbase:ldflags libtool:keepla # .la needed for plugin loading
+USE_GL= gl glu
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --without-debug
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} --without-debug
+CPPFLAGS+= -DRZR_LIBSTATIC
OPTIONS_DEFINE= DOCS
@@ -29,13 +31,8 @@ USE_GL+= glu
.else
USE_SDL= image mixer sdl
.endif
-
-CPPFLAGS+= -I${LOCALBASE}/include -DRZR_LIBSTATIC
-LDFLAGS+= -L${LOCALBASE}/lib
#MAKE_JOBS_UNSAFE= yes
-DOCS= README
-
# For gmake>=3.82
pre-configure:
@${FIND} ${WRKSRC} -name Makefile.in -print | ${XARGS} \
@@ -49,9 +46,7 @@ post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/pinball/lib*.so*
post-install-DOCS-on:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for FILE in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${FILE} ${STAGEDIR}${DOCSDIR}
-.endfor
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/games/pinball/files/patch-base_Config.cpp b/games/pinball/files/patch-base_Config.cpp
new file mode 100644
index 000000000000..5883b7f0d00a
--- /dev/null
+++ b/games/pinball/files/patch-base_Config.cpp
@@ -0,0 +1,13 @@
+--- base/Config.cpp.orig 2003-11-21 07:59:09 UTC
++++ base/Config.cpp
+@@ -423,8 +423,8 @@ void Config::setPaths(char const * const
+ m_sDataDir = string(EM_DATADIR) + "/";
+ m_sExeDir = "./";
+ if ( *( m_sDataDir.c_str() ) != '/' ) {
+- char* ptr=0;
+- char* ptrw = 0;
++ const char* ptr=0;
++ const char* ptrw = 0;
+ //cout<<"relative to exe file"<<endl;
+ ptr = (strrchr(argv0,'/')); // unix /cygwin / check win32
+ #ifdef WIN32