aboutsummaryrefslogtreecommitdiff
path: root/games/pinball
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-01-17 21:48:57 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-01-17 21:48:57 +0000
commit3c3ec2c36a7939af57ab2e801872afc0cfee4880 (patch)
tree7b0cf621183be373baaa3f537253b467e172c6ce /games/pinball
parent2144b2af430058db4559f57adf3d980459767267 (diff)
downloadports-3c3ec2c36a7939af57ab2e801872afc0cfee4880.tar.gz
ports-3c3ec2c36a7939af57ab2e801872afc0cfee4880.zip
games/pinball: fix build on GCC architectures
Pinball.cpp:733: error: expected `(' before '{' token Pinball.cpp: At global scope: Pinball.cpp:733: error: mixing declarations and function-definitions is forbidden Pinball.cpp:733: error: a function-definition is not allowed here before '{' token Pinball.cpp:733: error: expected unqualified-id before ',' token Pinball.cpp:733: error: a function-definition is not allowed here before '{' token Pinball.cpp:733: error: expected unqualified-id before ',' token Pinball.cpp:733: error: a function-definition is not allowed here before '{' token Pinball.cpp:734: error: expected unqualified-id before '{' token MFH: 2021O1
Notes
Notes: svn path=/head/; revision=561873
Diffstat (limited to 'games/pinball')
-rw-r--r--games/pinball/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/games/pinball/Makefile b/games/pinball/Makefile
index c4de18557adb..d645df11f04d 100644
--- a/games/pinball/Makefile
+++ b/games/pinball/Makefile
@@ -16,8 +16,8 @@ LIB_DEPENDS= libltdl.so:devel/libltdl
USE_GITHUB= yes
GH_ACCOUNT= adoptware
-USES= autoreconf gl gmake localbase:ldflags libtool:keepla \
- pkgconfig sdl xorg # .la needed for plugin loading
+USES= autoreconf compiler:c++11-lang gl gmake localbase:ldflags \
+ libtool:keepla pkgconfig sdl xorg # .la needed for plugin loading
USE_XORG= ice sm
USE_GL= gl glu
USE_SDL= image mixer sdl