aboutsummaryrefslogtreecommitdiff
path: root/games/pinball
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2019-06-28 17:47:22 +0000
committerThierry Thomas <thierry@FreeBSD.org>2019-06-28 17:47:22 +0000
commit6eab0b176b85d672224ebf798b76194e84a03023 (patch)
tree5954d71713446a28918bdb07e0a75b3f72ada2e9 /games/pinball
parentc6f131c3c0923676249f3cf40c4f97283d70122f (diff)
downloadports-6eab0b176b85d672224ebf798b76194e84a03023.tar.gz
ports-6eab0b176b85d672224ebf798b76194e84a03023.zip
There is no more activity on the SourceForce site, switch to a more
active fork on GitHub. Update to their latest release.
Notes
Notes: svn path=/head/; revision=505292
Diffstat (limited to 'games/pinball')
-rw-r--r--games/pinball/Makefile31
-rw-r--r--games/pinball/distinfo5
-rw-r--r--games/pinball/files/patch-Makefile.am15
-rw-r--r--games/pinball/files/patch-Makefile.in20
-rw-r--r--games/pinball/files/patch-base_Behavior.h2
-rw-r--r--games/pinball/files/patch-base_Config.cpp13
-rw-r--r--games/pinball/files/patch-base__TextureUtil.cpp8
-rw-r--r--games/pinball/files/patch-configure66
-rw-r--r--games/pinball/files/patch-configure.ac21
-rw-r--r--games/pinball/files/patch-data_Makefile.in11
-rw-r--r--games/pinball/files/patch-data__tux__ModuleTux.cpp11
-rw-r--r--games/pinball/files/patch-data_hurd_ModuleHurd.cpp10
-rw-r--r--games/pinball/files/patch-src_Makefile.am11
-rw-r--r--games/pinball/files/patch-src_Makefile.in20
-rw-r--r--games/pinball/files/patch-src__EyeBehavior.cpp12
-rw-r--r--games/pinball/files/patch-src__Loader.cpp4
-rw-r--r--games/pinball/files/patch-test_Makefile.am11
-rw-r--r--games/pinball/pkg-plist101
18 files changed, 196 insertions, 176 deletions
diff --git a/games/pinball/Makefile b/games/pinball/Makefile
index 1a339e83f226..b09b463f862b 100644
--- a/games/pinball/Makefile
+++ b/games/pinball/Makefile
@@ -2,10 +2,8 @@
# $FreeBSD$
PORTNAME= pinball
-PORTVERSION= 0.3.1
-PORTREVISION= 22
+PORTVERSION= 0.3.4
CATEGORIES= games
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= thierry@FreeBSD.org
COMMENT= Emilia Pinball is a free pinball game
@@ -13,34 +11,27 @@ COMMENT= Emilia Pinball is a free pinball game
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= gl gmake localbase:ldflags libtool:keepla # .la needed for plugin loading
+LIB_DEPENDS= libltdl.so:devel/libltdl
+
+USE_GITHUB= yes
+GH_ACCOUNT= sergiomb2
+
+USES= autoreconf gl gettext gmake localbase:ldflags libtool:keepla # .la needed for plugin loading
+USES+= sdl
USE_XORG= ice sm
USE_GL= gl glu
+USE_SDL= image mixer sdl
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-debug
CPPFLAGS+= -DRZR_LIBSTATIC
+MAKE_JOBS_UNSAFE=yes
OPTIONS_DEFINE= DOCS
-.if defined(WITH_ALLEGRO)
-BROKEN= support with Allegro is (temporarily?) broken as of version 0.3.1
-LIB_DEPENDS+= liballeg.so:devel/allegro
-CONFIGURE_ARGS+= --with-allegro
-USE_GL+= glu
-.else
-USES+= sdl
-USE_SDL= image mixer sdl
-.endif
-
-# For gmake>=3.82
-pre-configure:
- ${FIND} ${WRKSRC} -name Makefile.in -print | ${XARGS} \
- ${REINPLACE_CMD} -e 's,^dnl,# dnl,'
-
-post-install:
+post-install.orig:
${MV} ${STAGEDIR}/var/games/pinball/professor/highscores \
${STAGEDIR}/var/games/pinball/professor/highscores.sample
${MV} ${STAGEDIR}/var/games/pinball/tux/highscores \
diff --git a/games/pinball/distinfo b/games/pinball/distinfo
index 595411b24edb..f9ce775635d2 100644
--- a/games/pinball/distinfo
+++ b/games/pinball/distinfo
@@ -1,2 +1,3 @@
-SHA256 (pinball-0.3.1.tar.gz) = ba47989f7fb6e294faa95285563220c8b01c3dbb9aa1bc29828eb7e832855cb8
-SIZE (pinball-0.3.1.tar.gz) = 6082982
+TIMESTAMP = 1561318996
+SHA256 (sergiomb2-pinball-0.3.4_GH0.tar.gz) = c5b7a3992fd681c0d9a907461c2c68a8d868e9e15178534529ce7b9366698542
+SIZE (sergiomb2-pinball-0.3.4_GH0.tar.gz) = 24822463
diff --git a/games/pinball/files/patch-Makefile.am b/games/pinball/files/patch-Makefile.am
new file mode 100644
index 000000000000..06c73a5c7636
--- /dev/null
+++ b/games/pinball/files/patch-Makefile.am
@@ -0,0 +1,15 @@
+--- Makefile.am.orig 2018-03-24 23:40:31 UTC
++++ Makefile.am
+@@ -1,6 +1,6 @@
+ AUTOMAKE_OPTIONS = gnu
+
+-SUBDIRS = libltdl addon base data src test
++SUBDIRS = addon base data src test
+
+ EXTRA_DIST = bootstrap pinball.spec clean pinball.desktop
+
+@@ -10,4 +10,3 @@ pininclude_HEADERS = pinconfig.h
+
+ bin_SCRIPTS = pinball-config
+
+-ACLOCAL_AMFLAGS = -I libltdl/m4
diff --git a/games/pinball/files/patch-Makefile.in b/games/pinball/files/patch-Makefile.in
deleted file mode 100644
index ad0e3a83eef1..000000000000
--- a/games/pinball/files/patch-Makefile.in
+++ /dev/null
@@ -1,20 +0,0 @@
---- Makefile.in.orig 2003-12-10 12:35:31.000000000 +0100
-+++ Makefile.in 2014-04-13 21:03:05.000000000 +0200
-@@ -107,7 +107,7 @@
- install_sh = @install_sh@
- AUTOMAKE_OPTIONS = gnu
-
--SUBDIRS = libltdl addon base data src test
-+SUBDIRS = addon base data src test
-
- EXTRA_DIST = bootstrap pinball.spec clean pinball.desktop
-
-@@ -243,7 +243,7 @@
- else \
- local_target="$$target"; \
- fi; \
-- (cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) $$local_target) \
-+ ($(MAKE) -C $$subdir $(AM_MAKEFLAGS) $$local_target) \
- || case "$$amf" in *=*) exit 1;; *k*) fail=yes;; *) exit 1;; esac; \
- done; \
- if test "$$dot_seen" = "no"; then \
diff --git a/games/pinball/files/patch-base_Behavior.h b/games/pinball/files/patch-base_Behavior.h
index 4b77456d2ba1..0e4e2cd8c76b 100644
--- a/games/pinball/files/patch-base_Behavior.h
+++ b/games/pinball/files/patch-base_Behavior.h
@@ -1,4 +1,4 @@
---- base/Behavior.h.orig 2003-11-20 16:46:16.000000000 +0000
+--- base/Behavior.h.orig 2018-03-24 23:40:31 UTC
+++ base/Behavior.h
@@ -10,6 +10,7 @@
#ifndef BEHAVIOR_H
diff --git a/games/pinball/files/patch-base_Config.cpp b/games/pinball/files/patch-base_Config.cpp
deleted file mode 100644
index 5883b7f0d00a..000000000000
--- a/games/pinball/files/patch-base_Config.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
---- base/Config.cpp.orig 2003-11-21 07:59:09 UTC
-+++ base/Config.cpp
-@@ -423,8 +423,8 @@ void Config::setPaths(char const * const
- m_sDataDir = string(EM_DATADIR) + "/";
- m_sExeDir = "./";
- if ( *( m_sDataDir.c_str() ) != '/' ) {
-- char* ptr=0;
-- char* ptrw = 0;
-+ const char* ptr=0;
-+ const char* ptrw = 0;
- //cout<<"relative to exe file"<<endl;
- ptr = (strrchr(argv0,'/')); // unix /cygwin / check win32
- #ifdef WIN32
diff --git a/games/pinball/files/patch-base__TextureUtil.cpp b/games/pinball/files/patch-base__TextureUtil.cpp
index 507c733c0f46..0a2b925da8ce 100644
--- a/games/pinball/files/patch-base__TextureUtil.cpp
+++ b/games/pinball/files/patch-base__TextureUtil.cpp
@@ -1,6 +1,6 @@
---- ./base/TextureUtil.cpp.orig Thu Nov 20 17:46:16 2003
-+++ ./base/TextureUtil.cpp Fri Dec 12 21:14:17 2003
-@@ -54,6 +54,7 @@
+--- base/TextureUtil.cpp.orig 2018-03-24 23:40:31 UTC
++++ base/TextureUtil.cpp
+@@ -54,6 +54,7 @@ extern "C" {
#if EM_USE_ALLEGRO
#include <allegro.h>
@@ -8,7 +8,7 @@
BITMAP * backbuffer = NULL;
ZBUFFER * zbuffer = NULL;
#endif // EM_USE_ALLEGRO
-@@ -333,9 +334,10 @@
+@@ -333,9 +334,10 @@ int TextureUtil::genTexture( char const * const filena
EmTexture * const texture)
{
//cout<<"+ Texture::genTexture : "<<filename<<endl;
diff --git a/games/pinball/files/patch-configure b/games/pinball/files/patch-configure
deleted file mode 100644
index a4ab9ef7d213..000000000000
--- a/games/pinball/files/patch-configure
+++ /dev/null
@@ -1,66 +0,0 @@
---- configure.orig Wed Dec 10 12:34:54 2003
-+++ configure Thu Dec 11 20:59:05 2003
-@@ -431,7 +431,7 @@
- PACKAGE_STRING='pinball 0.3.1'
- PACKAGE_BUGREPORT='henqvist@users.sourceforge.net'
-
--ac_subdirs_all="$ac_subdirs_all libltdl"
-+ac_subdirs_all="$ac_subdirs_all"
- # Factoring default headers for most tests.
- ac_includes_default="\
- #include <stdio.h>
-@@ -1954,12 +1954,12 @@
-
-
-
--CFLAGS="-g -W -Wall -O2"
--CXXFLAGS="-g -W -Wall -O2"
-+#CFLAGS="-g -W -Wall -O2"
-+#CXXFLAGS="-g -W -Wall -O2"
-
-
-
--subdirs="$subdirs libltdl"
-+subdirs="$subdirs"
-
-
- ac_ext=c
-@@ -3439,18 +3439,6 @@
- test -z "$INSTALL_DATA" && INSTALL_DATA='${INSTALL} -m 644'
-
-
-- case $enable_ltdl_convenience in
-- no) { { echo "$as_me:$LINENO: error: this package needs a convenience libltdl" >&5
--echo "$as_me: error: this package needs a convenience libltdl" >&2;}
-- { (exit 1); exit 1; }; } ;;
-- "") enable_ltdl_convenience=yes
-- ac_configure_args="$ac_configure_args --enable-ltdl-convenience" ;;
-- esac
-- LIBLTDL='${top_builddir}/''libltdl'/libltdlc.la
-- LTDLINCL='-I${top_srcdir}/''libltdl'
-- # For backwards non-gettext consistent compatibility...
-- INCLTDL="$LTDLINCL"
--
- # Check whether --enable-shared or --disable-shared was given.
- if test "${enable_shared+set}" = set; then
- enableval="$enable_shared"
-@@ -11061,7 +11049,7 @@
-
-
- # Check whether --with-debug or --without-debug was given.
--if test "${with_debug+set}" = set; then
-+if test "set${with_debug}" = "set"; then
- withval="$with_debug"
- use_debug="yes"
- else
-@@ -11788,8 +11776,8 @@
- s,@CPP@,$CPP,;t t
- s,@EGREP@,$EGREP,;t t
- s,@LIBTOOL@,$LIBTOOL,;t t
--s,@INCLTDL@,$INCLTDL,;t t
--s,@LIBLTDL@,$LIBLTDL,;t t
-+s,@INCLTDL@,,;t t
-+s,@LIBLTDL@,,;t t
- s,@EM_DATADIR@,$EM_DATADIR,;t t
- s,@EM_LIBDIR@,$EM_LIBDIR,;t t
- s,@EM_BUILD_ROOT@,$EM_BUILD_ROOT,;t t
diff --git a/games/pinball/files/patch-configure.ac b/games/pinball/files/patch-configure.ac
new file mode 100644
index 000000000000..71e4b04bbf59
--- /dev/null
+++ b/games/pinball/files/patch-configure.ac
@@ -0,0 +1,21 @@
+--- configure.ac.orig 2018-03-24 23:40:31 UTC
++++ configure.ac
+@@ -4,9 +4,6 @@ dnl init autoconf and automake
+ AC_INIT(pinball, 0.3.4.1)
+
+ AC_CONFIG_HEADERS(pinconfig.h)
+-LT_CONFIG_LTDL_DIR([libltdl])
+-AC_CONFIG_AUX_DIR([libltdl/config])
+-AC_CONFIG_MACRO_DIR([libltdl/m4])
+
+ AC_CANONICAL_HOST
+ AC_CANONICAL_TARGET
+@@ -22,7 +19,7 @@ AC_PROG_MKDIR_P
+ AM_GNU_GETTEXT([external])
+ #For rhel6 but rhel6 doesn't have SDL2
+ #AM_GNU_GETTEXT_VERSION(0.17)
+-AM_GNU_GETTEXT_VERSION(0.19.8)
++AM_GNU_GETTEXT_VERSION(0.20)
+
+ dnl this is a c++ program
+ dnl CFLAGS="-g -W -Wall -O2"
diff --git a/games/pinball/files/patch-data_Makefile.in b/games/pinball/files/patch-data_Makefile.in
deleted file mode 100644
index 845ab44caadc..000000000000
--- a/games/pinball/files/patch-data_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- data/Makefile.in.orig 2003-12-10 12:34:46.000000000 +0100
-+++ data/Makefile.in 2014-04-13 21:09:57.000000000 +0200
-@@ -189,7 +189,7 @@
- else \
- local_target="$$target"; \
- fi; \
-- (cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) $$local_target) \
-+ ($(MAKE) -C $$subdir $(AM_MAKEFLAGS) $$local_target) \
- || case "$$amf" in *=*) exit 1;; *k*) fail=yes;; *) exit 1;; esac; \
- done; \
- if test "$$dot_seen" = "no"; then \
diff --git a/games/pinball/files/patch-data__tux__ModuleTux.cpp b/games/pinball/files/patch-data__tux__ModuleTux.cpp
index f6d45d46493c..c070d7387763 100644
--- a/games/pinball/files/patch-data__tux__ModuleTux.cpp
+++ b/games/pinball/files/patch-data__tux__ModuleTux.cpp
@@ -1,5 +1,5 @@
---- data/tux/ModuleTux.cpp.orig Thu Nov 20 17:46:17 2003
-+++ data/tux/ModuleTux.cpp Fri Dec 12 21:30:15 2003
+--- data/tux/ModuleTux.cpp.orig 2018-03-24 23:40:31 UTC
++++ data/tux/ModuleTux.cpp
@@ -7,6 +7,7 @@
***************************************************************************/
@@ -8,11 +8,12 @@
#include "Behavior.h"
#include "Group.h"
#include "Pinball.h"
-@@ -15,7 +16,6 @@
+@@ -15,7 +16,7 @@
#include "Score.h"
#include "Keyboard.h"
#include "Table.h"
-#include "Config.h"
++#include <libintl.h>
+
+ #include <locale>
- #define MISSION_TEXT_TIMEOUT 6000
- #define INFO_TEXT_TIME 600
diff --git a/games/pinball/files/patch-data_hurd_ModuleHurd.cpp b/games/pinball/files/patch-data_hurd_ModuleHurd.cpp
new file mode 100644
index 000000000000..2b2e5bf6fde1
--- /dev/null
+++ b/games/pinball/files/patch-data_hurd_ModuleHurd.cpp
@@ -0,0 +1,10 @@
+--- data/hurd/ModuleHurd.cpp.orig 2018-03-24 23:40:31 UTC
++++ data/hurd/ModuleHurd.cpp
+@@ -24,6 +24,7 @@
+ #include "Keyboard.h"
+ #include "Table.h"
+ #include "Config.h"
++#include <libintl.h>
+
+ #include <locale>
+
diff --git a/games/pinball/files/patch-src_Makefile.am b/games/pinball/files/patch-src_Makefile.am
new file mode 100644
index 000000000000..c746b37b2c0b
--- /dev/null
+++ b/games/pinball/files/patch-src_Makefile.am
@@ -0,0 +1,11 @@
+--- src/Makefile.am.orig 2018-03-24 23:40:31 UTC
++++ src/Makefile.am
+@@ -10,7 +10,7 @@ bin_PROGRAMS = pinball
+ AM_CPPFLAGS = -I../base -I../addon @INCLTDL@
+
+ pinball_LDADD = \
+- libemilia_pin.a ../addon/libemilia_addon.a ../base/libemilia_base.a @LIBLTDL@
++ libemilia_pin.a ../addon/libemilia_addon.a ../base/libemilia_base.a @LIBLTDL@ @LIBINTL@
+
+ pinball_LDFLAGS = -export-dynamic
+
diff --git a/games/pinball/files/patch-src_Makefile.in b/games/pinball/files/patch-src_Makefile.in
deleted file mode 100644
index 50ad0cd8c2e5..000000000000
--- a/games/pinball/files/patch-src_Makefile.in
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/Makefile.in.orig 2003-12-10 12:34:47.000000000 +0100
-+++ src/Makefile.in 2014-04-13 21:22:52.000000000 +0200
-@@ -116,7 +116,7 @@
-
- INCLUDES = -I../base -I../addon @INCLTDL@
-
--pinball_LDADD = ../src/libemilia_pin.a ../addon/libemilia_addon.a ../base/libemilia_base.a @LIBLTDL@
-+pinball_LDADD = libemilia_pin.a ../addon/libemilia_addon.a ../base/libemilia_base.a @LIBLTDL@
- pinball_LDFLAGS = -export-dynamic
-
- pinball_SOURCES = Pinball.cpp
-@@ -174,7 +174,7 @@
-
- am_pinball_OBJECTS = Pinball.$(OBJEXT)
- pinball_OBJECTS = $(am_pinball_OBJECTS)
--pinball_DEPENDENCIES = ../src/libemilia_pin.a ../addon/libemilia_addon.a \
-+pinball_DEPENDENCIES = libemilia_pin.a ../addon/libemilia_addon.a \
- ../base/libemilia_base.a
-
- DEFS = @DEFS@
diff --git a/games/pinball/files/patch-src__EyeBehavior.cpp b/games/pinball/files/patch-src__EyeBehavior.cpp
index 53e85792c157..bea972238652 100644
--- a/games/pinball/files/patch-src__EyeBehavior.cpp
+++ b/games/pinball/files/patch-src__EyeBehavior.cpp
@@ -1,6 +1,6 @@
---- src/EyeBehavior.cpp.orig Thu Nov 20 17:46:17 2003
-+++ src/EyeBehavior.cpp Thu Dec 11 21:02:38 2003
-@@ -56,6 +56,7 @@
+--- src/EyeBehavior.cpp.orig 2018-03-24 23:40:31 UTC
++++ src/EyeBehavior.cpp
+@@ -56,6 +56,7 @@ void EyeBehavior::onTick() {
EmAssert(table->getBall(2) != NULL, "Ball3 group NULL");
EmAssert(this->getParent() != NULL, "Parent group NULL");
@@ -8,9 +8,9 @@
// shortcuts for changing view F1, F2, F2, F4 // now F5 F6 F7 F8
// I changed to F5 F6 F7 F8 to use the Alt+F4 quit shortcut //!rzr
if (Keyboard::isKeyDown(SDLK_F5)) {
-@@ -67,6 +68,7 @@
- } else if (Keyboard::isKeyDown(SDLK_F8)) {
- Config::getInstance()->setView(3);
+@@ -71,6 +72,7 @@ void EyeBehavior::onTick() {
+ } else if (Keyboard::isKeyDown(SDLK_F10)) { //rotated screen
+ Config::getInstance()->setView(5);
}
+#endif
diff --git a/games/pinball/files/patch-src__Loader.cpp b/games/pinball/files/patch-src__Loader.cpp
index f74923316e7d..5bda5d3ee335 100644
--- a/games/pinball/files/patch-src__Loader.cpp
+++ b/games/pinball/files/patch-src__Loader.cpp
@@ -1,5 +1,5 @@
---- ./src/Loader.cpp.orig Thu Nov 20 17:46:17 2003
-+++ ./src/Loader.cpp Fri Dec 12 21:31:48 2003
+--- src/Loader.cpp.orig 2018-03-24 23:40:31 UTC
++++ src/Loader.cpp
@@ -17,6 +17,7 @@
#include <iostream>
diff --git a/games/pinball/files/patch-test_Makefile.am b/games/pinball/files/patch-test_Makefile.am
new file mode 100644
index 000000000000..a20ba5a3d7b0
--- /dev/null
+++ b/games/pinball/files/patch-test_Makefile.am
@@ -0,0 +1,11 @@
+--- test/Makefile.am.orig 2018-03-24 23:40:31 UTC
++++ test/Makefile.am
+@@ -6,7 +6,7 @@ testdatadir = $(pkgdatadir)
+ noinst_PROGRAMS = scale simple light texture load explode collision signal billboard font thread menu joy sound trans math misc varray unittest
+
+ AM_CPPFLAGS = -I../base -I../addon -I../src @INCLTDL@
+-LDADD = ../src/libemilia_pin.a ../addon/libemilia_addon.a ../base/libemilia_base.a @LIBLTDL@
++LDADD = ../src/libemilia_pin.a ../addon/libemilia_addon.a ../base/libemilia_base.a @LIBLTDL@ @LIBINTL@
+
+ testlib_LTLIBRARIES = libModuleTest.la
+
diff --git a/games/pinball/pkg-plist b/games/pinball/pkg-plist
index 76527510e723..755e5153e97d 100644
--- a/games/pinball/pkg-plist
+++ b/games/pinball/pkg-plist
@@ -62,11 +62,26 @@ include/pinball/TextureUtil.h
include/pinball/TransformVisitor.h
include/pinball/Visitor.h
include/pinball/pinconfig.h
+lib/pinball/libModuleGnu.a
+lib/pinball/libModuleGnu.la
+lib/pinball/libModuleGnu.so
+lib/pinball/libModuleGnu.so.0
+lib/pinball/libModuleGnu.so.0.0.0
+lib/pinball/libModuleHurd.a
+lib/pinball/libModuleHurd.la
+lib/pinball/libModuleHurd.so
+lib/pinball/libModuleHurd.so.0
+lib/pinball/libModuleHurd.so.0.0.0
lib/pinball/libModuleProfessor.a
lib/pinball/libModuleProfessor.la
lib/pinball/libModuleProfessor.so
lib/pinball/libModuleProfessor.so.0
lib/pinball/libModuleProfessor.so.0.0.0
+lib/pinball/libModuleProfessor2.a
+lib/pinball/libModuleProfessor2.la
+lib/pinball/libModuleProfessor2.so
+lib/pinball/libModuleProfessor2.so.0
+lib/pinball/libModuleProfessor2.so.0.0.0
lib/pinball/libModuleTest.a
lib/pinball/libModuleTest.la
lib/pinball/libModuleTest.so
@@ -81,8 +96,66 @@ lib/pinball/libemilia_addon.a
lib/pinball/libemilia_base.a
lib/pinball/libemilia_pin.a
%%PORTDOCS%%%%DOCSDIR%%/README
+share/locale/de_DE/LC_MESSAGES/pinball.mo
+share/locale/fr_FR/LC_MESSAGES/pinball.mo
+share/locale/pt_PT/LC_MESSAGES/pinball.mo
%%DATADIR%%/font_34.png
%%DATADIR%%/font_35.pcx
+%%DATADIR%%/gnu/bump.ogg
+%%DATADIR%%/gnu/bumpsoft.wav
+%%DATADIR%%/gnu/flip2b.ogg
+%%DATADIR%%/gnu/flip2br.ogg
+%%DATADIR%%/gnu/free_all.ogg
+%%DATADIR%%/gnu/free_letter.ogg
+%%DATADIR%%/gnu/freeball.ogg
+%%DATADIR%%/gnu/freedom0.ogg
+%%DATADIR%%/gnu/freedom1.ogg
+%%DATADIR%%/gnu/freedom2.ogg
+%%DATADIR%%/gnu/freedom3.ogg
+%%DATADIR%%/gnu/gnu.png
+%%DATADIR%%/gnu/gnu2b.png
+%%DATADIR%%/gnu/gnu_all.ogg
+%%DATADIR%%/gnu/gnu_letter.ogg
+%%DATADIR%%/gnu/gplv1.ogg
+%%DATADIR%%/gnu/gplv2.ogg
+%%DATADIR%%/gnu/gplv3.ogg
+%%DATADIR%%/gnu/hit-freeball-target.ogg
+%%DATADIR%%/gnu/hit-freedom-target.ogg
+%%DATADIR%%/gnu/knockdown.ogg
+%%DATADIR%%/gnu/lock.ogg
+%%DATADIR%%/gnu/multiball.wav
+%%DATADIR%%/gnu/music.ogg
+%%DATADIR%%/gnu/nudge.wav
+%%DATADIR%%/gnu/pinball.pbl
+%%DATADIR%%/gnu/plunger.wav
+%%DATADIR%%/gnu/raise-stopper.ogg
+%%DATADIR%%/gnu/reset_knockdowns.ogg
+%%DATADIR%%/gnu/shoot.ogg
+%%DATADIR%%/gnu/tiles.png
+%%DATADIR%%/gnu/tiles2.png
+%%DATADIR%%/gnu/tiles3.png
+%%DATADIR%%/hurd/Wood.jpg
+%%DATADIR%%/hurd/bump.wav
+%%DATADIR%%/hurd/bumphard.wav
+%%DATADIR%%/hurd/bumpsoft.wav
+%%DATADIR%%/hurd/flip.wav
+%%DATADIR%%/hurd/floor-room.jpg
+%%DATADIR%%/hurd/floor.png
+%%DATADIR%%/hurd/floor3.png
+%%DATADIR%%/hurd/game.ogg
+%%DATADIR%%/hurd/gameover.wav
+%%DATADIR%%/hurd/gnu.png
+%%DATADIR%%/hurd/hurd.png
+%%DATADIR%%/hurd/intro.ogg
+%%DATADIR%%/hurd/label.png
+%%DATADIR%%/hurd/loop.wav
+%%DATADIR%%/hurd/nudge.wav
+%%DATADIR%%/hurd/pinball.pbl
+%%DATADIR%%/hurd/shoot.wav
+%%DATADIR%%/hurd/sub.png
+%%DATADIR%%/hurd/tiles.png
+%%DATADIR%%/hurd/tiles2.png
+%%DATADIR%%/hurd/up.wav
%%DATADIR%%/pinball.xpm
%%DATADIR%%/professor/bump.wav
%%DATADIR%%/professor/bumphard.wav
@@ -96,6 +169,28 @@ lib/pinball/libemilia_pin.a
%%DATADIR%%/professor/pinball.pbl
%%DATADIR%%/professor/professor.ogg
%%DATADIR%%/professor/professor.png
+%%DATADIR%%/professor2/blue.png
+%%DATADIR%%/professor2/blue2.png
+%%DATADIR%%/professor2/bump.wav
+%%DATADIR%%/professor2/bumper.png
+%%DATADIR%%/professor2/bumphard.wav
+%%DATADIR%%/professor2/bumpsoft.wav
+%%DATADIR%%/professor2/flip.wav
+%%DATADIR%%/professor2/floor-room.jpg
+%%DATADIR%%/professor2/gameover.wav
+%%DATADIR%%/professor2/intro.ogg
+%%DATADIR%%/professor2/introp.ogg
+%%DATADIR%%/professor2/label.png
+%%DATADIR%%/professor2/nudge.wav
+%%DATADIR%%/professor2/pinball.pbl
+%%DATADIR%%/professor2/professor.ogg
+%%DATADIR%%/professor2/professor.png
+%%DATADIR%%/professor2/shoot.wav
+%%DATADIR%%/professor2/tiles.png
+%%DATADIR%%/professor2/triangle.png
+%%DATADIR%%/professor2/up.wav
+%%DATADIR%%/professor2/wall.jpg
+%%DATADIR%%/professor2/wheel.png
%%DATADIR%%/splash.png
%%DATADIR%%/splash.png.pcx
%%DATADIR%%/tux/bump.wav
@@ -110,7 +205,6 @@ lib/pinball/libemilia_pin.a
%%DATADIR%%/tux/floor3.png
%%DATADIR%%/tux/game.ogg
%%DATADIR%%/tux/gameover.wav
-%%DATADIR%%/tux/intro.mid
%%DATADIR%%/tux/intro.ogg
%%DATADIR%%/tux/lock.wav
%%DATADIR%%/tux/loop.wav
@@ -122,8 +216,3 @@ lib/pinball/libemilia_pin.a
%%DATADIR%%/tux/tiles.png
%%DATADIR%%/tux/tiles.png.pcx
%%DATADIR%%/tux/up.wav
-@sample(,games,664) /var/games/pinball/professor/highscores.sample
-@sample(,games,664) /var/games/pinball/tux/highscores.sample
-@dir(,games,775) /var/games/pinball/tux
-@dir(,games,775) /var/games/pinball/professor
-@dir /var/games/pinball