aboutsummaryrefslogtreecommitdiff
path: root/games/pinball
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2014-04-13 20:29:52 +0000
committerThierry Thomas <thierry@FreeBSD.org>2014-04-13 20:29:52 +0000
commitc3d86089091f291a26b7e59fcae914cd475c4e19 (patch)
tree59a8c52af202ea8a5aca8d38bfb23c7c8ec52a08 /games/pinball
parent2313ccd4433b9d71edfe73f5d532629f69c3ccf9 (diff)
downloadports-c3d86089091f291a26b7e59fcae914cd475c4e19.tar.gz
ports-c3d86089091f291a26b7e59fcae914cd475c4e19.zip
- Support stage and use the new infrastructure;
- Remove MAKE_JOBS_UNSAFE; - Register /var/games/pinball.
Notes
Notes: svn path=/head/; revision=351237
Diffstat (limited to 'games/pinball')
-rw-r--r--games/pinball/Makefile46
-rw-r--r--games/pinball/files/patch-Makefile.in15
-rw-r--r--games/pinball/files/patch-data_Makefile.in11
-rw-r--r--games/pinball/files/patch-src_Makefile.in20
-rw-r--r--games/pinball/pkg-plist16
5 files changed, 76 insertions, 32 deletions
diff --git a/games/pinball/Makefile b/games/pinball/Makefile
index 00804c8004e9..797f41c34176 100644
--- a/games/pinball/Makefile
+++ b/games/pinball/Makefile
@@ -3,54 +3,48 @@
PORTNAME= pinball
PORTVERSION= 0.3.1
-PORTREVISION= 14
+PORTREVISION= 15
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= thierry@FreeBSD.org
COMMENT= Emilia Pinball is a free pinball game
-.if !defined(WITH_ALLEGRO)
-BUILD_DEPENDS= ${SDL_CONFIG}:${PORTSDIR}/devel/sdl12
-.else
-BROKEN= support with Allegro is (temporarily) broken as of version 0.3.1
-BUILD_DEPENDS= ${ALLEGRO_CONFIG}:${PORTSDIR}/devel/allegro
-LIB_DEPENDS= alleg.42:${PORTSDIR}/devel/allegro
-.endif
+LICENSE= GPLv2
-USE_SDL= image mixer sdl
-USE_GMAKE= yes
+USES= gmake libtool
USE_GL= gl
-USE_AUTOTOOLS= libtool
+GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --without-debug
+
.if defined(WITH_ALLEGRO)
+BROKEN= support with Allegro is (temporarily?) broken as of version 0.3.1
+LIB_DEPENDS+= liballeg.so:${PORTSDIR}/devel/allegro
CONFIGURE_ARGS+= --with-allegro
-EXTRA_LIBS= -lGL -lGLU
+USE_GL+= glu
+.else
+USE_SDL= image mixer sdl
.endif
+
CPPFLAGS+= -I${LOCALBASE}/include -DRZR_LIBSTATIC
-LDFLAGS+= -L${LOCALBASE}/lib ${EXTRA_LIBS}
-MAKE_JOBS_UNSAFE= yes
-ALLEGRO_CONFIG= ${LOCALBASE}/bin/allegro-config
+LDFLAGS+= -L${LOCALBASE}/lib
+#MAKE_JOBS_UNSAFE= yes
DOCS= README
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-# For gmake>=3.82
-post-patch:
- @${FIND} ${WRKSRC} -name Makefile.in -print | ${XARGS} \
- ${REINPLACE_CMD} -e 's,^dnl,# dnl,'
+# For gmake>=3.82 + ranlib runs twice
+pre-configure:
+ ${FIND} ${WRKSRC} -name Makefile.in -print | ${XARGS} \
+ ${REINPLACE_CMD} -e 's,^dnl,# dnl,;/echo.*RANLIB/,+1d'
post-install:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for FILE in ${DOCS}
- @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${FILE} ${STAGEDIR}${DOCSDIR}
.endfor
- @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/pinball/files/patch-Makefile.in b/games/pinball/files/patch-Makefile.in
index 7ef803ba425e..ad0e3a83eef1 100644
--- a/games/pinball/files/patch-Makefile.in
+++ b/games/pinball/files/patch-Makefile.in
@@ -1,5 +1,5 @@
---- Makefile.in.orig Thu May 29 06:47:43 2003
-+++ Makefile.in Thu Jun 5 22:12:54 2003
+--- Makefile.in.orig 2003-12-10 12:35:31.000000000 +0100
++++ Makefile.in 2014-04-13 21:03:05.000000000 +0200
@@ -107,7 +107,7 @@
install_sh = @install_sh@
AUTOMAKE_OPTIONS = gnu
@@ -7,5 +7,14 @@
-SUBDIRS = libltdl addon base data src test
+SUBDIRS = addon base data src test
- EXTRA_DIST = bootstrap pinball.spec clean
+ EXTRA_DIST = bootstrap pinball.spec clean pinball.desktop
+@@ -243,7 +243,7 @@
+ else \
+ local_target="$$target"; \
+ fi; \
+- (cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) $$local_target) \
++ ($(MAKE) -C $$subdir $(AM_MAKEFLAGS) $$local_target) \
+ || case "$$amf" in *=*) exit 1;; *k*) fail=yes;; *) exit 1;; esac; \
+ done; \
+ if test "$$dot_seen" = "no"; then \
diff --git a/games/pinball/files/patch-data_Makefile.in b/games/pinball/files/patch-data_Makefile.in
new file mode 100644
index 000000000000..845ab44caadc
--- /dev/null
+++ b/games/pinball/files/patch-data_Makefile.in
@@ -0,0 +1,11 @@
+--- data/Makefile.in.orig 2003-12-10 12:34:46.000000000 +0100
++++ data/Makefile.in 2014-04-13 21:09:57.000000000 +0200
+@@ -189,7 +189,7 @@
+ else \
+ local_target="$$target"; \
+ fi; \
+- (cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) $$local_target) \
++ ($(MAKE) -C $$subdir $(AM_MAKEFLAGS) $$local_target) \
+ || case "$$amf" in *=*) exit 1;; *k*) fail=yes;; *) exit 1;; esac; \
+ done; \
+ if test "$$dot_seen" = "no"; then \
diff --git a/games/pinball/files/patch-src_Makefile.in b/games/pinball/files/patch-src_Makefile.in
new file mode 100644
index 000000000000..50ad0cd8c2e5
--- /dev/null
+++ b/games/pinball/files/patch-src_Makefile.in
@@ -0,0 +1,20 @@
+--- src/Makefile.in.orig 2003-12-10 12:34:47.000000000 +0100
++++ src/Makefile.in 2014-04-13 21:22:52.000000000 +0200
+@@ -116,7 +116,7 @@
+
+ INCLUDES = -I../base -I../addon @INCLTDL@
+
+-pinball_LDADD = ../src/libemilia_pin.a ../addon/libemilia_addon.a ../base/libemilia_base.a @LIBLTDL@
++pinball_LDADD = libemilia_pin.a ../addon/libemilia_addon.a ../base/libemilia_base.a @LIBLTDL@
+ pinball_LDFLAGS = -export-dynamic
+
+ pinball_SOURCES = Pinball.cpp
+@@ -174,7 +174,7 @@
+
+ am_pinball_OBJECTS = Pinball.$(OBJEXT)
+ pinball_OBJECTS = $(am_pinball_OBJECTS)
+-pinball_DEPENDENCIES = ../src/libemilia_pin.a ../addon/libemilia_addon.a \
++pinball_DEPENDENCIES = libemilia_pin.a ../addon/libemilia_addon.a \
+ ../base/libemilia_base.a
+
+ DEFS = @DEFS@
diff --git a/games/pinball/pkg-plist b/games/pinball/pkg-plist
index 28a44402f93f..5c735476349a 100644
--- a/games/pinball/pkg-plist
+++ b/games/pinball/pkg-plist
@@ -66,14 +66,17 @@ lib/pinball/libModuleProfessor.a
lib/pinball/libModuleProfessor.la
lib/pinball/libModuleProfessor.so
lib/pinball/libModuleProfessor.so.0
+lib/pinball/libModuleProfessor.so.0.0.0
lib/pinball/libModuleTest.a
lib/pinball/libModuleTest.la
lib/pinball/libModuleTest.so
lib/pinball/libModuleTest.so.0
+lib/pinball/libModuleTest.so.0.0.0
lib/pinball/libModuleTux.a
lib/pinball/libModuleTux.la
lib/pinball/libModuleTux.so
lib/pinball/libModuleTux.so.0
+lib/pinball/libModuleTux.so.0.0.0
lib/pinball/libemilia_addon.a
lib/pinball/libemilia_base.a
lib/pinball/libemilia_pin.a
@@ -119,9 +122,16 @@ lib/pinball/libemilia_pin.a
%%DATADIR%%/tux/tiles.png
%%DATADIR%%/tux/tiles.png.pcx
%%DATADIR%%/tux/up.wav
-@dirrm include/pinball
-@dirrm lib/pinball
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%DATADIR%%/tux
@dirrm %%DATADIR%%/professor
@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm lib/pinball
+@dirrm include/pinball
+@group games
+@unexec rmdir >/dev/null 2>&1 /var/games/pinball/tux || :
+@unexec rmdir >/dev/null 2>&1 /var/games/pinball/professor || :
+@unexec rmdir >/dev/null 2>&1 /var/games/pinball || :
+/var/games/pinball/professor/highscores
+/var/games/pinball/tux/highscores
+@group