aboutsummaryrefslogtreecommitdiff
path: root/games/pingus
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2013-10-19 11:19:35 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2013-10-19 11:19:35 +0000
commit9f03ef324f227e864cdcd436f73711c5320308e2 (patch)
tree602d34b71c285783d4a999bb86b46a19cc261876 /games/pingus
parentae827a9a31dbf709eba72972a1697251e1242c12 (diff)
downloadports-9f03ef324f227e864cdcd436f73711c5320308e2.tar.gz
ports-9f03ef324f227e864cdcd436f73711c5320308e2.zip
- Fix build with clang with two new patches
- Install icon and use it in a .desktop file - While here, use space in WWW: and use new style LIB_DEPENDS PR: ports/181498 Submitted by: amdmi3 Approved by: maintainer timeout (8 weeks)
Notes
Notes: svn path=/head/; revision=330859
Diffstat (limited to 'games/pingus')
-rw-r--r--games/pingus/Makefile15
-rw-r--r--games/pingus/files/patch-src-editor-editor__screen.hpp11
-rw-r--r--games/pingus/files/patch-src-lisp-getters.hpp11
-rw-r--r--games/pingus/pkg-descr2
4 files changed, 32 insertions, 7 deletions
diff --git a/games/pingus/Makefile b/games/pingus/Makefile
index 494445ecdb0d..a8607efc0080 100644
--- a/games/pingus/Makefile
+++ b/games/pingus/Makefile
@@ -3,16 +3,16 @@
PORTNAME= pingus
PORTVERSION= 0.7.2
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= games
MASTER_SITES= http://pingus.seul.org/files/
MAINTAINER= acm@FreeBSD.org
COMMENT= Free Lemmings-like game
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- boost_regex:${PORTSDIR}/devel/boost-libs \
- physfs.1:${PORTSDIR}/devel/physfs
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
+ libboost_regex.so:${PORTSDIR}/devel/boost-libs \
+ libphysfs.so:${PORTSDIR}/devel/physfs
USE_BZIP2= yes
USES= iconv
@@ -21,8 +21,9 @@ SCONS_ARGS= with_linuxusbmouse=0 \
with_linuxevdev=0
USE_SDL= sdl image mixer
-DESKTOP_ENTRIES= "Pingus" "${COMMENT}" "" \
- "pingus" "" false
+DESKTOP_ENTRIES="Pingus" "${COMMENT}" \
+ "${PREFIX}/share/pixmaps/${PORTNAME}.ico" \
+ "pingus" "" "false"
PLIST= ${WRKDIR}/pkg-plist
@@ -34,6 +35,7 @@ post-patch:
pre-install:
@${RM} -f ${PLIST}
@${ECHO_CMD} "bin/${PORTNAME}" >> ${PLIST}
+ @${ECHO_CMD} "share/pixmaps/${PORTNAME}.ico" >> ${PLIST}
@cd ${WRKSRC}/data && \
${FIND} * -type f | ${SORT} | ${SED} -e 's|^|%%DATADIR%%/|' >> ${PLIST} && \
${FIND} * -type d | ${SORT} -r | ${SED} -e 's|^|@dirrm %%DATADIR%%/|' >> ${PLIST}
@@ -45,5 +47,6 @@ do-install:
${FIND} * -type d -exec ${MKDIR} "${DATADIR}/{}" \; && \
${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/src/win32/icon1.ico ${PREFIX}/share/pixmaps/${PORTNAME}.ico
.include <bsd.port.mk>
diff --git a/games/pingus/files/patch-src-editor-editor__screen.hpp b/games/pingus/files/patch-src-editor-editor__screen.hpp
new file mode 100644
index 000000000000..c607fe21ec98
--- /dev/null
+++ b/games/pingus/files/patch-src-editor-editor__screen.hpp
@@ -0,0 +1,11 @@
+--- src/editor/editor_screen.hpp.orig 2007-09-30 20:07:08.000000000 +0400
++++ src/editor/editor_screen.hpp 2013-08-23 23:08:40.689231327 +0400
+@@ -27,7 +27,7 @@
+
+ class DrawingContext;
+ class FileDialog;
+-class GUI::GUIManager;
++namespace GUI { class GUIManager; }
+ class Pathname;
+
+ namespace Editor {
diff --git a/games/pingus/files/patch-src-lisp-getters.hpp b/games/pingus/files/patch-src-lisp-getters.hpp
new file mode 100644
index 000000000000..ec0260523983
--- /dev/null
+++ b/games/pingus/files/patch-src-lisp-getters.hpp
@@ -0,0 +1,11 @@
+--- src/lisp/getters.hpp.orig 2007-08-17 20:20:09.000000000 +0400
++++ src/lisp/getters.hpp 2013-08-09 13:42:19.551761882 +0400
+@@ -30,7 +30,7 @@
+ if(lisp->get_list_size() != 2)
+ return false;
+
+- const Lisp* el = lisp->get_list_elem(1);
++ const Lisp* el = lisp->get_list_elem(1).get();
+ return get(el, val);
+ }
+
diff --git a/games/pingus/pkg-descr b/games/pingus/pkg-descr
index 4c813635cda2..ff643b80c2c9 100644
--- a/games/pingus/pkg-descr
+++ b/games/pingus/pkg-descr
@@ -2,4 +2,4 @@ Pingus is a free Lemmings-like game covered under the GNU GPL. It features
currently 22 playable levels and runs under a wide variety of operating systems
(FreeBSD, Linux, Windows, etc.)
-WWW: http://pingus.seul.org/
+WWW: http://pingus.seul.org/