aboutsummaryrefslogtreecommitdiff
path: root/games/pioneers
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2020-09-30 10:58:50 +0000
committerStefan Eßer <se@FreeBSD.org>2020-09-30 10:58:50 +0000
commit16def30775b1e0583957e90af337799b7bc2f177 (patch)
treeab600b6e8a7c381681f88d23547ec24f7ed7b86b /games/pioneers
parent7a5d288d08d7f3093bb708e5008e6931d6d9622c (diff)
downloadports-16def30775b1e0583957e90af337799b7bc2f177.tar.gz
ports-16def30775b1e0583957e90af337799b7bc2f177.zip
Fix build with -fno-common
While here add dependencies reported as missing by stage-qa.
Notes
Notes: svn path=/head/; revision=550679
Diffstat (limited to 'games/pioneers')
-rw-r--r--games/pioneers/Makefile5
-rw-r--r--games/pioneers/files/patch-common_game.h11
2 files changed, 15 insertions, 1 deletions
diff --git a/games/pioneers/Makefile b/games/pioneers/Makefile
index d7ea18cef5eb..584a7cecf2b7 100644
--- a/games/pioneers/Makefile
+++ b/games/pioneers/Makefile
@@ -3,6 +3,7 @@
PORTNAME= pioneers
PORTVERSION= 15.5
+PORTREVISION= 1
CATEGORIES= games gnome
MASTER_SITES= SF/pio/Source
@@ -13,10 +14,12 @@ LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= itstool:textproc/itstool
+LIB_DEPENDS= libavahi-common.so:net/avahi-app \
+ libnotify.so:devel/libnotify
RUN_DEPENDS= yelp:x11/yelp
USES= gettext gmake gnome pkgconfig
-USE_GNOME= gnomeprefix gtk30 intltool libgnome librsvg2
+USE_GNOME= cairo gnomeprefix gtk30 intltool libgnome librsvg2
INSTALLS_ICONS= yes
INSTALLS_OMF= yes
GNU_CONFIGURE= yes
diff --git a/games/pioneers/files/patch-common_game.h b/games/pioneers/files/patch-common_game.h
new file mode 100644
index 000000000000..86f2601280ae
--- /dev/null
+++ b/games/pioneers/files/patch-common_game.h
@@ -0,0 +1,11 @@
+--- common/game.h.orig 2018-03-14 13:44:46 UTC
++++ common/game.h
+@@ -137,7 +137,7 @@ typedef enum {
+ typedef void (*WriteLineFunc) (gpointer user_data, const gchar *);
+
+ /** Default style for a player. */
+-const gchar *default_player_style;
++extern const gchar *default_player_style;
+
+ GameParams *params_new(void);
+ GameParams *params_copy(const GameParams * params);