aboutsummaryrefslogtreecommitdiff
path: root/games/pmars-sdl
diff options
context:
space:
mode:
authorDejan Lesjak <lesi@FreeBSD.org>2005-07-31 02:31:38 +0000
committerDejan Lesjak <lesi@FreeBSD.org>2005-07-31 02:31:38 +0000
commitb233cd98cd3da6c0a61b7be0e60dbb4db71b386d (patch)
tree95c5f0a9d376f0e5d3ce1845ce0399be34189aa4 /games/pmars-sdl
parent4ae1da5b8f24c37faddc1aec10fb7e3a065455a4 (diff)
downloadports-b233cd98cd3da6c0a61b7be0e60dbb4db71b386d.tar.gz
ports-b233cd98cd3da6c0a61b7be0e60dbb4db71b386d.zip
Add pmars-sdl: Port of pMARS using the Simple Directmedia Library.
PR: ports/84351 Submitted by: Alejandro Pulver (alejandro at varnet.biz)
Notes
Notes: svn path=/head/; revision=140515
Diffstat (limited to 'games/pmars-sdl')
-rw-r--r--games/pmars-sdl/Makefile58
-rw-r--r--games/pmars-sdl/distinfo2
-rw-r--r--games/pmars-sdl/files/patch-Makefile17
-rw-r--r--games/pmars-sdl/pkg-descr17
4 files changed, 94 insertions, 0 deletions
diff --git a/games/pmars-sdl/Makefile b/games/pmars-sdl/Makefile
new file mode 100644
index 000000000000..5f963a3139c8
--- /dev/null
+++ b/games/pmars-sdl/Makefile
@@ -0,0 +1,58 @@
+# New ports collection makefile for: pmars-sdl
+# Date created: 30 Jul 2005
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pmars
+PORTVERSION= 0.9.2
+CATEGORIES= games
+MASTER_SITES= http://www.cs.helsinki.fi/u/jpihlaja/cw/pmars-sdl/
+PKGNAMESUFFIX= -sdl
+DISTNAME= ${PORTNAME}-${PORTVERSION}-5
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= Port of pMARS using the Simple Directmedia Library
+
+USE_GCC= 3.1+
+USE_SDL= sdl
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+
+OPTIONS= ICWS94 "Enable ICWS'94 support" on \
+ OPTIMIZED_CFLAGS "Enable compilation optimizations" on \
+ PERMUTATE "Enable the -P switch" on \
+ SMALLMEM "Use 16-bit addresses (smaller)" off
+
+MAKE_ARGS+= CFLAGS+="${CFLAGS}" \
+ CFLAGS+="-fno-builtin" \
+ CFLAGS+="`${SDL_CONFIG} --cflags`" \
+ LIB+="`${SDL_CONFIG} --libs`" \
+ CFLAGS+="-DSDLGRAPHX"
+
+PLIST_FILES= bin/${PORTNAME}${PKGNAMESUFFIX}
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} \
+ ${PREFIX}/bin/${PORTNAME}${PKGNAMESUFFIX}
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_ICWS94)
+MAKE_ARGS+= CFLAGS+="-DEXT94"
+.endif
+
+.if defined(WITH_OPTIMIZED_CFLAGS)
+MAKE_ARGS+= CFLAGS+="-O3 -fomit-frame-pointer"
+.endif
+
+.if defined(WITH_PERMUTATE)
+MAKE_ARGS+= CFLAGS+="-DPERMUTATE"
+.endif
+
+.if defined(WITH_SMALLMEM)
+MAKE_ARGS+= CFLAGS+="-DSMALLMEM"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/games/pmars-sdl/distinfo b/games/pmars-sdl/distinfo
new file mode 100644
index 000000000000..855af68368a6
--- /dev/null
+++ b/games/pmars-sdl/distinfo
@@ -0,0 +1,2 @@
+MD5 (pmars-0.9.2-5.tar.gz) = 4733185c5eb6a4554a54d91331e6501d
+SIZE (pmars-0.9.2-5.tar.gz) = 200966
diff --git a/games/pmars-sdl/files/patch-Makefile b/games/pmars-sdl/files/patch-Makefile
new file mode 100644
index 000000000000..fe62f828d963
--- /dev/null
+++ b/games/pmars-sdl/files/patch-Makefile
@@ -0,0 +1,17 @@
+--- Makefile.orig Thu May 1 10:09:46 2003
++++ Makefile Mon Jul 18 09:49:02 2005
+@@ -1,5 +1,4 @@
+ # generic UNIX makefile
+-CC = gcc # req. for linux
+ #CC = cc # if you don't have gcc
+ # Configuration options:
+ #
+@@ -18,8 +17,6 @@
+ # (8) -DSDLGRAPHX 1 SDL graphics (generic)
+
+ #DBG = -g -W -Wall -pg
+-CFLAGS = -O4 -fomit-frame-pointer $(DBG) -DSERVER -DEXT94 -DPERMUTATE $(INC)
+-LFLAGS = -x
+ # LIB = -lcurses -ltermlib # enable this one for curses display
+ # LIB = -lvgagl -lvga # enable this one for Linux/SVGA
+ # LIB = -L/usr/X11R6/lib -lX11 # enable this one for X11
diff --git a/games/pmars-sdl/pkg-descr b/games/pmars-sdl/pkg-descr
new file mode 100644
index 000000000000..1658b1d20b99
--- /dev/null
+++ b/games/pmars-sdl/pkg-descr
@@ -0,0 +1,17 @@
+Port of pMARS using the Simple Directmedia Library. Currently the port is in
+beta testing stage testing and bug reports/feature requests are more than
+welcome. The latest release is version 0.9.2-5.
+
+Features/fixes:
+
+* Environment sensitive. Now looks for macro files in the directory specified
+ by the environment variable PMARSHOME if they are not found in the current
+ directory.
+* Both Win32 and X11 supported.
+* Command line history using Shift-Up and Shift-Down keys.
+* Rewrote text display and screen update routines for faster text panels (for
+ slow computers like mine.)
+* BIG core cells for those tiny cores. (Choose a display mode larger than 2,
+ e.g. -v 134.)
+
+WWW: http://www.cs.helsinki.fi/u/jpihlaja/cw/pmars-sdl/