aboutsummaryrefslogtreecommitdiff
path: root/games/pmars
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-01-31 17:39:31 +0000
committerJohn Marino <marino@FreeBSD.org>2016-01-31 17:39:31 +0000
commit4979584876fee91981baabd8b67e529243b30215 (patch)
treeb7e16e331586f59f4e8e90fdcdd4942833f3d07e /games/pmars
parentc9832f80da3be2107da3c51885145afe82c21e8a (diff)
downloadports-4979584876fee91981baabd8b67e529243b30215.tar.gz
ports-4979584876fee91981baabd8b67e529243b30215.zip
games/pmars: USES+= ncurses, respect LDFLAGS
Also link with libncurses rather than libcurses.
Notes
Notes: svn path=/head/; revision=407655
Diffstat (limited to 'games/pmars')
-rw-r--r--games/pmars/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/games/pmars/Makefile b/games/pmars/Makefile
index 3a585d4998b5..8f05921c3db4 100644
--- a/games/pmars/Makefile
+++ b/games/pmars/Makefile
@@ -24,6 +24,7 @@ ICWS94_DESC= Enable ICWS'94 support
PERMUTATE_DESC= Enable the -P switch
SERVER_DESC= Build the command-line interface
SMALLMEM_DESC= Use 16-bit addresses (smaller)
+CURSES_USES= ncurses
OPTIONS_SUB= yes
@@ -40,7 +41,7 @@ SMALLMEM_MAKE_ARGS= CFLAGS+="-DSMALLMEM"
.if ${PORT_OPTIONS:MCURSES}
TARGETS+= curses
CURSES_ARGS+= CFLAGS+="-DGRAPHX" \
- LIB+="-lcurses"
+ LIB+="${LDFLAGS} -lncurses"
.endif
.if ${PORT_OPTIONS:MSERVER}