aboutsummaryrefslogtreecommitdiff
path: root/games/pongix
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-06-07 19:20:27 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-06-07 19:20:27 +0000
commit3902d8caddb6d07ae77347ad8906807fa4b8b117 (patch)
tree5e1bdbc23b4eb0874c0acd7c34429d0a2d63cfd5 /games/pongix
parent5916ca5af15ebdb4f74d0744a5a31e2408271f14 (diff)
downloadports-3902d8caddb6d07ae77347ad8906807fa4b8b117.tar.gz
ports-3902d8caddb6d07ae77347ad8906807fa4b8b117.zip
Pongix is a free game based on classical pong game with support for net game.
WWW: http://www.losersjuegos.com.ar PR: ports/95390 Submitted by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe> Approved by: lawrance (mentor, implicit)
Notes
Notes: svn path=/head/; revision=164743
Diffstat (limited to 'games/pongix')
-rw-r--r--games/pongix/Makefile45
-rw-r--r--games/pongix/distinfo3
-rw-r--r--games/pongix/files/patch-configure20
-rw-r--r--games/pongix/pkg-descr3
-rw-r--r--games/pongix/pkg-plist10
5 files changed, 81 insertions, 0 deletions
diff --git a/games/pongix/Makefile b/games/pongix/Makefile
new file mode 100644
index 000000000000..59bfef8e16b8
--- /dev/null
+++ b/games/pongix/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: pongix
+# Date created: 2006-04-01
+# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pongix
+PORTVERSION= 0.4
+CATEGORIES= games
+MASTER_SITES= http://www.losersjuegos.com.ar/juegos/pongix/descargas/
+
+MAINTAINER= acardenas@bsd.org.pe
+COMMENT= Free pong-like game
+
+USE_X_PREFIX= yes
+USE_SDL= sdl image net
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include -I${X11BASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+post-extract:
+ @${FIND} -E ${WRKSRC}/src/ -type f -iregex ".*\.(c|h)" \
+ -print0 | ${XARGS} -0 ${REINPLACE_CMD} -e 's/<SDL/<SDL11/g'
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ @cd ${WRKSRC}/src && \
+ ${INSTALL_PROGRAM} pongix ${PREFIX}/bin
+ @cd ${WRKSRC}/data && \
+ ${FIND} * -type d -exec ${MKDIR} "${DATADIR}/{}" \; && \
+ ${FIND} -E * -type f -iregex ".*\.(jpg|bmp)" \
+ -exec ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC} && \
+ ${INSTALL_DATA} AUTHORS ChangeLog README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/pongix/distinfo b/games/pongix/distinfo
new file mode 100644
index 000000000000..b1b57731abcd
--- /dev/null
+++ b/games/pongix/distinfo
@@ -0,0 +1,3 @@
+MD5 (pongix-0.4.tar.gz) = 225972add1588c6ba33d7d2cf87e7b38
+SHA256 (pongix-0.4.tar.gz) = b72060ded5446f60e187aff1a35eb727484a3b2f798134dc920a16c75b09175e
+SIZE (pongix-0.4.tar.gz) = 207490
diff --git a/games/pongix/files/patch-configure b/games/pongix/files/patch-configure
new file mode 100644
index 000000000000..d6e13f3e28d5
--- /dev/null
+++ b/games/pongix/files/patch-configure
@@ -0,0 +1,20 @@
+--- configure Sun Dec 25 16:08:14 2005
++++ configure Wed Apr 5 21:28:25 2006
+@@ -2800,7 +2800,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lSDL $LIBS"
++LIBS="`sdl11-config --libs` $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -2862,7 +2862,7 @@
+ #define HAVE_LIBSDL 1
+ _ACEOF
+
+- LIBS="-lSDL $LIBS"
++ LIBS="`sdl11-config --libs` $LIBS"
+
+ else
+ \
diff --git a/games/pongix/pkg-descr b/games/pongix/pkg-descr
new file mode 100644
index 000000000000..72df3a7179bb
--- /dev/null
+++ b/games/pongix/pkg-descr
@@ -0,0 +1,3 @@
+Pongix is a free game based on classical pong game with support for net game.
+
+WWW: http://www.losersjuegos.com.ar
diff --git a/games/pongix/pkg-plist b/games/pongix/pkg-plist
new file mode 100644
index 000000000000..2f0535be84a2
--- /dev/null
+++ b/games/pongix/pkg-plist
@@ -0,0 +1,10 @@
+bin/pongix
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%DATADIR%%/fondo_juego.jpg
+%%DATADIR%%/fuente.bmp
+%%DATADIR%%/paleta.bmp
+%%DATADIR%%/pelota.bmp
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%