aboutsummaryrefslogtreecommitdiff
path: root/games/powermanga
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-10-24 09:04:23 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-10-24 09:04:23 +0000
commitad004b1c9380a6ae548c250a5eec719f917a9feb (patch)
tree75d236863f29091dbc643bee3e1f036e0935687f /games/powermanga
parentb38083be42144a9b309c1d31aad3d9f739a202f4 (diff)
downloadports-ad004b1c9380a6ae548c250a5eec719f917a9feb.tar.gz
ports-ad004b1c9380a6ae548c250a5eec719f917a9feb.zip
- Update WWW
- Fix LICENSE - Switch to USES=localbase - Switch to options helpers
Notes
Notes: svn path=/head/; revision=452759
Diffstat (limited to 'games/powermanga')
-rw-r--r--games/powermanga/Makefile19
1 files changed, 10 insertions, 9 deletions
diff --git a/games/powermanga/Makefile b/games/powermanga/Makefile
index 0bce6ac15ae3..9fe594e5eb60 100644
--- a/games/powermanga/Makefile
+++ b/games/powermanga/Makefile
@@ -5,18 +5,17 @@ PORTNAME= powermanga
PORTVERSION= 0.93.1
CATEGORIES= games
MASTER_SITES= http://linux.tlk.fr/games/Powermanga/download/ \
- http://mirror.amdmi3.ru/distfiles/
-EXTRACT_SUFX= .tgz
+ https://mirror.amdmi3.ru/distfiles/
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Arcade 2D shoot-em-up
-LICENSE= GPLv3
+LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpng.so:graphics/png
-USES= autoreconf
+USES= autoreconf localbase tar:tgz
USE_XORG= xext xxf86dga
USE_SDL= sdl mixer
GNU_CONFIGURE= yes
@@ -24,10 +23,10 @@ GNU_CONFIGURE= yes
PORTDOCS= *
PORTDATA= *
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
LIBS+= -lm
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e '/CFLAGS/ { s|-O3||; s|-Werror||; }' ${WRKSRC}/configure.ac
@${REINPLACE_CMD} -e \
@@ -42,13 +41,15 @@ post-patch:
@${REINPLACE_CMD} -e 's|Lang=fr|Lang=en|' ${WRKSRC}/texts/config.ini
post-install:
- ${CHMOD} 755 ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ @${CHMOD} 755 ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
${INSTALL_DATA} ${WRKSRC}/powermanga.desktop ${STAGEDIR}${PREFIX}/share/applications/
${INSTALL_DATA} ${WRKSRC}/powermanga.xpm ${STAGEDIR}${PREFIX}/share/pixmaps/
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/AUTHORS ${WRKSRC}/CHANGES ${STAGEDIR}${DOCSDIR}
.for f in powermanga.hi powermanga.hi-easy powermanga.hi-hard
${MV} ${STAGEDIR}/var/games/${PORTNAME}/${f} ${STAGEDIR}/var/games/${PORTNAME}/${f}.sample
.endfor
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/AUTHORS ${WRKSRC}/CHANGES ${STAGEDIR}${DOCSDIR}
+
.include <bsd.port.mk>