aboutsummaryrefslogtreecommitdiff
path: root/games/prboom
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2020-09-30 11:10:02 +0000
committerStefan Eßer <se@FreeBSD.org>2020-09-30 11:10:02 +0000
commit2c6c867da341644627884cf0bc41ea3781d9a416 (patch)
tree1586b18e8db27affeda4dba45c45385ca6ece77f /games/prboom
parentb0889bbad1e666c600d2cd542cb479face225a72 (diff)
downloadports-2c6c867da341644627884cf0bc41ea3781d9a416.tar.gz
ports-2c6c867da341644627884cf0bc41ea3781d9a416.zip
Fix build with -fno-common
Notes
Notes: svn path=/head/; revision=550681
Diffstat (limited to 'games/prboom')
-rw-r--r--games/prboom/Makefile6
-rw-r--r--games/prboom/files/patch-src_gl__intern.h10
-rw-r--r--games/prboom/files/patch-src_gl__main.c11
3 files changed, 25 insertions, 2 deletions
diff --git a/games/prboom/Makefile b/games/prboom/Makefile
index f320ec746d1d..b0339446bce6 100644
--- a/games/prboom/Makefile
+++ b/games/prboom/Makefile
@@ -3,7 +3,7 @@
PORTNAME= prboom
PORTVERSION= 2.5.0
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20stable/${PORTVERSION}
@@ -12,9 +12,11 @@ COMMENT= Multiplayer-capable and modified version of ID's classic DOOM game
LICENSE= GPLv2
-LIB_DEPENDS= libsmpeg.so:multimedia/smpeg
+LIB_DEPENDS= libsmpeg.so:multimedia/smpeg \
+ libpng16.so:graphics/png
USES= gmake sdl
+USE_GL= gl
USE_SDL= mixer net sdl
GNU_CONFIGURE= yes
diff --git a/games/prboom/files/patch-src_gl__intern.h b/games/prboom/files/patch-src_gl__intern.h
new file mode 100644
index 000000000000..38077c91850a
--- /dev/null
+++ b/games/prboom/files/patch-src_gl__intern.h
@@ -0,0 +1,10 @@
+--- src/gl_intern.h.orig 2008-10-11 12:10:39 UTC
++++ src/gl_intern.h
+@@ -83,6 +83,6 @@ int gld_GetTexDimension(int value);
+ void gld_SetTexturePalette(GLenum target);
+ void gld_Precache(void);
+
+-PFNGLCOLORTABLEEXTPROC gld_ColorTableEXT;
++extern PFNGLCOLORTABLEEXTPROC gld_ColorTableEXT;
+
+ #endif // _GL_INTERN_H
diff --git a/games/prboom/files/patch-src_gl__main.c b/games/prboom/files/patch-src_gl__main.c
new file mode 100644
index 000000000000..9f3ab8c7108c
--- /dev/null
+++ b/games/prboom/files/patch-src_gl__main.c
@@ -0,0 +1,11 @@
+--- src/gl_main.c.orig 2008-10-18 13:32:29 UTC
++++ src/gl_main.c
+@@ -83,6 +83,8 @@ int gl_paletted_texture = 0;
+ int gl_shared_texture_palette = 0;
+ int gl_sprite_offset; // item out of floor offset Mead 8/13/03
+
++PFNGLCOLORTABLEEXTPROC gld_ColorTableEXT;
++
+ GLuint gld_DisplayList=0;
+ int fog_density=200;
+ static float extra_red=0.0f;