aboutsummaryrefslogtreecommitdiff
path: root/games/prboom
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-05 01:27:53 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-05 01:27:53 +0000
commitb59192cc24ef24fba3659c2761a29f8b3a4aca74 (patch)
treee76dc4a6200f0a3d27977eed5644b5087c891914 /games/prboom
parent521d90b8eee2430b755841ae8b359d0121a33aff (diff)
downloadports-b59192cc24ef24fba3659c2761a29f8b3a4aca74.tar.gz
ports-b59192cc24ef24fba3659c2761a29f8b3a4aca74.zip
- Convert LIB_DEPENDS to new syntax
- Convert USE_GMAKE to USES - Use options helpers - Add stage support
Notes
Notes: svn path=/head/; revision=332800
Diffstat (limited to 'games/prboom')
-rw-r--r--games/prboom/Makefile12
-rw-r--r--games/prboom/pkg-plist16
2 files changed, 14 insertions, 14 deletions
diff --git a/games/prboom/Makefile b/games/prboom/Makefile
index a199fea6886e..cf8f16780201 100644
--- a/games/prboom/Makefile
+++ b/games/prboom/Makefile
@@ -10,9 +10,9 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20stable/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Multiplayer-capable and modified version of ID's classic DOOM game
-LIB_DEPENDS= smpeg.1:${PORTSDIR}/multimedia/smpeg
+LIB_DEPENDS= libsmpeg.so:${PORTSDIR}/multimedia/smpeg
-USE_GMAKE= yes
+USES= gmake
USE_SDL= mixer net sdl
GNU_CONFIGURE= yes
@@ -22,21 +22,17 @@ LDFLAGS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= OPENGL
OPTIONS_DEFAULT= OPENGL
-MAN5= boom.cfg.5
-MAN6= prboom.6 prboom-game-server.6
-
DATADIR= ${DMDIR}
PLIST_SUB= PORTVERSION=${PORTVERSION}
-NO_STAGE= yes
+OPENGL_CONFIGURE_ENABLE= gl
+
.include "${.CURDIR}/../doom-data/Makefile.include"
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MOPENGL}
USE_GL= yes
-.else
-CONFIGURE_ARGS+=--disable-gl
.endif
.include <bsd.port.mk>
diff --git a/games/prboom/pkg-plist b/games/prboom/pkg-plist
index c69028f2fb48..a075bd54f18d 100644
--- a/games/prboom/pkg-plist
+++ b/games/prboom/pkg-plist
@@ -1,9 +1,13 @@
bin/prboom
bin/prboom-game-server
+man/man5/boom.cfg.5.gz
+man/man6/prboom-game-server.6.gz
+man/man6/prboom.6.gz
%%DATADIR%%/prboom.wad
-share/doc/prboom-%%PORTVERSION%%/boom.txt
-share/doc/prboom-%%PORTVERSION%%/MBF.txt
-share/doc/prboom-%%PORTVERSION%%/MBFFAQ.txt
-share/doc/prboom-%%PORTVERSION%%/README.demos
-share/doc/prboom-%%PORTVERSION%%/README.compat
-@dirrm share/doc/prboom-%%PORTVERSION%%
+%%DOCSDIR%%-%%PORTVERSION%%/boom.txt
+%%DOCSDIR%%-%%PORTVERSION%%/MBF.txt
+%%DOCSDIR%%-%%PORTVERSION%%/MBFFAQ.txt
+%%DOCSDIR%%-%%PORTVERSION%%/README.demos
+%%DOCSDIR%%-%%PORTVERSION%%/README.compat
+@dirrm %%DOCSDIR%%-%%PORTVERSION%%
+@dirrmtry %%DATADIR%%