aboutsummaryrefslogtreecommitdiff
path: root/games/puckman
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2012-09-21 13:13:03 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2012-09-21 13:13:03 +0000
commit63e9cfee639abcae91b2e342ad7ba5fd432b1be2 (patch)
treec6236ad63bda1611c4eee4461b63430d5cd01a05 /games/puckman
parenteefc9bd47de25d44731db3ed3ef71b09b5c990b5 (diff)
downloadports-63e9cfee639abcae91b2e342ad7ba5fd432b1be2.tar.gz
ports-63e9cfee639abcae91b2e342ad7ba5fd432b1be2.zip
Notes
Diffstat (limited to 'games/puckman')
-rw-r--r--games/puckman/Makefile52
-rw-r--r--games/puckman/distinfo2
-rw-r--r--games/puckman/files/patch-Makefile24
-rw-r--r--games/puckman/files/patch-puckman.c11
-rw-r--r--games/puckman/pkg-descr4
5 files changed, 93 insertions, 0 deletions
diff --git a/games/puckman/Makefile b/games/puckman/Makefile
new file mode 100644
index 000000000000..1b835a824be4
--- /dev/null
+++ b/games/puckman/Makefile
@@ -0,0 +1,52 @@
+# New Ports collection makefile for puckman
+# Date created: 2012-08-08
+# Whom: nemysis@gmx.ch
+#
+# $FreeBSD$
+#
+
+PORTNAME= puckman
+PORTVERSION= 1.0
+CATEGORIES= games
+MASTER_SITES= https://github.com/downloads/patapizza/puckman/
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= An unofficial clone of the original Pac-Man game
+
+LICENSE= GPLv3
+
+FETCH_ARGS?= -Fpr
+USE_GMAKE= yes
+USE_SDL= sdl image gfx
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/pixmaps/${PORTNAME}.png
+
+PORTDATA= *
+PORTDOCS= README.md
+
+.include <bsd.port.options.mk>
+
+do-build:
+ cd ${WRKSRC} && ${CC} -o ${PORTNAME} ${CFLAGS} \
+ -DDATA_PREFIX=\"${DATADIR}/\" \
+ -lm `${SDL_CONFIG} --cflags --libs` -lSDL -lSDL_image -lSDL_gfx -lm puckman.c
+
+do-install:
+# Executable
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+# Data
+ ${MKDIR} ${DATADIR}
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} images ${DATADIR})
+
+# Pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/images/logo.png ${PREFIX}/share/pixmaps/${PORTNAME}.png
+
+# Documentation
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.md ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/puckman/distinfo b/games/puckman/distinfo
new file mode 100644
index 000000000000..e492ce1a04cc
--- /dev/null
+++ b/games/puckman/distinfo
@@ -0,0 +1,2 @@
+SHA256 (puckman-1.0.tar.gz) = 842919da45c77de4c77f66f11dde9f189b1d0d764f2ba76f5b93ee3288e967b2
+SIZE (puckman-1.0.tar.gz) = 210385
diff --git a/games/puckman/files/patch-Makefile b/games/puckman/files/patch-Makefile
new file mode 100644
index 000000000000..2e2c2ddb9936
--- /dev/null
+++ b/games/puckman/files/patch-Makefile
@@ -0,0 +1,24 @@
+--- Makefile.orig 2012-08-16 19:32:29.000000000 +0200
++++ Makefile 2012-08-16 20:12:01.000000000 +0200
+@@ -1,10 +1,10 @@
+-BIN = $(DESTDIR)/usr/bin
+-ICONS = $(DESTDIR)/usr/share/puckman/images
+-ICON = $(DESTDIR)/usr/share/pixmaps
+-SYMICON = $(DESTDIR)/usr/share/icons/hicolor/48x48/apps
++BIN = $(DESTDIR)/usr/local/bin
++ICONS = $(DESTDIR)/usr/local/share/puckman/images
++ICON = $(DESTDIR)/usr/local/share/pixmaps
++SYMICON = $(DESTDIR)/usr/local/share/icons/hicolor/48x48/apps
+ SHELL = /bin/sh
+ CC = g++
+-prefix = /usr
++prefix = /usr/local
+ includedir = $(prefix)/include
+ pacdir = ~/.puckman
+ puckman: puckman.c
+@@ -23,4 +23,4 @@
+
+ uninstall:
+ rm -vr $(ICONS) $(BIN)/puckman $(ICON)/puckman.png $(SYMICON)/puckman.png
+- if test -e $(DESTDIR)/usr/share/applications/puckman.desktop; then rm -v $(DESTDIR)/usr/share/applications/puckman.desktop; fi
++ if test -e $(DESTDIR)/usr/local/share/applications/puckman.desktop; then rm -v $(DESTDIR)/usr/local/share/applications/puckman.desktop; fi
diff --git a/games/puckman/files/patch-puckman.c b/games/puckman/files/patch-puckman.c
new file mode 100644
index 000000000000..243cdb6ec7ca
--- /dev/null
+++ b/games/puckman/files/patch-puckman.c
@@ -0,0 +1,11 @@
+--- puckman.c.orig 2012-08-16 19:32:29.000000000 +0200
++++ puckman.c 2012-08-16 20:11:00.000000000 +0200
+@@ -29,7 +29,7 @@
+ #include <SDL_image.h>
+ #include <SDL_gfxPrimitives.h>
+
+-#define PACPATH "/usr/share/puckman/"
++#define PACPATH "/usr/local/share/puckman/"
+ #define SCREEN_WIDTH 461
+ #define SCREEN_HEIGHT 580
+ #define RIGHT 0
diff --git a/games/puckman/pkg-descr b/games/puckman/pkg-descr
new file mode 100644
index 000000000000..17cd9ccce53c
--- /dev/null
+++ b/games/puckman/pkg-descr
@@ -0,0 +1,4 @@
+This game is an unofficial clone of the original Pac-Man game
+and is not endorsed by the registered trademark owners Namco, Inc.
+
+WWW: https://github.com/patapizza/puckman