aboutsummaryrefslogtreecommitdiff
path: root/games/py-pychess
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2020-04-08 13:39:43 +0000
committerMikhail Teterin <mi@FreeBSD.org>2020-04-08 13:39:43 +0000
commitda6f6d25a457c070c0bd1e2dac69dc053b4efcee (patch)
treea8f809062076bf93d1f6bd3499ff138f7683eda1 /games/py-pychess
parente29950fc192faa626eb2b8ca9166689e001a2db9 (diff)
downloadports-da6f6d25a457c070c0bd1e2dac69dc053b4efcee.tar.gz
ports-da6f6d25a457c070c0bd1e2dac69dc053b4efcee.zip
Bring pychess -- new version -- back from the void.
Take maintainership. PR: 245379 Submitted by: self
Notes
Notes: svn path=/head/; revision=531116
Diffstat (limited to 'games/py-pychess')
-rw-r--r--games/py-pychess/Makefile28
-rw-r--r--games/py-pychess/distinfo3
-rw-r--r--games/py-pychess/files/patch-setup9
-rw-r--r--games/py-pychess/pkg-descr22
-rw-r--r--games/py-pychess/pkg-message10
5 files changed, 72 insertions, 0 deletions
diff --git a/games/py-pychess/Makefile b/games/py-pychess/Makefile
new file mode 100644
index 000000000000..d3362f9f5151
--- /dev/null
+++ b/games/py-pychess/Makefile
@@ -0,0 +1,28 @@
+# Created by: Nicola Vitale <nivit@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pychess
+PORTVERSION= 1.0.0
+CATEGORIES= games python
+MASTER_SITES= https://github.com/pychess/pychess/releases/download/${PORTVERSION}/
+
+MAINTAINER= mi@aldan.algebra.com
+COMMENT= GTK chess client written in Python
+
+LICENSE= GPLv3
+
+COMMON_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pexpect>0:misc/py-pexpect@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sqlalchemy*>1.:databases/py-sqlalchemy13@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}psutil*>0.:sysutils/py-psutil@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}websockets*>7.:devel/py-websockets@${PY_FLAVOR}
+RUN_DEPENDS= ${COMMON_DEPENDS}
+BUILD_DEPENDS= ${COMMON_DEPENDS}
+
+USES= desktop-file-utils display gettext python:3.3+
+USE_GSTREAMER1= yes
+USE_PYTHON= distutils autoplist
+USE_GNOME= gtksourceview3:run glib20 gtk30 librsvg2 introspection
+INSTALLS_ICONS= yes
+PYDISTUTILS_INSTALLNOSINGLE= nope
+
+.include <bsd.port.mk>
diff --git a/games/py-pychess/distinfo b/games/py-pychess/distinfo
new file mode 100644
index 000000000000..bfb9794a759c
--- /dev/null
+++ b/games/py-pychess/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1586042912
+SHA256 (pychess-1.0.0.tar.gz) = cf6c326068b11287cb656eb30ad99a3026b7827d33e6a73b7d2cc09317dddabc
+SIZE (pychess-1.0.0.tar.gz) = 12853354
diff --git a/games/py-pychess/files/patch-setup b/games/py-pychess/files/patch-setup
new file mode 100644
index 000000000000..96fc1fb3be87
--- /dev/null
+++ b/games/py-pychess/files/patch-setup
@@ -0,0 +1,9 @@
+--- setup.py 2019-03-10 06:22:01.000000000 -0400
++++ setup.py 2020-04-05 12:09:51.478233000 -0400
+@@ -343,5 +343,4 @@
+ scripts=['pychess'],
+ options={"build_exe": build_exe_options,
+- "bdist_msi": bdist_msi_options},
+- executables=executables
++ "bdist_msi": bdist_msi_options}
+ )
diff --git a/games/py-pychess/pkg-descr b/games/py-pychess/pkg-descr
new file mode 100644
index 000000000000..0077c9029880
--- /dev/null
+++ b/games/py-pychess/pkg-descr
@@ -0,0 +1,22 @@
+PyChess is a gnome-inspired chess client written in Python.
+
+Features
+
+ * CECP and UCI Engine support
+ * Free on-line play on the FICS chess servers
+ * Read and writes the PGN, EPD and FEN chess file formats
+ * Built-in Python based engine
+ * Undo and pause functions
+ * Board and piece animation
+ * Drag and drop
+ * Tabbed interface
+ * Hints and spy arrows
+ * Opening book side panel using sqlite
+ * Scoreplot side panel
+ * "Enter game" in pgn dialog
+ * Internationalised or figure pieces in notation
+ * Optional sounds
+ * Legal move highlighting
+ * A nice and accessible look
+
+WWW: http://www.pychess.org/
diff --git a/games/py-pychess/pkg-message b/games/py-pychess/pkg-message
new file mode 100644
index 000000000000..9fe397b92055
--- /dev/null
+++ b/games/py-pychess/pkg-message
@@ -0,0 +1,10 @@
+PyChess can let you play against others online.
+
+To play against your own computer, install one or more of the
+game-engines:
+
+ * games/crafty
+ * games/gnuchess
+ * games/phalanx
+ * games/sjeng
+ * games/stockfish