aboutsummaryrefslogtreecommitdiff
path: root/games/py-sgflib
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-01-27 12:28:48 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-01-27 12:28:48 +0000
commit1cb42a41f7552d22eaf7751a488229b697f7c6f2 (patch)
treee3d9d1985c45f4d32faec741d82aaa8274f8eec8 /games/py-sgflib
parent3f79a2d77585e74d1c5d7a09823a9c9fc289a297 (diff)
downloadports-1cb42a41f7552d22eaf7751a488229b697f7c6f2.tar.gz
ports-1cb42a41f7552d22eaf7751a488229b697f7c6f2.zip
Add py-sgflib, a python module containing a parser and classes for SGF, the
Smart Game Format. It is a part of the Go Tools Project. PR: ports/61419 Submitted by: Leland Wang <llwang@infor.org>
Notes
Notes: svn path=/head/; revision=99263
Diffstat (limited to 'games/py-sgflib')
-rw-r--r--games/py-sgflib/Makefile27
-rw-r--r--games/py-sgflib/distinfo1
-rw-r--r--games/py-sgflib/pkg-descr5
-rw-r--r--games/py-sgflib/pkg-plist2
4 files changed, 35 insertions, 0 deletions
diff --git a/games/py-sgflib/Makefile b/games/py-sgflib/Makefile
new file mode 100644
index 000000000000..86437594704f
--- /dev/null
+++ b/games/py-sgflib/Makefile
@@ -0,0 +1,27 @@
+# Ports collection makefile for: py-sgflib
+# Date created: January 16, 2004
+# Whom: Leland Wang <llwang@infor.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sgflib
+PORTVERSION= 1.0
+CATEGORIES= games python
+MASTER_SITES= http://gotools.sourceforge.net/sgflib/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= llwang@infor.org
+COMMENT= Smart Game Format Parser Library for Python
+
+USE_PYTHON= yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/sgflib.py ${PYTHON_SITELIBDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/typelib.py ${PYTHON_SITELIBDIR}
+
+.include <bsd.port.mk>
diff --git a/games/py-sgflib/distinfo b/games/py-sgflib/distinfo
new file mode 100644
index 000000000000..ea4ef6e59340
--- /dev/null
+++ b/games/py-sgflib/distinfo
@@ -0,0 +1 @@
+MD5 (sgflib.tgz) = 12a5785b28015613b9e9b4564f300216
diff --git a/games/py-sgflib/pkg-descr b/games/py-sgflib/pkg-descr
new file mode 100644
index 000000000000..bfda412a7bc8
--- /dev/null
+++ b/games/py-sgflib/pkg-descr
@@ -0,0 +1,5 @@
+Sgflib is a python module containing a parser and classes for SGF, the
+Smart Game Format. It is a part of the Go Tools Project.
+
+Author: David John Goodger <goodger@python.org>
+WWW: http://gotools.sourceforge.net/sgflib/
diff --git a/games/py-sgflib/pkg-plist b/games/py-sgflib/pkg-plist
new file mode 100644
index 000000000000..80fb40d4b41d
--- /dev/null
+++ b/games/py-sgflib/pkg-plist
@@ -0,0 +1,2 @@
+%%PYTHON_SITELIBDIR%%/sgflib.py
+%%PYTHON_SITELIBDIR%%/typelib.py