aboutsummaryrefslogtreecommitdiff
path: root/games/pyawale
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2013-11-21 00:50:01 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2013-11-21 00:50:01 +0000
commit4e9551c1b246347f66b3d3bc23c0bcdcfebd7619 (patch)
treecf54a6d16c2edcec742caf1bb4dbfca7bd210b6b /games/pyawale
parent256912bc55d790422d887b8b56efd5e29397e3a6 (diff)
downloadports-4e9551c1b246347f66b3d3bc23c0bcdcfebd7619.tar.gz
ports-4e9551c1b246347f66b3d3bc23c0bcdcfebd7619.zip
Notes
Diffstat (limited to 'games/pyawale')
-rw-r--r--games/pyawale/Makefile32
-rw-r--r--games/pyawale/pkg-plist85
2 files changed, 99 insertions, 18 deletions
diff --git a/games/pyawale/Makefile b/games/pyawale/Makefile
index e1657ec76266..f97f3dc135b2 100644
--- a/games/pyawale/Makefile
+++ b/games/pyawale/Makefile
@@ -7,7 +7,7 @@ PORTREVISION= 4
CATEGORIES= games python
MASTER_SITES= http://download.gna.org/pyawale/
-MAINTAINER= nemysis@gmx.ch
+MAINTAINER= nemysis@FreeBSD.org
COMMENT= African board game
LICENSE= GPLv2
@@ -16,11 +16,8 @@ RUN_DEPENDS= ${PYGAME}
USE_PYTHON= yes
-PLIST_FILES= bin/${PORTNAME} \
- share/applications/${PORTNAME}.desktop \
- share/pixmaps/${PORTNAME}.png
+SUB_FILES= ${PORTNAME}
-PORTDATA= *
PORTDOCS= *
DOCSRCDIR1= ${WRKSRC}
@@ -30,9 +27,8 @@ DOCSRCDIR2= ${WRKSRC}/docs
DOCSDIR2= ${DOCSDIR}/docs
DOC_FILES2= *.rest *.html *.jpg
-SUB_FILES= ${PORTNAME}
+OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
@@ -45,15 +41,15 @@ do-build:
@${PYTHON_CMD} -O -m compileall ${WRKSRC}
do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
- ${MKDIR} ${DATADIR}
- @(cd ${WRKSRC}/src && ${COPYTREE_SHARE} \* ${DATADIR})
- ${INSTALL_DATA} ${WRKSRC}/docs/${PORTNAME}.png ${PREFIX}/share/pixmaps
- ${INSTALL_DATA} ${WRKSRC}/docs/${PORTNAME}.desktop ${PREFIX}/share/applications
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${DOCSDIR}
- ${MKDIR} ${DOCSDIR2}
- ${INSTALL_DATA} ${DOC_FILES2:S|^|${DOCSRCDIR2}/|} ${DOCSDIR2}
-.endif
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ @(cd ${WRKSRC}/src && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR})
+ ${INSTALL_DATA} ${WRKSRC}/docs/${PORTNAME}.png ${STAGEDIR}${PREFIX}/share/pixmaps/
+ @${MKDIR} ${STAGEDIR}${DESKTOPDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/${PORTNAME}.desktop ${STAGEDIR}${DESKTOPDIR}
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR2}
+ ${INSTALL_DATA} ${DOC_FILES2:S|^|${DOCSRCDIR2}/|} ${STAGEDIR}${DOCSDIR2}
+
.include <bsd.port.mk>
diff --git a/games/pyawale/pkg-plist b/games/pyawale/pkg-plist
new file mode 100644
index 000000000000..c1670af65b9f
--- /dev/null
+++ b/games/pyawale/pkg-plist
@@ -0,0 +1,85 @@
+bin/pyawale
+share/applications/pyawale.desktop
+share/pixmaps/pyawale.png
+%%DATADIR%%/__init__.py
+%%DATADIR%%/__init__.pyc
+%%DATADIR%%/__init__.pyo
+%%DATADIR%%/awale.py
+%%DATADIR%%/awale.pyc
+%%DATADIR%%/awale.pyo
+%%DATADIR%%/images/awale_board_closed.png
+%%DATADIR%%/images/awale_board_empty.png
+%%DATADIR%%/images/awale_north_0.png
+%%DATADIR%%/images/awale_north_1.png
+%%DATADIR%%/images/awale_north_10.png
+%%DATADIR%%/images/awale_north_11.png
+%%DATADIR%%/images/awale_north_12.png
+%%DATADIR%%/images/awale_north_13.png
+%%DATADIR%%/images/awale_north_14.png
+%%DATADIR%%/images/awale_north_15.png
+%%DATADIR%%/images/awale_north_16.png
+%%DATADIR%%/images/awale_north_17.png
+%%DATADIR%%/images/awale_north_18.png
+%%DATADIR%%/images/awale_north_19.png
+%%DATADIR%%/images/awale_north_2.png
+%%DATADIR%%/images/awale_north_20.png
+%%DATADIR%%/images/awale_north_21.png
+%%DATADIR%%/images/awale_north_22.png
+%%DATADIR%%/images/awale_north_23.png
+%%DATADIR%%/images/awale_north_24.png
+%%DATADIR%%/images/awale_north_25.png
+%%DATADIR%%/images/awale_north_3.png
+%%DATADIR%%/images/awale_north_4.png
+%%DATADIR%%/images/awale_north_5.png
+%%DATADIR%%/images/awale_north_6.png
+%%DATADIR%%/images/awale_north_7.png
+%%DATADIR%%/images/awale_north_8.png
+%%DATADIR%%/images/awale_north_9.png
+%%DATADIR%%/images/awale_seed_0.png
+%%DATADIR%%/images/awale_seed_10d.png
+%%DATADIR%%/images/awale_seed_11d.png
+%%DATADIR%%/images/awale_seed_12d.png
+%%DATADIR%%/images/awale_seed_12d_13.png
+%%DATADIR%%/images/awale_seed_14d.png
+%%DATADIR%%/images/awale_seed_15d.png
+%%DATADIR%%/images/awale_seed_1d.png
+%%DATADIR%%/images/awale_seed_2c.png
+%%DATADIR%%/images/awale_seed_3b.png
+%%DATADIR%%/images/awale_seed_4D.png
+%%DATADIR%%/images/awale_seed_5d.png
+%%DATADIR%%/images/awale_seed_6c.png
+%%DATADIR%%/images/awale_seed_7b.png
+%%DATADIR%%/images/awale_seed_8e.png
+%%DATADIR%%/images/awale_seed_9d.png
+%%DATADIR%%/images/awale_south_0.png
+%%DATADIR%%/images/awale_south_1.png
+%%DATADIR%%/images/awale_south_10.png
+%%DATADIR%%/images/awale_south_11.png
+%%DATADIR%%/images/awale_south_12.png
+%%DATADIR%%/images/awale_south_13.png
+%%DATADIR%%/images/awale_south_14.png
+%%DATADIR%%/images/awale_south_15.png
+%%DATADIR%%/images/awale_south_16.png
+%%DATADIR%%/images/awale_south_17.png
+%%DATADIR%%/images/awale_south_18.png
+%%DATADIR%%/images/awale_south_19.png
+%%DATADIR%%/images/awale_south_2.png
+%%DATADIR%%/images/awale_south_20.png
+%%DATADIR%%/images/awale_south_21.png
+%%DATADIR%%/images/awale_south_22.png
+%%DATADIR%%/images/awale_south_23.png
+%%DATADIR%%/images/awale_south_24.png
+%%DATADIR%%/images/awale_south_25.png
+%%DATADIR%%/images/awale_south_3.png
+%%DATADIR%%/images/awale_south_4.png
+%%DATADIR%%/images/awale_south_5.png
+%%DATADIR%%/images/awale_south_6.png
+%%DATADIR%%/images/awale_south_7.png
+%%DATADIR%%/images/awale_south_8.png
+%%DATADIR%%/images/awale_south_9.png
+%%DATADIR%%/images/freesansbold.ttf
+%%DATADIR%%/pyawale.py
+%%DATADIR%%/pyawale.pyc
+%%DATADIR%%/pyawale.pyo
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%