aboutsummaryrefslogtreecommitdiff
path: root/games/pysolfc
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2020-02-24 11:36:15 +0000
committerKai Knoblich <kai@FreeBSD.org>2020-02-24 11:36:15 +0000
commit74174b26616baa21c285c0515b591e7d738c5c0f (patch)
tree1c10419849a595f8ebfa59836f2e676bb7ec3469 /games/pysolfc
parent45b08b671d6459dc7e71950a89cac654920ec089 (diff)
downloadports-74174b26616baa21c285c0515b591e7d738c5c0f.tar.gz
ports-74174b26616baa21c285c0515b591e7d738c5c0f.zip
Notes
Diffstat (limited to 'games/pysolfc')
-rw-r--r--games/pysolfc/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/games/pysolfc/Makefile b/games/pysolfc/Makefile
index 78935e5d7822..4f721f532f4c 100644
--- a/games/pysolfc/Makefile
+++ b/games/pysolfc/Makefile
@@ -2,6 +2,7 @@
PORTNAME= pysolfc
DISTVERSION= 2.6.4
+PORTREVISION= 1
CATEGORIES= games python
MASTER_SITES= SF/${PORTNAME}/PySolFC/${PYSOLFCDIR} \
SF/${PORTNAME}/PySolFC-Cardsets/${CARDSETDIR}:cardsets
@@ -15,8 +16,7 @@ COMMENT= Solitaire game, written in Python and the successor of PySol
LICENSE= GPLv2+ GPLv3+ MIT PCW PD UCP UCJ ULG
LICENSE_COMB= multi
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}random2>=0:math/py-random2@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}random2>=0:math/py-random2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${PY_FLAVOR}
@@ -74,6 +74,14 @@ PYSOLFCDIST= ${PYSOLFCDIR}${EXTRACT_SUFX}
CARDSETDIR= PySolFC-Cardsets-2.0
CARDSETDIST= ${CARDSETDIR}.tar.bz2
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3500
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow6>0:graphics/py-pillow6@${PY_FLAVOR}
+.else
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
+.endif
+
post-patch:
@${MV} ${WRKSRC}/pysol.py ${WRKSRC}/pysolfc
@${REINPLACE_CMD} -e 's|pysol.py|pysolfc|' ${WRKSRC}/setup.py
@@ -96,4 +104,4 @@ post-install:
(cd ${WRKDIR}/${CARDSETDIR} && \
${FIND} . -type f | ${SED} -e 's|^./|${DATADIR_REL}/|' >> ${TMPPLIST})
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>