aboutsummaryrefslogtreecommitdiff
path: root/games/q2pro
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2020-08-31 04:00:21 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2020-08-31 04:00:21 +0000
commit74c61c2ea2b562394f113a4e492b9e9139aea2e5 (patch)
tree27c7cc4cb0da208c893270367b9e0d4a1c571e85 /games/q2pro
parenta18fde5513eda071b83e8d91c11c60c788443db2 (diff)
downloadports-74c61c2ea2b562394f113a4e492b9e9139aea2e5.tar.gz
ports-74c61c2ea2b562394f113a4e492b9e9139aea2e5.zip
Ensure that there is only one variable definition per each object, as
the C (and C++) standards mandated for years and compilers started to enforce as of recently (Clang 11, GCC 10). Reported by: pkg-fallout
Notes
Notes: svn path=/head/; revision=547148
Diffstat (limited to 'games/q2pro')
-rw-r--r--games/q2pro/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/games/q2pro/Makefile b/games/q2pro/Makefile
index 0dc4aef91cfd..1b9a23f4557c 100644
--- a/games/q2pro/Makefile
+++ b/games/q2pro/Makefile
@@ -95,6 +95,11 @@ post-patch:
${WRKSRC}/ref_shared/r_images.c
@${REINPLACE_CMD} -E 's|[[:digit:]]+|${SVN_REV}|' \
${WRKSRC}/include/version.h
+# Fix the build with -fno-common (for Clang 11 and GCC 10)
+ @${REINPLACE_CMD} -e '/^unsigned[[:blank:]]*d_8to24table/,+1d' \
+ ${WRKSRC}/ref_soft/sw_main.c
+ @${REINPLACE_CMD} -e '/\*cl_paused/,+1d' \
+ ${WRKSRC}/source/cl_null.c
do-install:
@${MKDIR} ${STAGEDIR}${LIBDIR}/baseq2