aboutsummaryrefslogtreecommitdiff
path: root/games/q3cellshading
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-11-28 12:04:12 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-11-28 12:04:12 +0000
commit535b6e3bcf3a1f7e9d657c4aef69a7193fa7249e (patch)
tree9ae02190d2874a8318b2123b67b0ccb1b7720d01 /games/q3cellshading
parentb44e0658fc555138a88a039ed5284e4f1842d84b (diff)
downloadports-535b6e3bcf3a1f7e9d657c4aef69a7193fa7249e.tar.gz
ports-535b6e3bcf3a1f7e9d657c4aef69a7193fa7249e.zip
Notes
Diffstat (limited to 'games/q3cellshading')
-rw-r--r--games/q3cellshading/Makefile2
-rw-r--r--games/q3cellshading/files/patch-code-Construct2
-rw-r--r--games/q3cellshading/files/patch-code-unix-Makefile6
3 files changed, 5 insertions, 5 deletions
diff --git a/games/q3cellshading/Makefile b/games/q3cellshading/Makefile
index 00dad03d14da..87f90ca03f09 100644
--- a/games/q3cellshading/Makefile
+++ b/games/q3cellshading/Makefile
@@ -7,7 +7,7 @@
PORTNAME= quake3
PORTVERSION= 1.32b
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= ftp://ftp.idsoftware.com/idstuff/source/ \
http://www.proarena.com/p/ftpx/x8524/quake_3_arena/ \
diff --git a/games/q3cellshading/files/patch-code-Construct b/games/q3cellshading/files/patch-code-Construct
index 5d75e09d9384..8ec4aa967b32 100644
--- a/games/q3cellshading/files/patch-code-Construct
+++ b/games/q3cellshading/files/patch-code-Construct
@@ -49,7 +49,7 @@
else
{
- $BASE_CFLAGS = $COMMON_CFLAGS . '-DNDEBUG -O6 -mcpu=pentiumpro -march=pentium -fomit-frame-pointer -ffast-math -malign-loops=2 -malign-jumps=2 -malign-functions=2 -fno-strict-aliasing -fstrength-reduce ';
-+ $BASE_CFLAGS = $COMMON_CFLAGS . '-DNDEBUG -O6 -march=pentiumpro -march=pentium -fomit-frame-pointer -ffast-math -falign-loops=2 -falign-jumps=2 -falign-functions=2 -fno-strict-aliasing -fstrength-reduce ';
++ $BASE_CFLAGS = $COMMON_CFLAGS . '-DNDEBUG -O6 -fomit-frame-pointer -ffast-math -falign-loops=2 -falign-jumps=2 -falign-functions=2 -fno-strict-aliasing -fstrength-reduce ';
$BSPC_BASE_CFLAGS = $BASE_CFLAGS . '-DLINUX -DBSPC -Dstricmp=strcasecmp ';
}
diff --git a/games/q3cellshading/files/patch-code-unix-Makefile b/games/q3cellshading/files/patch-code-unix-Makefile
index 415a976544fc..47f9174f8a2e 100644
--- a/games/q3cellshading/files/patch-code-unix-Makefile
+++ b/games/q3cellshading/files/patch-code-unix-Makefile
@@ -14,10 +14,10 @@
# NOTE: the -fomit-frame-pointer option leads to an unstable binary on my test box if it was built on the main box
# but building on the Mdk 7.2 baseline seems to work
- RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG -O6 -mcpu=pentiumpro -march=pentium -fomit-frame-pointer -pipe -ffast-math -malign-loops=2 -malign-jumps=2 -malign-functions=2 -fno-strict-aliasing -fstrength-reduce
-+ RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG -O6 -march=pentiumpro -march=pentium -fomit-frame-pointer -pipe -ffast-math -falign-loops=2 -falign-jumps=2 -falign-functions=2 -fno-strict-aliasing -fstrength-reduce
++ RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG -O6 -fomit-frame-pointer -pipe -ffast-math -falign-loops=2 -falign-jumps=2 -falign-functions=2 -fno-strict-aliasing -fstrength-reduce
# TTimo: use this for building on P3 gcc 2.95.3 libc2.2 for all targets (experimental! -fomit-fram-pointer removed)
-# RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG -O6 -mcpu=pentiumpro -march=pentium -pipe -ffast-math -malign-loops=2 -malign-jumps=2 -malign-functions=2 -fno-strict-aliasing -fstrength-reduce
-+# RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG -O6 -march=pentiumpro -march=pentium -pipe -ffast-math -falign-loops=2 -falign-jumps=2 -falign-functions=2 -fno-strict-aliasing -fstrength-reduce
++# RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG -O6 -pipe -ffast-math -falign-loops=2 -falign-jumps=2 -falign-functions=2 -fno-strict-aliasing -fstrength-reduce
endif
endif
@@ -35,7 +35,7 @@
NEWPGCC=/home/raistllin/src/gcc/build/install/bin/gcc
CC=$(shell if [ -f $(NEWPGCC) ]; then echo $(NEWPGCC); else echo pgcc; fi )
-RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG -O6 -mcpu=pentiumpro -march=pentium -fomit-frame-pointer -pipe -ffast-math -malign-loops=2 -malign-jumps=2 -malign-functions=2 -fno-strict-aliasing - fstrength-reduce
-+RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG -O6 -march=pentiumpro -march=pentium -fomit-frame-pointer -pipe -ffast-math -falign-loops=2 -falign-jumps=2 -falign-functions=2 -fno-strict-aliasing - fstrength-reduce
++RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG -O6 -fomit-frame-pointer -pipe -ffast-math -falign-loops=2 -falign-jumps=2 -falign-functions=2 -fno-strict-aliasing - fstrength-reduce
endif
LIBEXT=a