aboutsummaryrefslogtreecommitdiff
path: root/games/qstat
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2020-08-31 04:00:21 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2020-08-31 04:00:21 +0000
commit74c61c2ea2b562394f113a4e492b9e9139aea2e5 (patch)
tree27c7cc4cb0da208c893270367b9e0d4a1c571e85 /games/qstat
parenta18fde5513eda071b83e8d91c11c60c788443db2 (diff)
downloadports-74c61c2ea2b562394f113a4e492b9e9139aea2e5.tar.gz
ports-74c61c2ea2b562394f113a4e492b9e9139aea2e5.zip
Ensure that there is only one variable definition per each object, as
the C (and C++) standards mandated for years and compilers started to enforce as of recently (Clang 11, GCC 10). Reported by: pkg-fallout
Notes
Notes: svn path=/head/; revision=547148
Diffstat (limited to 'games/qstat')
-rw-r--r--games/qstat/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/games/qstat/Makefile b/games/qstat/Makefile
index 7abf956f6517..55e32bef6cb6 100644
--- a/games/qstat/Makefile
+++ b/games/qstat/Makefile
@@ -30,7 +30,9 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e 's|qstat\.cfg|&.sample|' ${WRKSRC}/Makefile.am
- @${REINPLACE_CMD} -e 's|OpenBSD|${OPSYS}|' ${WRKSRC}/qstat.c
+ @${REINPLACE_CMD} -e 's|__hpux|${OPSYS}|' ${WRKSRC}/qstat.c
+ @${ECHO_CMD} 'int do_dump = 0;' >> ${WRKSRC}/qstat.c
+ @${REINPLACE_CMD} -e 's|^int do_dump|extern &|' ${WRKSRC}/debug.h
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}/info ${STAGEDIR}${DOCSDIR}/template