aboutsummaryrefslogtreecommitdiff
path: root/games/quake2-ctf
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-07-28 22:24:50 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-07-28 22:24:50 +0000
commit676baf734b9b3621bd527551b883861bdc066c41 (patch)
tree5648caf704928fe268854ce0d3788762be6549a7 /games/quake2-ctf
parent9b386ca62058418126c1ee6d37ef6139397d0b63 (diff)
downloadports-676baf734b9b3621bd527551b883861bdc066c41.tar.gz
ports-676baf734b9b3621bd527551b883861bdc066c41.zip
Capture the Flag offers an exciting variation on team play. It gives more
meaning to base defense along with offensive positioning and organized strikes. The basic premise is this: Attack the enemy base, grab their flag, then take it back to your base. In this variation you must touch your base flag when carrying the enemy flag in order to score - if your flag isn't at your base when you return, you or your team must get it back to gain points and captures.
Notes
Notes: svn path=/head/; revision=169009
Diffstat (limited to 'games/quake2-ctf')
-rw-r--r--games/quake2-ctf/Makefile55
-rw-r--r--games/quake2-ctf/distinfo6
-rw-r--r--games/quake2-ctf/files/Makefile12
-rw-r--r--games/quake2-ctf/pkg-descr10
-rw-r--r--games/quake2-ctf/pkg-plist7
5 files changed, 90 insertions, 0 deletions
diff --git a/games/quake2-ctf/Makefile b/games/quake2-ctf/Makefile
new file mode 100644
index 000000000000..12fa744ce9f6
--- /dev/null
+++ b/games/quake2-ctf/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: quake2-ctf
+# Date created: 26 Jul 2006
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= ctf
+PORTVERSION= 1.50
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_IDSOFTWARE:S|$|:data,src|}
+MASTER_SITE_SUBDIR= quake2/ctf/:data \
+ quake2/ctf/source/:src
+PKGNAMEPREFIX= ${Q2PKGNAMEPREFIX}
+DISTFILES= ${CTF_DATA}:data \
+ ${CTF_SRC}:src
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= Quake II CTF (Capture The Flag) modification
+
+USE_ZIP= yes
+NO_WRKSUBDIR= yes
+
+LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}
+DOCSDIR= ${PREFIX}/share/doc/${LATEST_LINK}
+
+CTF_DATA= q2ctf${PORTVERSION:S/.//}.zip
+CTF_SRC= q2ctf-1.02-source.shar.Z
+
+.include "${.CURDIR}/../quake2-data/Makefile.include"
+
+.include <bsd.port.pre.mk>
+
+do-extract:
+ @${MKDIR} ${WRKDIR}
+ @cd ${WRKDIR} && \
+ uncompress -c ${DISTDIR}/${CTF_SRC} | ${TAIL} +394 | ${SH}
+ @${UNZIP_CMD} -aq -d ${WRKDIR}/ctf \
+ ${DISTDIR}/${CTF_DATA} -x *.dll *.ico
+
+post-extract:
+ @${CP} ${FILESDIR}/${MAKEFILE} ${WRKSRC}
+
+do-install:
+ ${MKDIR} ${Q2DIR}/ctf
+ ${INSTALL_PROGRAM} ${WRKSRC}/game.so ${Q2DIR}/ctf
+.for f in *.cfg *.pak
+ ${INSTALL_DATA} ${WRKSRC}/ctf/${f} ${Q2DIR}/ctf
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/ctf/readme.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/games/quake2-ctf/distinfo b/games/quake2-ctf/distinfo
new file mode 100644
index 000000000000..43bd65563abc
--- /dev/null
+++ b/games/quake2-ctf/distinfo
@@ -0,0 +1,6 @@
+MD5 (q2ctf150.zip) = 89218caf5950b17663d4f81df7e8f893
+SHA256 (q2ctf150.zip) = 5e85db1bff51aa53e12307bd3251aa4b507b5a7a47004a862d8ae3777c5a87c1
+SIZE (q2ctf150.zip) = 9559697
+MD5 (q2ctf-1.02-source.shar.Z) = 1644c4fd145a74160f3f013452ee4103
+SHA256 (q2ctf-1.02-source.shar.Z) = e6efdfddb55ba9f573e030886032a6609590cf2a992bdea1630bd217afa1d72a
+SIZE (q2ctf-1.02-source.shar.Z) = 277487
diff --git a/games/quake2-ctf/files/Makefile b/games/quake2-ctf/files/Makefile
new file mode 100644
index 000000000000..424646b48e22
--- /dev/null
+++ b/games/quake2-ctf/files/Makefile
@@ -0,0 +1,12 @@
+# $FreeBSD$
+
+SHLIB_NAME= game.so
+
+SRCS!= ls *.c
+
+CFLAGS+= -Dstricmp=strcasecmp -ffast-math -funroll-loops \
+ -fomit-frame-pointer -fexpensive-optimizations
+
+LDFLAGS+= -L/lib -lm
+
+.include <bsd.lib.mk>
diff --git a/games/quake2-ctf/pkg-descr b/games/quake2-ctf/pkg-descr
new file mode 100644
index 000000000000..a98f75a322af
--- /dev/null
+++ b/games/quake2-ctf/pkg-descr
@@ -0,0 +1,10 @@
+Capture the Flag offers an exciting variation on team play. It gives more
+meaning to base defense along with offensive positioning and organized
+strikes.
+
+The basic premise is this:
+
+Attack the enemy base, grab their flag, then take it back to your base. In
+this variation you must touch your base flag when carrying the enemy flag in
+order to score - if your flag isn't at your base when you return, you or your
+team must get it back to gain points and captures.
diff --git a/games/quake2-ctf/pkg-plist b/games/quake2-ctf/pkg-plist
new file mode 100644
index 000000000000..6b618e4931bb
--- /dev/null
+++ b/games/quake2-ctf/pkg-plist
@@ -0,0 +1,7 @@
+%%Q2DIR%%/ctf/game.so
+%%Q2DIR%%/ctf/pak0.pak
+%%Q2DIR%%/ctf/pak1.pak
+%%Q2DIR%%/ctf/server.cfg
+%%PORTDOCS%%%%DOCSDIR%%/readme.txt
+@dirrm %%Q2DIR%%/ctf
+%%PORTDOCS%%@dirrm %%DOCSDIR%%