aboutsummaryrefslogtreecommitdiff
path: root/games/quake2-psychomod
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-12-26 04:28:41 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-12-26 04:28:41 +0000
commitcb0aa15545bfbbe5fda9b4bd79deaafe70dfa172 (patch)
tree3be501156ad696bf84a0dda4d795301990aa282b /games/quake2-psychomod
parentebc1071c88e5eecb86c5762aba725c6d17f77304 (diff)
downloadports-cb0aa15545bfbbe5fda9b4bd79deaafe70dfa172.tar.gz
ports-cb0aa15545bfbbe5fda9b4bd79deaafe70dfa172.zip
Psychomod modification for Quake II.
Notes
Notes: svn path=/head/; revision=180771
Diffstat (limited to 'games/quake2-psychomod')
-rw-r--r--games/quake2-psychomod/Makefile44
-rw-r--r--games/quake2-psychomod/distinfo3
-rw-r--r--games/quake2-psychomod/files/patch-src__Makefile71
-rw-r--r--games/quake2-psychomod/pkg-descr1
-rw-r--r--games/quake2-psychomod/pkg-plist7
5 files changed, 126 insertions, 0 deletions
diff --git a/games/quake2-psychomod/Makefile b/games/quake2-psychomod/Makefile
new file mode 100644
index 000000000000..962193db078f
--- /dev/null
+++ b/games/quake2-psychomod/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: quake2-psychomod
+# Date created: 2006-12-24
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= psychomod
+PORTVERSION= 3.1
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= alepulver
+PKGNAMEPREFIX= ${Q2PKGNAMEPREFIX}
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= Psychomod modification for Quake II
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+BUILD_WRKSRC= ${WRKSRC}/src
+ALL_TARGET= release
+
+DOCSDIR= ${PREFIX}/share/doc/${LATEST_LINK}
+
+.include "${.CURDIR}/../quake2-data/Makefile.include"
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/__linux__/__unix__/' \
+ ${BUILD_WRKSRC}/q_shared.[ch]
+
+do-install:
+ ${MKDIR} ${Q2DIR}/${PORTNAME}
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/release/psychomod/game.so \
+ ${Q2DIR}/${PORTNAME}
+ cd ${WRKSRC} && ${INSTALL_DATA} *.cfg pak0.pak ${Q2DIR}/${PORTNAME}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/readme.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/games/quake2-psychomod/distinfo b/games/quake2-psychomod/distinfo
new file mode 100644
index 000000000000..866ae247353a
--- /dev/null
+++ b/games/quake2-psychomod/distinfo
@@ -0,0 +1,3 @@
+MD5 (psychomod-3.1.tar.bz2) = 3e1c6fe563db80de2740d6042891c2dd
+SHA256 (psychomod-3.1.tar.bz2) = cf4b45c5b423652b0be5841ce6678f2c27d2c65b441c06f6cf265766de0b2388
+SIZE (psychomod-3.1.tar.bz2) = 1510599
diff --git a/games/quake2-psychomod/files/patch-src__Makefile b/games/quake2-psychomod/files/patch-src__Makefile
new file mode 100644
index 000000000000..3c8b681b5196
--- /dev/null
+++ b/games/quake2-psychomod/files/patch-src__Makefile
@@ -0,0 +1,71 @@
+--- ./src/Makefile.orig Wed Feb 1 20:46:55 2006
++++ ./src/Makefile Sun Dec 24 16:23:24 2006
+@@ -16,20 +16,10 @@
+ # this nice line comes from the linux kernel makefile
+ ARCH := $(shell uname -m | sed -e s/i.86/i386/ -e s/sun4u/sparc/ -e s/sparc64/sparc/ -e s/arm.*/arm/ -e s/sa110/arm/ -e s/alpha/axp/)
+
+-ifneq ($(ARCH),i386)
+-ifneq ($(ARCH),axp)
+-ifneq ($(ARCH),ppc)
+-ifneq ($(ARCH),sparc)
+-$(error arch $(ARCH) is currently not supported)
+-endif
+-endif
+-endif
+-endif
+-
+-BUILD_DEBUG_DIR=debug$(ARCH)
+-BUILD_RELEASE_DIR=release$(ARCH)
++BUILD_DEBUG_DIR=debug
++BUILD_RELEASE_DIR=release
+
+-CC=gcc
++CC?=gcc
+ BASE_CFLAGS=-Dstricmp=strcasecmp
+
+ RELEASE_CFLAGS=$(BASE_CFLAGS) -ffast-math -funroll-loops \
+@@ -53,7 +43,7 @@
+ DO_CC=$(CC) $(CFLAGS) -o $@ -c $<
+ DO_SHLIB_CC=$(CC) $(CFLAGS) $(SHLIBCFLAGS) -o $@ -c $<
+
+-TARGETS=$(BUILDDIR)/psychomod/game$(ARCH).$(SHLIBEXT)
++TARGETS=$(BUILDDIR)/psychomod/game.$(SHLIBEXT)
+
+ all:
+ @echo
+@@ -64,11 +54,11 @@
+ @echo
+ debug:
+ @-mkdir -p $(BUILD_DEBUG_DIR)/psychomod
+- $(MAKE) targets BUILDDIR=$(BUILD_DEBUG_DIR) CFLAGS="$(DEBUG_CFLAGS)"
++ $(MAKE) targets BUILDDIR=$(BUILD_DEBUG_DIR) CFLAGS+="$(DEBUG_CFLAGS)"
+
+ release:
+ @-mkdir -p $(BUILD_RELEASE_DIR)/psychomod
+- $(MAKE) targets BUILDDIR=$(BUILD_RELEASE_DIR) CFLAGS="$(RELEASE_CFLAGS)"
++ $(MAKE) targets BUILDDIR=$(BUILD_RELEASE_DIR) CFLAGS+="$(RELEASE_CFLAGS)"
+
+ targets: $(TARGETS)
+
+@@ -124,7 +114,7 @@
+ $(BUILDDIR)/p_weapon.o \
+ $(BUILDDIR)/q_shared.o
+
+-$(BUILDDIR)/psychomod/game$(ARCH).$(SHLIBEXT) : $(GAME_OBJS)
++$(BUILDDIR)/psychomod/game.$(SHLIBEXT) : $(GAME_OBJS)
+ $(CC) $(CFLAGS) $(SHLIBLDFLAGS) -o $@ $(GAME_OBJS)
+
+ $(BUILDDIR)/g_ai.o : g_ai.c
+@@ -282,10 +272,10 @@
+ clean: clean-debug clean-release
+
+ clean-debug:
+- $(MAKE) clean2 BUILDDIR=$(BUILD_DEBUG_DIR) CFLAGS="$(DEBUG_CFLAGS)"
++ $(MAKE) clean2 BUILDDIR=$(BUILD_DEBUG_DIR) CFLAGS+="$(DEBUG_CFLAGS)"
+
+ clean-release:
+- $(MAKE) clean2 BUILDDIR=$(BUILD_RELEASE_DIR) CFLAGS="$(DEBUG_CFLAGS)"
++ $(MAKE) clean2 BUILDDIR=$(BUILD_RELEASE_DIR) CFLAGS+="$(DEBUG_CFLAGS)"
+
+ clean2:
+ -rm -f $(GAME_OBJS)
diff --git a/games/quake2-psychomod/pkg-descr b/games/quake2-psychomod/pkg-descr
new file mode 100644
index 000000000000..b61dbe2dca82
--- /dev/null
+++ b/games/quake2-psychomod/pkg-descr
@@ -0,0 +1 @@
+Psychomod modification for Quake II.
diff --git a/games/quake2-psychomod/pkg-plist b/games/quake2-psychomod/pkg-plist
new file mode 100644
index 000000000000..37d28b0c32e9
--- /dev/null
+++ b/games/quake2-psychomod/pkg-plist
@@ -0,0 +1,7 @@
+%%PORTDOCS%%%%DOCSDIR%%/readme.txt
+%%Q2DIR%%/psychomod/game.so
+%%Q2DIR%%/psychomod/pak0.pak
+%%Q2DIR%%/psychomod/server_dm.cfg
+%%Q2DIR%%/psychomod/uservars.cfg
+@dirrm %%Q2DIR%%/psychomod
+%%PORTDOCS%%@dirrm %%DOCSDIR%%