aboutsummaryrefslogtreecommitdiff
path: root/games/quake2-relay
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2006-03-24 13:56:49 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2006-03-24 13:56:49 +0000
commitc139494f6050458193611f7ab68cec50c68cd094 (patch)
tree590d55d8ffa04a9f49f5147434b826263df14010 /games/quake2-relay
parentd52139f9a6931514086f5b5745cf48b9d2be2094 (diff)
downloadports-c139494f6050458193611f7ab68cec50c68cd094.tar.gz
ports-c139494f6050458193611f7ab68cec50c68cd094.zip
Q2-Relay is multi-view demo recording facility for Quake II.
Notes
Notes: svn path=/head/; revision=158066
Diffstat (limited to 'games/quake2-relay')
-rw-r--r--games/quake2-relay/Makefile61
-rw-r--r--games/quake2-relay/distinfo3
-rw-r--r--games/quake2-relay/pkg-descr17
3 files changed, 81 insertions, 0 deletions
diff --git a/games/quake2-relay/Makefile b/games/quake2-relay/Makefile
new file mode 100644
index 000000000000..c427dccbf249
--- /dev/null
+++ b/games/quake2-relay/Makefile
@@ -0,0 +1,61 @@
+# New ports collection makefile for: Q2 Relay
+# Date created: 23 Mar 2006
+# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= relay
+PORTVERSION= 0.4
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_LOCAL} http://freebsd.nsu.ru/distfiles/
+MASTER_SITE_SUBDIR= danfe
+PKGNAMEPREFIX= ${Q2PKGNAMEPREFIX}
+DISTNAME= relay-${PORTVERSION}.src
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Quake II multi-view demo recording facility
+
+USE_GMAKE= yes
+MAKE_ARGS= MODE=release OBJ_DIR=. OUT_DIR=. Q2MODULE=game.so \
+ QUAKE2_DIR="${Q2DIR}" BIN_DIR="${PREFIX}/bin" \
+ CC="${CC}" CFLAGS="${CFLAGS}"
+
+WRKSRC= ${WRKDIR}/relay-${PORTVERSION}
+
+PLIST_FILES= bin/democonv bin/dm2server \
+ %%Q2DIR%%/release/game.so \
+ %%Q2DIR%%/proxy/relay/game.so \
+ %%Q2DIR%%/proxy/replay/game.so
+PLIST_DIRS= %%Q2DIR%%/proxy/replay %%Q2DIR%%/proxy/relay \
+ %%Q2DIR%%/proxy %%Q2DIR%%/release
+PORTDOCS= FAQ README
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
+CFLAGS+= -fPIC
+.endif
+
+post-patch: .SILENT
+ ${REINPLACE_CMD} -e 's/-ldl// ; /^include/d ; \
+ s/cp -p/${INSTALL_PROGRAM}/' ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e '/random/d' ${WRKSRC}/replay/rp_local.h
+ ${REINPLACE_CMD} -e 's,<malloc\.h>,<stdlib\.h>,' \
+ ${WRKSRC}/common/mem.c
+ cd ${WRKSRC}/common && ${SH} -c 'for i in *.h; do \
+ ${ECHO_CMD} >> $${i}; done'
+ # Reorganize #include's
+ ${ECHO_MSG} -e '35t30\n36d\nwq' | ${ED} -s ${WRKSRC}/common/net.h
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/FAQ ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+ED?= /bin/ed
+
+.include "${.CURDIR}/../quake2-data/Makefile.include"
+
+.include <bsd.port.post.mk>
diff --git a/games/quake2-relay/distinfo b/games/quake2-relay/distinfo
new file mode 100644
index 000000000000..62ca46163653
--- /dev/null
+++ b/games/quake2-relay/distinfo
@@ -0,0 +1,3 @@
+MD5 (relay-0.4.src.tar.gz) = eaf6afb60f45163307aca766a1d9269d
+SHA256 (relay-0.4.src.tar.gz) = 118ebf3ee4f19b62a97a7762507cb1782ba799fccf56884018db6bcdcbaf7129
+SIZE (relay-0.4.src.tar.gz) = 123977
diff --git a/games/quake2-relay/pkg-descr b/games/quake2-relay/pkg-descr
new file mode 100644
index 000000000000..f967e749c3f2
--- /dev/null
+++ b/games/quake2-relay/pkg-descr
@@ -0,0 +1,17 @@
+Have you ever wanted more from a Quake2 demo? Tired of making every
+player record demos of your clan matches just to see everything? Now
+your problems are over (well not all, but..). With Quake2 Relay, you
+can record entire matches and play them back through the Replay
+module. Unlike client demos, which only record a match through one
+player's view, relay demos can record everything in the level for the
+entire duration of the match. With Replay, you can watch these matches
+through any player's perspective, chase-cam mode, or free-fly mode.
+
+Benefits of Relay:
+
+ - Every player's perspective is recorded
+ - No lag
+ - Smaller and easier than many separate demos
+ - Many different viewing options
+
+WWW: http://www.planetquake.com/relay/