aboutsummaryrefslogtreecommitdiff
path: root/games/quake2lnx/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-08-09 13:28:18 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-08-09 13:28:18 +0000
commita61d65d14b0d89ac4d89a8b6252f1e63b3f339ae (patch)
tree8f80a0a062a3e1d873311de3e240fa1131951d49 /games/quake2lnx/Makefile
parent540084f486a70c82937f463de2d9f573aa4aa9ea (diff)
downloadports-a61d65d14b0d89ac4d89a8b6252f1e63b3f339ae.tar.gz
ports-a61d65d14b0d89ac4d89a8b6252f1e63b3f339ae.zip
- Some time ago, original (non-SDL) client executable started to yield
choppy sound (when using standard OSS API). It happens because the SNDCTL_DSP_GETOSPACE ioctl() was issued before setting other important parameters; to remedy the problem, it should be moved below the mmap() call. While here, cleanup few more potential problems: avoid using AFMT_S16_LE as it would break on big-endian machines, align mmap()'ed buffer to the page size, and fix resource leaks here and there. - In the port's Makefile: bump PORTREVISION and convert USE_GMAKE Submitted by: Ozkan Sezer (via icculus.org quake2 mailing list)
Notes
Notes: svn path=/head/; revision=324435
Diffstat (limited to 'games/quake2lnx/Makefile')
-rw-r--r--games/quake2lnx/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/games/quake2lnx/Makefile b/games/quake2lnx/Makefile
index dd82baed6904..1d8ece26ee23 100644
--- a/games/quake2lnx/Makefile
+++ b/games/quake2lnx/Makefile
@@ -3,7 +3,7 @@
PORTNAME= quake2lnx
PORTVERSION= 0.16.2
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= games ipv6
MASTER_SITES= http://offload1.icculus.org/quake2/files/
DISTNAME= quake2-r${PORTVERSION}
@@ -16,7 +16,7 @@ COMMENT= Icculus.org version of the original Quake II
LICENSE= GPLv2
-USE_GMAKE= yes
+USES= gmake
WANT_SDL= yes
ALL_TARGET= build_release