aboutsummaryrefslogtreecommitdiff
path: root/games/quake2max
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /games/quake2max
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
- update png to 1.5.10
Notes
Notes: svn path=/head/; revision=297915
Diffstat (limited to 'games/quake2max')
-rw-r--r--games/quake2max/Makefile4
-rw-r--r--games/quake2max/files/patch-ref_gl__sul_png.c11
2 files changed, 13 insertions, 2 deletions
diff --git a/games/quake2max/Makefile b/games/quake2max/Makefile
index f8b499aed7db..c26dcf6b2a16 100644
--- a/games/quake2max/Makefile
+++ b/games/quake2max/Makefile
@@ -7,7 +7,7 @@
PORTNAME= quake2max
PORTVERSION= 0.45
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= games
MASTER_SITES= http://qudos.quakedev.com/linux/quake2/engines/Quake2MaX/:src \
${MASTER_SITE_LOCAL:S/$/:data/}
@@ -48,7 +48,7 @@ Q2MAX_DATA= ${PORTNAME}.044.rar
.if defined(WITH_GLX) || defined(WITH_SDLGL)
LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg \
- png.6:${PORTSDIR}/graphics/png
+ png15:${PORTSDIR}/graphics/png
USE_GL= yes
.endif
diff --git a/games/quake2max/files/patch-ref_gl__sul_png.c b/games/quake2max/files/patch-ref_gl__sul_png.c
new file mode 100644
index 000000000000..9061bd5a9a32
--- /dev/null
+++ b/games/quake2max/files/patch-ref_gl__sul_png.c
@@ -0,0 +1,11 @@
+--- ref_gl/sul_png.c.orig 2005-12-27 10:57:45.000000000 +0100
++++ ref_gl/sul_png.c 2012-04-29 06:53:31.000000000 +0200
+@@ -177,7 +177,7 @@
+ return;
+ }
+
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ png_destroy_write_struct(&png_ptr, &info_ptr);
+ free(rgbdata);