aboutsummaryrefslogtreecommitdiff
path: root/games/quake3-data
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-05-12 08:06:32 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-05-12 08:06:32 +0000
commit9752f9ac9754718fcf1046e29c071474a69e749e (patch)
tree36fe9bc878683842de3c4779e9a7645be41dba81 /games/quake3-data
parent459303bbf89ffb7d06079da088a4cc1b4961fb93 (diff)
downloadports-9752f9ac9754718fcf1046e29c071474a69e749e.tar.gz
ports-9752f9ac9754718fcf1046e29c071474a69e749e.zip
If port is setting PKGNAMEPREFIX=${FOOPKGNAMEPREFIX}, but .include's this
file before <bsd.port.options.mk>, options handling gets broken because options will be loaded from OPTIONSFILE which is based on UNIQUENAME and thus PKGNAMEPREFIX, which is empty at that point. Prevent this: ensure that FOOPKGNAMEPREFIX is defined in advance for ports that use it to set their PKGNAMEPREFIX and having OPTIONS.
Notes
Notes: svn path=/head/; revision=317934
Diffstat (limited to 'games/quake3-data')
-rw-r--r--games/quake3-data/Makefile.include4
1 files changed, 4 insertions, 0 deletions
diff --git a/games/quake3-data/Makefile.include b/games/quake3-data/Makefile.include
index dbd7ff998c07..7c9dd4e9216c 100644
--- a/games/quake3-data/Makefile.include
+++ b/games/quake3-data/Makefile.include
@@ -4,6 +4,10 @@
Q3PKGNAMEPREFIX?= quake3-
Q3DIR?= ${LOCALBASE}/share/quake3
+.if ${PKGNAMEPREFIX} == ${Q3PKGNAMEPREFIX} && defined(OPTIONSMKINCLUDED)
+. error include before <bsd.port.options.mk> if using Q3PKGNAMEPREFIX
+.endif
+
MAKE_ENV+= Q3DIR="${Q3DIR}"
PLIST_SUB+= Q3DIR="${Q3DIR:S/${LOCALBASE}\///}"
SUB_LIST+= Q3DIR="${Q3DIR}"