aboutsummaryrefslogtreecommitdiff
path: root/games/quake3
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-10-20 04:51:17 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-10-20 04:51:17 +0000
commit49d6f10fafee6ab99a06aad488e65134b68dc60d (patch)
treee5415a40a506dfa1477fa41e176f66337e8a9806 /games/quake3
parentd20c1b85f4cf3db3e82ab739fd2c5f5c77425482 (diff)
downloadports-49d6f10fafee6ab99a06aad488e65134b68dc60d.tar.gz
ports-49d6f10fafee6ab99a06aad488e65134b68dc60d.zip
- Fix build on 10 [1]
- Update MASTER_SITES [1] - Add stage support PR: ports/183074 Submitted by: Linas Valiukas <shirshegsm@gmail.com> (maintainer) [1]
Notes
Notes: svn path=/head/; revision=330975
Diffstat (limited to 'games/quake3')
-rw-r--r--games/quake3/Makefile17
-rw-r--r--games/quake3/files/patch-code-Construct11
-rw-r--r--games/quake3/files/patch-code-botlib-linux-i386.mak11
-rw-r--r--games/quake3/files/patch-code-bspc-Makefile11
-rw-r--r--games/quake3/files/patch-code-bspc-linux-i386.mak11
-rw-r--r--games/quake3/files/patch-code-qcommon-vm_x86.c11
-rw-r--r--games/quake3/files/patch-code-unix-Makefile32
7 files changed, 81 insertions, 23 deletions
diff --git a/games/quake3/Makefile b/games/quake3/Makefile
index 71974fff7b23..19c2b2de3809 100644
--- a/games/quake3/Makefile
+++ b/games/quake3/Makefile
@@ -3,13 +3,11 @@
PORTNAME= quake3
PORTVERSION= 1.32c
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
-MASTER_SITES= http://www.proarena.com/p/ftpx/x8524/quake_3_arena/ \
- http://www.planetgargoyle.com/ \
- http://www.teamdarkside.net/ \
- http://0day.icculus.org/mirrors/quake3/ \
- http://www.olpainless.net/files/ \
+MASTER_SITES= ftp://mancubus.net/pub/idgames/idstuff/source/ \
+ http://ftp.mancubus.net/pub/idgames/idstuff/source/ \
+ http://www.gamers.org/pub/idgames/idstuff/source/ \
${MASTER_SITE_IDSOFTWARE:S|$|source/|}
DISTNAME= ${PORTNAME}-${REALVERSION}-source
@@ -42,7 +40,6 @@ LIBDIR= ${PREFIX}/lib/${PORTNAME}
REALVERSION= 1.32b
VM_ARCHS= i386 powerpc
-NO_STAGE= yes
.include <bsd.port.options.mk>
.include <bsd.port.pre.mk>
@@ -111,12 +108,12 @@ post-patch:
do-install:
.for bin in ${Q3BIN}
- ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/release/${bin} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/release/${bin} ${STAGEDIR}${PREFIX}/bin
.endfor
.if ${PORT_OPTIONS:MGAMELIBS} || !defined(HAVE_VM_COMPILED)
.for dir in baseq3 missionpack
- ${MKDIR} ${LIBDIR}/${dir}
- ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/release/${dir}/*.so ${LIBDIR}/${dir}
+ ${MKDIR} ${STAGEDIR}${LIBDIR}/${dir}
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/release/${dir}/*.so ${STAGEDIR}${LIBDIR}/${dir}
.endfor
.endif
diff --git a/games/quake3/files/patch-code-Construct b/games/quake3/files/patch-code-Construct
new file mode 100644
index 000000000000..dc06efb802d4
--- /dev/null
+++ b/games/quake3/files/patch-code-Construct
@@ -0,0 +1,11 @@
+--- code/Construct.orig 2013-10-18 02:05:36.000000000 +0300
++++ code/Construct 2013-10-18 02:05:53.000000000 +0300
+@@ -237,7 +237,7 @@
+ }
+ else
+ {
+- $BASE_CFLAGS = $COMMON_CFLAGS . '-DNDEBUG -O6 -mcpu=pentiumpro -march=pentium -fomit-frame-pointer -ffast-math -malign-loops=2 -malign-jumps=2 -malign-functions=2 -fno-strict-aliasing -fstrength-reduce ';
++ $BASE_CFLAGS = $COMMON_CFLAGS . '-DNDEBUG -O2 -mcpu=pentiumpro -march=pentium -fomit-frame-pointer -ffast-math -malign-loops=2 -malign-jumps=2 -malign-functions=2 -fno-strict-aliasing -fstrength-reduce ';
+ $BSPC_BASE_CFLAGS = $BASE_CFLAGS . '-DLINUX -DBSPC -Dstricmp=strcasecmp ';
+ }
+
diff --git a/games/quake3/files/patch-code-botlib-linux-i386.mak b/games/quake3/files/patch-code-botlib-linux-i386.mak
new file mode 100644
index 000000000000..c4bf258b38aa
--- /dev/null
+++ b/games/quake3/files/patch-code-botlib-linux-i386.mak
@@ -0,0 +1,11 @@
+--- code/botlib/linux-i386.mak.orig 2013-10-18 02:02:20.000000000 +0300
++++ code/botlib/linux-i386.mak 2013-10-18 02:02:35.000000000 +0300
+@@ -8,7 +8,7 @@
+ BASE_CFLAGS=-Dstricmp=strcasecmp
+
+ #use these cflags to optimize it
+-CFLAGS=$(BASE_CFLAGS) -m486 -O6 -ffast-math -funroll-loops \
++CFLAGS=$(BASE_CFLAGS) -m486 -O2 -ffast-math -funroll-loops \
+ -fomit-frame-pointer -fexpensive-optimizations -malign-loops=2 \
+ -malign-jumps=2 -malign-functions=2
+ #use these when debugging
diff --git a/games/quake3/files/patch-code-bspc-Makefile b/games/quake3/files/patch-code-bspc-Makefile
new file mode 100644
index 000000000000..f3944ebdbe65
--- /dev/null
+++ b/games/quake3/files/patch-code-bspc-Makefile
@@ -0,0 +1,11 @@
+--- code/bspc/Makefile.orig 2013-10-18 02:04:52.000000000 +0300
++++ code/bspc/Makefile 2013-10-18 02:05:03.000000000 +0300
+@@ -12,7 +12,7 @@
+ BASE_CFLAGS=-Dstricmp=strcasecmp
+
+ #use these cflags to optimize it
+-CFLAGS=$(BASE_CFLAGS) -m486 -O6 -ffast-math -funroll-loops \
++CFLAGS=$(BASE_CFLAGS) -m486 -O2 -ffast-math -funroll-loops \
+ -fomit-frame-pointer -fexpensive-optimizations -malign-loops=2 \
+ -malign-jumps=2 -malign-functions=2 -DLINUX -DBSPC
+ #use these when debugging
diff --git a/games/quake3/files/patch-code-bspc-linux-i386.mak b/games/quake3/files/patch-code-bspc-linux-i386.mak
new file mode 100644
index 000000000000..1b0e21df708e
--- /dev/null
+++ b/games/quake3/files/patch-code-bspc-linux-i386.mak
@@ -0,0 +1,11 @@
+--- code/bspc/linux-i386.mak.orig 2013-10-18 02:04:04.000000000 +0300
++++ code/bspc/linux-i386.mak 2013-10-18 02:04:18.000000000 +0300
+@@ -8,7 +8,7 @@
+ BASE_CFLAGS=-Dstricmp=strcasecmp
+
+ #use these cflags to optimize it
+-CFLAGS=$(BASE_CFLAGS) -m486 -O6 -ffast-math -funroll-loops \
++CFLAGS=$(BASE_CFLAGS) -m486 -O2 -ffast-math -funroll-loops \
+ -fomit-frame-pointer -fexpensive-optimizations -malign-loops=2 \
+ -malign-jumps=2 -malign-functions=2 -DLINUX -DBSPC
+ #use these when debugging
diff --git a/games/quake3/files/patch-code-qcommon-vm_x86.c b/games/quake3/files/patch-code-qcommon-vm_x86.c
new file mode 100644
index 000000000000..e333be546668
--- /dev/null
+++ b/games/quake3/files/patch-code-qcommon-vm_x86.c
@@ -0,0 +1,11 @@
+--- code/qcommon/vm_x86.c.orig 2013-10-18 02:26:13.000000000 +0300
++++ code/qcommon/vm_x86.c 2013-10-18 02:26:30.000000000 +0300
+@@ -84,7 +84,7 @@
+ #endif // !_WIN32
+
+
+-static int callMask = 0; // bk001213 - init
++static int __attribute__((used)) callMask = 0; // bk001213 - init
+
+ static int instruction, pass;
+ static int lastConst = 0;
diff --git a/games/quake3/files/patch-code-unix-Makefile b/games/quake3/files/patch-code-unix-Makefile
index 56eb13a14c4f..9ef59a791aa5 100644
--- a/games/quake3/files/patch-code-unix-Makefile
+++ b/games/quake3/files/patch-code-unix-Makefile
@@ -1,5 +1,5 @@
---- code/unix/Makefile.orig Sun Jun 4 18:13:21 2006
-+++ code/unix/Makefile Sun Jun 4 18:14:42 2006
+--- code/unix/Makefile.orig 2013-10-18 02:01:30.000000000 +0300
++++ code/unix/Makefile 2013-10-18 02:07:18.000000000 +0300
@@ -34,7 +34,7 @@
# Build name
@@ -29,12 +29,18 @@
# bk010215 - TODO - add all defaults / kill Ryan
-@@ -136,7 +136,7 @@
+@@ -131,12 +131,12 @@
+ # DEBUG_CFLAGS=$(BASE_CFLAGS) -g -Wall -O
+ ifeq ($(ARCH),axp)
+ CC=pgcc
+- RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG -O6 -ffast-math -funroll-loops -fomit-frame-pointer -fexpensive-optimizations
++ RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG -O2 -ffast-math -funroll-loops -fomit-frame-pointer -fexpensive-optimizations
+ else
ifeq ($(ARCH),ppc)
NEWPGCC=/loki/global/ppc/bin/gcc
CC=$(NEWPGCC)
- RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG -O6 -fomit-frame-pointer -pipe -ffast-math -malign-loops=2 -malign-jumps=2 -malign-functions=2 -fno-strict-aliasing -fstrength-reduce
-+ RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG -O6 -fomit-frame-pointer -pipe -ffast-math -falign-loops=2 -falign-jumps=2 -falign-functions=2 -fno-strict-aliasing -fstrength-reduce
++ RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG -O2 -fomit-frame-pointer -pipe -ffast-math -falign-loops=2 -falign-jumps=2 -falign-functions=2 -fno-strict-aliasing -fstrength-reduce
else
#NEWPGCC=/usr/local/gcc-2.95.2/bin/gcc # bk001205
#NEWPGCC=/loki/global/x86/bin/gcc
@@ -43,10 +49,10 @@
# NOTE: the -fomit-frame-pointer option leads to an unstable binary on my test box if it was built on the main box
# but building on the Mdk 7.2 baseline seems to work
- RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG -O6 -mcpu=pentiumpro -march=pentium -fomit-frame-pointer -pipe -ffast-math -malign-loops=2 -malign-jumps=2 -malign-functions=2 -fno-strict-aliasing -fstrength-reduce
-+ RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG -O6 -fomit-frame-pointer -pipe -ffast-math -falign-loops=2 -falign-jumps=2 -falign-functions=2 -fno-strict-aliasing -fstrength-reduce
++ RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG -O2 -fomit-frame-pointer -pipe -ffast-math -falign-loops=2 -falign-jumps=2 -falign-functions=2 -fno-strict-aliasing -fstrength-reduce
# TTimo: use this for building on P3 gcc 2.95.3 libc2.2 for all targets (experimental! -fomit-fram-pointer removed)
-# RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG -O6 -mcpu=pentiumpro -march=pentium -pipe -ffast-math -malign-loops=2 -malign-jumps=2 -malign-functions=2 -fno-strict-aliasing -fstrength-reduce
-+# RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG -O6 -pipe -ffast-math -falign-loops=2 -falign-jumps=2 -falign-functions=2 -fno-strict-aliasing -fstrength-reduce
++# RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG -O2 -pipe -ffast-math -falign-loops=2 -falign-jumps=2 -falign-functions=2 -fno-strict-aliasing -fstrength-reduce
endif
endif
@@ -89,9 +95,9 @@
-GL_CFLAGS = -I$(MESADIR)/include -I/usr/X11R6/include
+ifdef OPTIMIZED_CFLAGS
+ ifeq ($(ARCH),i386)
-+RELEASE_CFLAGS+=-O6 -fomit-frame-pointer -pipe -ffast-math -falign-loops=2 -falign-jumps=2 -falign-functions=2 -fno-strict-aliasing -fstrength-reduce
++RELEASE_CFLAGS+=-O2 -fomit-frame-pointer -pipe -ffast-math -falign-loops=2 -falign-jumps=2 -falign-functions=2 -fno-strict-aliasing -fstrength-reduce
+ else
-+RELEASE_CFLAGS+=-O6 -ffast-math -funroll-loops -fomit-frame-pointer -fexpensive-optimizations
++RELEASE_CFLAGS+=-O2 -ffast-math -funroll-loops -fomit-frame-pointer -fexpensive-optimizations
+ endif
+endif
@@ -230,10 +236,7 @@
$(B)/client/linux_glimp.o \
$(B)/client/linux_snd.o \
+ $(B)/client/linux_signals.o \
- $(B)/client/snd_mixa.o \
-- $(B)/client/matha.o \
-- $(B)/client/ftol.o \
-- $(B)/client/snapvector.o
++ $(B)/client/snd_mixa.o \
+ $(B)/client/matha.o
+
+ Q3POBJ_SMP=\
@@ -242,7 +245,10 @@
+ $(B)/client/linux_glimp_smp.o \
+ $(B)/client/linux_snd.o \
+ $(B)/client/linux_signals.o \
-+ $(B)/client/snd_mixa.o \
+ $(B)/client/snd_mixa.o \
+- $(B)/client/matha.o \
+- $(B)/client/ftol.o \
+- $(B)/client/snapvector.o
+ $(B)/client/matha.o
+
+ ifeq ($(ARCH),i386)