aboutsummaryrefslogtreecommitdiff
path: root/games/quake3
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-11-23 12:00:47 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-11-23 12:00:47 +0000
commit6db26ba974644717e439058b4c65ca3a69ac9882 (patch)
treedc91268ea2582590643753822db59bfa6e46aa4e /games/quake3
parent3305e65662631fdb15ce4e5cd641295636735f87 (diff)
downloadports-6db26ba974644717e439058b4c65ca3a69ac9882.tar.gz
ports-6db26ba974644717e439058b4c65ca3a69ac9882.zip
- Force use of a higher GCC version
- Include digest::md5 for perl on 4.x - Add BUILD_ENV to make sure that do-build works fine - Fix files/patch-code-unix-cons to understand $ENV{CC} and friends - Fix files/patch-code-qcommon-common.c to include sys/types.h Noticed by: YAPHR
Notes
Notes: svn path=/head/; revision=149171
Diffstat (limited to 'games/quake3')
-rw-r--r--games/quake3/Makefile13
-rw-r--r--games/quake3/files/patch-code-Construct15
-rw-r--r--games/quake3/files/patch-code-qcommon-common.c8
-rw-r--r--games/quake3/files/patch-code-unix-cons20
4 files changed, 40 insertions, 16 deletions
diff --git a/games/quake3/Makefile b/games/quake3/Makefile
index 41846d782d2f..00dad03d14da 100644
--- a/games/quake3/Makefile
+++ b/games/quake3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= quake3
PORTVERSION= 1.32b
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= ftp://ftp.idsoftware.com/idstuff/source/ \
http://www.proarena.com/p/ftpx/x8524/quake_3_arena/ \
@@ -27,9 +27,16 @@ USE_GMAKE= yes
USE_REINPLACE= yes
USE_PERL5_BUILD=yes
USE_GL= yes
+USE_GCC= 3.2+
PLIST_FILES= bin/q3ded bin/quake3
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|%%Q3DIR%%|"${Q3DIR}"|' \
${WRKSRC}/code/unix/unix_shared.c
@@ -38,7 +45,7 @@ pre-build:
${MKDIR} ${WRKSRC}/lcc/build
do-build:
- cd ${WRKSRC}/code && ${PERL} unix/cons
+ cd ${WRKSRC}/code && ${MAKE_ENV} ${PERL} unix/cons
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/code/install/linuxq3ded \
@@ -47,4 +54,4 @@ do-install:
${PREFIX}/bin/quake3
.include "${.CURDIR}/../quake3-data/Makefile.include"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/quake3/files/patch-code-Construct b/games/quake3/files/patch-code-Construct
index 21b6c1d5ab76..e9e859985f18 100644
--- a/games/quake3/files/patch-code-Construct
+++ b/games/quake3/files/patch-code-Construct
@@ -1,5 +1,5 @@
---- code/Construct Mon Aug 15 23:56:27 2005
-+++ ../../work/quake3-1.32b/code/Construct Sun Aug 28 23:13:56 2005
+--- /work/a/ports/games/quake3/work/quake3-1.32b/code/Construct.orig Mon Aug 15 20:56:27 2005
++++ /work/a/ports/games/quake3/work/quake3-1.32b/code/Construct Wed Nov 23 10:37:04 2005
@@ -19,8 +19,8 @@
use Cons_gcc;
@@ -11,6 +11,17 @@
$do_masterserver = 0;
$do_authserver = 0;
$do_authport = 0;
+@@ -32,8 +32,8 @@
+ $DO_WIN32 = 0;
+ $NO_VM = 0;
+ $NO_SO = 0;
+-$CC='gcc';
+-$CXX='g++';
++$CC=$ENV{CC};
++$CXX=$ENV{CXX};
+
+ # detect an sdk build (don't attempt client build and other things)
+ if ( -r 'unix/Conscript-client' )
@@ -63,9 +63,9 @@
else
{
diff --git a/games/quake3/files/patch-code-qcommon-common.c b/games/quake3/files/patch-code-qcommon-common.c
index 94164ed41b01..9db06e6c63a5 100644
--- a/games/quake3/files/patch-code-qcommon-common.c
+++ b/games/quake3/files/patch-code-qcommon-common.c
@@ -1,11 +1,11 @@
-diff -ruN ./code/qcommon/common.c ../quake3-1.32b-BUILT/./code/qcommon/common.c
---- ./code/qcommon/common.c Tue Aug 16 02:10:07 2005
-+++ ../quake3-1.32b-BUILT/./code/qcommon/common.c Mon Aug 22 21:03:32 2005
-@@ -24,15 +24,7 @@
+--- code/qcommon/common.c.orig Mon Aug 15 23:10:07 2005
++++ code/qcommon/common.c Wed Nov 23 10:53:29 2005
+@@ -24,15 +24,8 @@
#include "../game/q_shared.h"
#include "qcommon.h"
#include <setjmp.h>
-#ifdef __linux__
++#include <sys/types.h>
#include <netinet/in.h>
-#else
-#if defined(MACOS_X)
diff --git a/games/quake3/files/patch-code-unix-cons b/games/quake3/files/patch-code-unix-cons
index 71d5fac4ad93..f62b3d8eb9ed 100644
--- a/games/quake3/files/patch-code-unix-cons
+++ b/games/quake3/files/patch-code-unix-cons
@@ -1,15 +1,21 @@
-diff -ruN ./code/unix/cons ../quake3-1.32b-BUILT/./code/unix/cons
---- ./code/unix/cons Fri Jun 14 15:01:32 2002
-+++ ../quake3-1.32b-BUILT/./code/unix/cons Tue Aug 23 14:21:45 2005
-@@ -271,7 +271,7 @@
+--- /work/a/ports/games/quake3/work/quake3-1.32b/code/unix/cons.orig Fri Jun 14 13:01:32 2002
++++ /work/a/ports/games/quake3/work/quake3-1.32b/code/unix/cons Wed Nov 23 10:32:49 2005
+@@ -271,11 +271,11 @@
# Defaults for a typical (?) UNIX platform.
# Your mileage may vary.
'unix' => [
- 'CC' => 'cc',
-+ 'CC' => 'gcc',
- 'CFLAGS' => '',
+- 'CFLAGS' => '',
++ 'CC' => $ENV{CC},
++ 'CFLAGS' => $ENV{CFLAGS},
'CCCOM' => '%CC %CFLAGS %_IFLAGS -c %< -o %>',
- 'CXX' => '%CC',
+- 'CXX' => '%CC',
+- 'CXXFLAGS' => '%CFLAGS',
++ 'CXX' => $ENV{CXX},
++ 'CXXFLAGS' => $ENV{CXXFLAGS},
+ 'CXXCOM' => '%CXX %CXXFLAGS %_IFLAGS -c %< -o %>',
+ 'INCDIRPREFIX' => '-I',
+ 'INCDIRSUFFIX' => '',
@@ -294,7 +294,7 @@
'LD' => 'ld',
'LDFLAGS' => '',