aboutsummaryrefslogtreecommitdiff
path: root/games/quakeforge
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-01-20 17:22:27 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-01-20 17:22:27 +0000
commit18ebf7811d9079864c33f421c33e399d0bf31338 (patch)
tree74e4abe7fc5b8a9e67ed098d610601d5a4494535 /games/quakeforge
parentc78fe46fff156b7810f1c45ac769993e0b986273 (diff)
downloadports-18ebf7811d9079864c33f421c33e399d0bf31338.tar.gz
ports-18ebf7811d9079864c33f421c33e399d0bf31338.zip
- Fix building (last commit for -fPIC broke it: some code is compiled twice,
so there is a conditional code compilation checking for -DPIC, but the code in the static library later goes into a shared one, so use -fPIC but no -DPIC in that case, because otherwise there would be redefined symbols). Reported by: pointyhat
Notes
Notes: svn path=/head/; revision=182865
Diffstat (limited to 'games/quakeforge')
-rw-r--r--games/quakeforge/files/patch-libs__video__renderer__sw__Makefile.in16
1 files changed, 3 insertions, 13 deletions
diff --git a/games/quakeforge/files/patch-libs__video__renderer__sw__Makefile.in b/games/quakeforge/files/patch-libs__video__renderer__sw__Makefile.in
index 6fd5eb615889..d9e0b5df3b48 100644
--- a/games/quakeforge/files/patch-libs__video__renderer__sw__Makefile.in
+++ b/games/quakeforge/files/patch-libs__video__renderer__sw__Makefile.in
@@ -1,23 +1,13 @@
--- ./libs/video/renderer/sw/Makefile.in.orig Sun May 2 17:52:12 2004
-+++ ./libs/video/renderer/sw/Makefile.in Fri Jan 12 23:26:27 2007
++++ ./libs/video/renderer/sw/Makefile.in Sat Jan 20 12:17:37 2007
@@ -403,8 +403,8 @@
target_vendor = @target_vendor@
vid_libs = @vid_libs@
AUTOMAKE_OPTIONS = foreign
-AM_CFLAGS = @PREFER_NON_PIC@
-AM_CCASFLAGS = @PREFER_NON_PIC@
-+AM_CFLAGS = @PREFER_PIC@
-+AM_CCASFLAGS = @PREFER_PIC@
++AM_CFLAGS = -fPIC
++AM_CCASFLAGS = -fPIC
INCLUDES = -I$(top_srcdir)/include
@ASM_ARCH_FALSE@asm =
@ASM_ARCH_TRUE@asm = libasm.la
-@@ -422,9 +422,7 @@
- sw_redge.c sw_rmain.c sw_rmisc.c sw_rpart.c sw_rsky.c sw_rsprite.c \
- sw_rsurf.c sw_skin.c
-
--libasm_la_LDFLAGS = @STATIC@
- libasm_la_SOURCES = $(asm_src)
--libsw_la_LDFLAGS = @STATIC@
- libsw_la_SOURCES = $(sw_src)
- @ASM_ARCH_TRUE@libsw_la_LIBADD = $(asm)
- @ASM_ARCH_TRUE@libsw_la_DEPENDENCIES = $(asm)