aboutsummaryrefslogtreecommitdiff
path: root/games/quakeforge
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-03-08 11:32:11 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-03-08 11:32:11 +0000
commit9250d94365048cf854570d93b5196aa250eba8f0 (patch)
tree9c130b083139cc77280c7e96cc9cea75a84d2d4c /games/quakeforge
parent09fa4f371396ff884f3845939561bfc786faf491 (diff)
downloadports-9250d94365048cf854570d93b5196aa250eba8f0.tar.gz
ports-9250d94365048cf854570d93b5196aa250eba8f0.zip
Convert USE_BISON to USES= bison
It brings bison as a build dependency in case it is set the following way: USES= bison or USES= bison:build it brings bison as a run dependency in case it is set the following way: USES= bison:run it brings bison both as a run and build dependency in case it the set the following way: USES= bison:both While here trim some headers Convert some USE_GNOME= gnomehack to USES= pathfix
Notes
Notes: svn path=/head/; revision=313635
Diffstat (limited to 'games/quakeforge')
-rw-r--r--games/quakeforge/Makefile50
1 files changed, 25 insertions, 25 deletions
diff --git a/games/quakeforge/Makefile b/games/quakeforge/Makefile
index ccbe61001acc..6e8534fa8c34 100644
--- a/games/quakeforge/Makefile
+++ b/games/quakeforge/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: QuakeForge
-# Date created: 4 January 2000
-# Whom: darius@dons.net.au
-#
+# Created by: darius@dons.net.au
# $FreeBSD$
-#
PORTNAME= quakeforge
PORTVERSION= 0.5.5
@@ -21,7 +17,7 @@ NOT_FOR_ARCHS= sparc64
NOT_FOR_ARCHS_REASON= generated Quake C compiler (qfcc) does not work
USE_AUTOTOOLS= libtool
USE_BZIP2= yes
-USE_BISON= build
+USES= bison
USE_GMAKE= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -31,13 +27,17 @@ CONFIGURE_ARGS+=--with-global-cfg=${PREFIX}/etc/quakeforge.conf \
--with-sharepath=${DATADIR} \
--disable-optimize
-OPTIONS= CLIENTS "Build clients" on \
- OPTIMIZED_CFLAGS "Enable compilation optimizations" on \
- SDL "Build SDL client" off \
- SERVERS "Build dedicated servers" on \
- SKYBOXES "Install skyboxes pak" off \
- VORBIS "Enable Ogg Vorbis support in clients" off \
- XMMS "Enable XMMS support in clients" off
+OPTIONS_DEFINE= CLIENTS OPTIMIZED_CFLAGS SDL SERVERS SKYBOXES VORBIS \
+ XMMS DOCS
+
+OPTIONS_DEFAULT= CLIENTS OPTIMIZED_CFLAGS SERVERS DOCS
+
+CLIENTS_DESC= Clients
+SDL_DESC= SDL client
+SERVERS_DESC= Dedicated servers
+SKYBOXES_DESC= Install skyboxes pak
+VORBIS_DESC= Ogg Vorbis support in clients
+XMMS_DESC= XMMS support in clients
MAN1= pak.1 qfcc.1 qflight.1 qfvis.1 wad.1
SUB_FILES= pkg-message
@@ -46,14 +46,14 @@ DATADIR= ${Q1DIR}
.include "${.CURDIR}/../quake-data/Makefile.include"
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_CLIENTS)
+.if ${PORT_OPTIONS:MCLIENTS}
USE_GL= yes
USE_XORG= x11 xt
PLIST_SUB+= CLIENTS=""
-.if defined(WITH_SDL)
+.if ${PORT_OPTIONS:MSDL}
USE_SDL= sdl
CONFIGURE_ARGS+=--with-sdl=${LOCALBASE}
PLIST_SUB+= SDL=""
@@ -62,7 +62,7 @@ CONFIGURE_ARGS+=--disable-sdl
PLIST_SUB+= SDL="@comment "
.endif
-.if defined(WITH_VORBIS)
+.if ${PORT_OPTIONS:MVORBIS}
LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
CONFIGURE_ARGS+=--with-ogg=${LOCALBASE} --with-vorbis=${LOCALBASE}
PLIST_SUB+= VORBIS=""
@@ -71,7 +71,7 @@ CONFIGURE_ARGS+=--disable-ogg --disable-vorbis
PLIST_SUB+= VORBIS="@comment "
.endif
-.if defined(WITH_XMMS)
+.if ${PORT_OPTIONS:MXMMS}
LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
CONFIGURE_ARGS+=--with-xmms-prefix=${LOCALBASE}
PLIST_SUB+= XMMS=""
@@ -83,9 +83,9 @@ PLIST_SUB+= XMMS="@comment "
.else
CONFIGURE_ARGS+=--with-clients=""
PLIST_SUB+= CLIENTS="@comment "
-.endif # WITH_CLIENTS
+.endif
-.if !defined(WITHOUT_OPTIMIZED_CFLAGS)
+.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
CFLAGS+= -O3 -funroll-loops -fomit-frame-pointer -fno-common \
-fexpensive-optimizations -fstrict-aliasing
. if ${ARCH} != "alpha"
@@ -93,14 +93,14 @@ CFLAGS+= -ffast-math
. endif
.endif
-.if !defined(WITHOUT_SERVERS)
+.if ${PORT_OPTIONS:MSERVERS}
PLIST_SUB+= SERVERS=""
.else
CONFIGURE_ARGS+=--with-servers=""
PLIST_SUB+= SERVERS="@comment "
.endif
-.if defined(WITH_SKYBOXES)
+.if ${PORT_OPTIONS:MSKYBOXES}
MASTER_SITES+= http://www.quakeforge.net/files/:qf
DISTFILES+= skyboxes.pak:qf
PLIST_SUB+= SKYBOXES=""
@@ -109,10 +109,10 @@ PLIST_SUB+= SKYBOXES="@comment "
.endif
post-install:
-.if defined(WITH_SKYBOXES)
+.if ${PORT_OPTIONS:MSKYBOXES}
${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/skyboxes.pak ${DATADIR}/QF
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
. for f in *.txt *.q1 *.q2 *.ico *.gif *.fig *.h CodingStyle
${INSTALL_DATA} ${WRKSRC}/doc/${f} ${DOCSDIR}
@@ -123,4 +123,4 @@ post-install:
.endif
@${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>